BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-16-2008, 09:51 AM   #1 (permalink)
No longer Registered.
 
Join Date: Apr 2007
Model: 8800
PIN: N/A
Carrier: T-Mobile
Posts: 105
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Blackberry 8800 does not fully charge. Stuck at 65%

Please Login to Remove!

Anyone have any ideas? I just got the phone used from some guy. Seems kinda shady--the sticker inside was ripped off (behind the battery). It's a Cingular branded 8800. Anyway the battery life through the system info is 65% and when I try to charge it, the little plug icon shows up as if its charging, then goes off a second later, refusing to charge further than 65%. Any ideas??
Offline  
Old 04-16-2008, 09:52 AM   #2 (permalink)
No longer Registered.
 
Join Date: Apr 2007
Model: 8800
PIN: N/A
Carrier: T-Mobile
Posts: 105
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

And this is after a 4.2.1 os install. Did this right when I got the phone so I dont know if it happened before.
Offline  
Old 04-16-2008, 10:17 AM   #3 (permalink)
BBF Moderator
 
akosnitzky's Avatar
 
Join Date: Jul 2005
Location: Southern Florida
Model: 9650
OS: 6.0.0.333
Carrier: Verizon BIS
Posts: 14,484
Post Thanks: 6
Thanked 7 Times in 7 Posts
Default

Wirelessly posted (Verizon 8830)

I hope its just the battery. Have you tried plugging it to your Desktop Manager? , as well as to an electrical outlet?
__________________
------
Follow @akosnitzky on Twitter

LET'S GO CANES!

Last edited by akosnitzky : 04-16-2008 at 10:17 AM.
Offline  
Old 04-16-2008, 11:30 AM   #4 (permalink)
BlackBerry Extraordinaire
 
kjjb0204's Avatar
 
Join Date: Jul 2007
Location: USA
Model: 9630
Carrier: VZW
Posts: 1,813
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

What charger are you using? If it doesn't deliver the proper current, the bb charging icon turns on when you plug in, then turns back off and doesn't charge. Try another charger.
Offline  
Old 04-16-2008, 12:37 PM   #5 (permalink)
EPIC MOD
 
ezrunner's Avatar
 
Join Date: Mar 2006
Location: Virginia Beach
Model: ZED10
OS: DOS 3.1
PIN: INK STICK
Carrier: Tmobile
Posts: 12,214
Post Thanks: 9
Thanked 6 Times in 6 Posts
Default

Wirelessly posted (life goes on! yes it is tough)

Could be a bad battery
__________________
ZED 10
Offline  
Old 04-17-2008, 09:14 AM   #6 (permalink)
Thumbs Must Hurt
 
darkdragoon's Avatar
 
Join Date: Sep 2005
Location: Hong Kong SAR
Model: 9000
OS: 5.0.0.464
PIN: 2562425C
Carrier: SmarTone-Vodafone
Posts: 198
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ezrunner View Post
Wirelessly posted (life goes on! yes it is tough)

Could be a bad battery
I second that.
__________________
|)ark|)ragooN
BB experience from 5820 > 7730 > 7290 > 8707v > 8800 > 9000
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.