BlackBerry Forums Support Community               

Closed Thread
LinkBack Thread Tools
Old 05-17-2008, 11:28 PM   #1 (permalink)
New Member
Join Date: Apr 2008
Model: 8700c
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 8700c quit working

Please Login to Remove!

My blackberry 8700c quit working tonight.....nothing. I didn't drop it or anything. I was weedeating tonight & had it clipped to my belt, when I got through it wouldn't work, and it was working just fine before. I removed the battery, replaced it, but still nothing. I plugged it into the charger & got a quick flash, but nothing else happened. It's like it has some kind of a short. Was wondering if possibly the vibration from the weedeater could have done something to it. Any help would be appreciated. Thanks.
Old 05-27-2008, 11:06 AM   #2 (permalink)
Knows Where the Search Button Is
nathandees's Avatar
Join Date: Oct 2007
Model: 8830
Carrier: Sprint
Posts: 29
Post Thanks: 0
Thanked 0 Times in 0 Posts

I've never experienced anything like that with any 8700. I've always found them (and the 7100's) to be the most durable of all BB's. You may try gently cleaning the battery connectors and make sure there wasn't a build-up of dust from the weedeating.
Old 05-27-2008, 02:00 PM   #3 (permalink)
New Member
Join Date: May 2008
Location: Toronto
Model: 8703e
Carrier: Telus
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts

How long did you have it in the charger?
Aingaran Thirunadarajah
QWiX Network Solutions, Inc.
1.416.333.3368 | 1.888.779.2774
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Copyright 2004-2014
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.