BlackBerry Forums Support Community

BlackBerry Forums Support Community (
-   General Legacy Device Discussion (
-   -   Using ApplicationPermissionsManager in non RIM J2ME code (

airan 05-22-2008 06:39 AM

Using ApplicationPermissionsManager in non RIM J2ME code
I am using J2ME(no rim api, only j2me apis) for my app and the app is targeted at devices including blackberry.
But whenever i use any restricted api, it prompts for user permission.
Point to note is it only happens on a particular model of blackberry on CDMA network happens only on 8830 which i bought from reliance store in india .
Other blackberry handsets bought from reliance store like 8703e dont ask for any permissions ..
Question1: Why the prompts are coming only on a particular model.
Question 2: Is there a way to get rid of these prompts/
Question 3: Can applicationPermissionsManager class help in this regard(again, no rim code, only J2ME code).

airan 05-23-2008 01:40 AM

I have posted the same question in dev forum expecting faster response ..You may choose to delete it from here ..!

All times are GMT -5. The time now is 07:47 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.