BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-21-2008, 03:18 AM   #1 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8700g
PIN: N/A
Carrier: Bharti Airtel
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default OS Upgrade qs

Please Login to Remove!

Hi,

I bought a blackberry device last month from e-bay(T-Mobile Hungary).

I upgraded the OS to version 4.2.1.* with the device software provided by my service provide(Bharti Airtel India). But after that I am getting a connectivity error. It is saying that "Data connection refused".

I went to the customer care service and found out that the problem is with my device. What should I do now?

My question is as the device is from T-Mobile Hungary which device software should I use, the current service provider Bharti Airtel or T-Mobile Hungary.

Thanks,
Paritosh.
Offline  
Old 06-21-2008, 07:02 AM   #2 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: iPh6
Carrier: AT&T
Posts: 27,813
Post Thanks: 33
Thanked 442 Times in 382 Posts
Default

Data Connection Refused means that you do not have a BlackBerry Data Plan. It has nothing to do with the device. Customer Care was (shocking) wrong.

The device software does not matter. It is all written by RIM.
Offline  
Old 06-21-2008, 11:06 AM   #3 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8700g
PIN: N/A
Carrier: Bharti Airtel
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Clarification...

Hi,

I do have a data plan activated.

I talked with the Customer Care people. They told me that as I am getting edge in small letter I am getting the error message "Data connection refused".

The customer care guy tried my SIM in a spare blackberry device and there it worked. He got EDGE in the spare blackberry device, but when I tried again I got small edge on my device.

When I bought it and activated the data plan it worked well for some days. In one bad day I upgraded the OS to 4.2.* with the OS software provided in Bharti Airtel's site. Since that day the blackberry data service stopped working and got the error message.

What is the problem now. I think there is some problem with the OS I installed.

Thanks,
Paritosh.
Offline  
Old 06-21-2008, 11:46 AM   #4 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,035
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

First try pulling the battery for about 30 seconds and see if that works. If not, have your carrier reactivate the BB dataplan and resend the service books.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 06-21-2008, 01:07 PM   #5 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8700g
PIN: N/A
Carrier: Bharti Airtel
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

I have tried it all. After that I went to the customer care center where the customer care guy tried my SIM card in another blackberry device, and it worked well. But when I put my SIM in my own device it stopped working.

He told me that there is some problem with my device and no problem whatsoever from their side. As the handset is from T-Mobile he refused to fix the hardware/device issue.

Is there any other option that I can try.

Thanks ppl,
Paritosh.
Offline  
Old 06-21-2008, 01:16 PM   #6 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Do you have a BlackBerry Data Plan. Not a "data plan" but a BlackBerry Data Plan?
Offline  
Old 06-21-2008, 01:41 PM   #7 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8700g
PIN: N/A
Carrier: Bharti Airtel
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah, I do have a data plan and my blackberry was working fine before the OS upgrade, but after the upgrade it stopped working.

Thanks,
Paritosh.
Offline  
Old 06-21-2008, 01:46 PM   #8 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

I didn't ask if it had "a data plan", but ok.

Then maybe you need to downgrade to the OS that worked well.
Here you go: How do I downgrade the OS on my BlackBerry? - BlackBerryFAQ
Offline  
Old 06-22-2008, 05:02 AM   #9 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8700g
PIN: N/A
Carrier: Bharti Airtel
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

Sorry, I missed "blackberry" in my previous reply. I do have a blackberry dataplan(6 month unlimited plan).

I tried to downgrade it to earlier version, but that didn't fix the issue. Then I asked the customer care guy to reinstall the OS for me. He told that the software they have wont work in my case as it is from T-Mobile.

I will try to downgrade my OS.

As someone pointed out earlier, there is no difference between different OS provided by different service providers, then why does all the service providers provide the link for the OS to download. Everyone can dload the OS from blackberry site itself. Just curious.

Thanks,
Paritosh.
Offline  
Old 06-22-2008, 06:31 AM   #10 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Perhaps you need to try another SIM card in your BlackBerry. I know you said your SIM works well in another BlackBerry, but still, try another in yours. Or get that other device for your own.

This really doesn't appear to be an OS problem.
Offline  
Old 06-22-2008, 10:29 AM   #11 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8700g
PIN: N/A
Carrier: Bharti Airtel
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

I did try putting another working sim in my blackberry device, but it didn't work in my device.

When I went to the customer care center after calling them for a week, the customer care guy tried my SIM in a spare blackberry they have and it worked in the spare blackberry. After that he tried my device with a spare SIM they have for testing, but it didn't work for my device.

He told me that there might be some problem with my device and as the blackberry handset is from T-Mobile he denied to fix it.

I have no idea what might be the problem.

Thanks for the replies,
Paritosh.
Offline  
Old 06-23-2008, 04:20 AM   #12 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8700g
PIN: N/A
Carrier: Bharti Airtel
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

I downgraded the OS to 4.1.0.284, but I am still getting the same error.

Please help.

Thanks,
Paritosh.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.