BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-23-2008, 01:06 AM   #1 (permalink)
New Member
 
nifty5's Avatar
 
Join Date: Dec 2007
Model: 9630
OS: hybrid 5.
PIN: N/A
Carrier: telus
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default can't upgrade "net.rim.platform.ecmascript" error

Please Login to Remove!

Hi,

I now have way to many grey hairs while trying to upgrade my 8830 to 4.5

When I get to the stage of loading the new F/W, I have this error message blocking any moving forward.

"the application "BlackBerry PGP Email Library can not be loaded, because it requires the following applications that are not available. "net.rim.platform.ecmascript"

This has me sitting here with no clue what to do next. I have used the JL program to wipe the unit and reloaded the 4.2 that I had on there before.

Anyone had this same problem or can offer some advice?

Thanks,

Mike

Last edited by nifty5 : 07-23-2008 at 11:08 AM.
Offline  
Old 07-30-2008, 07:35 AM   #2 (permalink)
CrackBerry Addict
 
qc_metal's Avatar
 
Join Date: Mar 2005
Location: Rockford, IL
Model: 9530
OS: 4.7.x
Carrier: Verizon
Posts: 590
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm also having this issue trying to update to 4.5.

Not sure what is up, but I'm currently sitting at 4.2 drooling for HTML mail.
__________________
Provision, maintain, and report on users via web: the NEW BerryStats | FAQ
Offline  
Old 07-30-2008, 09:43 AM   #3 (permalink)
CrackBerry Addict
 
qc_metal's Avatar
 
Join Date: Mar 2005
Location: Rockford, IL
Model: 9530
OS: 4.7.x
Carrier: Verizon
Posts: 590
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ahhh - probably because we are trying to install a GPRS OS on a CDMA phone?

I modified my alx files so that it included 'CDMA' along with 'GPRS' (platform.alx, blackberry.alx). In addition, I changed the platform.alx OS node to:

Code:
                <os radio="CDMA" series="8700" Colour="True" Theme="Normal" JVMLevel="1.0" Memory="Large" VoiceNotes="True" KeyboardType="Qwerty" SystemSize="normal" MMS="True" Sound="Tunes7130c" Bluetooth="True">CDMA/rim8703c.sfi</os>
and then copied the CDMA/rim8703c.sfi folder/file from my own OS installation for 4.2 to the 4.5 folder...and of course, deleting the vendor.xml file.

While this made it possible to install the OS on my Sprint 8703, it did not work at ALL. The device kept taunting me with the hourglass of dispair, and I am now downgrading back to 4.2.

Oh well
__________________
Provision, maintain, and report on users via web: the NEW BerryStats | FAQ
Offline  
Old 08-09-2008, 05:26 PM   #4 (permalink)
New Member
 
nifty5's Avatar
 
Join Date: Dec 2007
Model: 9630
OS: hybrid 5.
PIN: N/A
Carrier: telus
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

You are right, wrong OS.

Have to wait for the official 4.5 for my carrier.

Mike
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.