BlackBerry Forums Support Community
              

Closed Thread
 
LinkBack Thread Tools
Old 09-02-2008, 05:14 PM   #1 (permalink)
Thumbs Must Hurt
 
John-Fox's Avatar
 
Join Date: Apr 2005
Location: Louisville, KY
Model: 9000
OS: 4.6.0.167
Carrier: AT&T Mobility
Posts: 80
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question Wi-Fi on 8820 / Belkin Router

Please Login to Remove!

Stats:
BB 8820 (v4.5.0.55)
Belkin Wireless G + MIMO Router (firmware 5.01.16) (hardware F5D9230-4 v5000)

I cannot maintain a wi-fi connection for much longer than 20 minutes. It is up. It is down. Sometimes restarting the BB will get it back, sometimes not. Wirelessly, I have a laptop and an Xbox that maintains a connection perfectly.

I have had wi-fi off for days until I decided to make this post, and of course now it is connected, so I cannot quote errors verbatim. But, I just turned wi-fi off and back on and now I get the error ... DHCP server is unreachable. But, then a few minutes later, it connected on its own. *sigh*

Can someone shed some light for me. Is this a common BlackBerry problem, or do I need to tweak settings on the router, the device, or what?

I write this as I sit on the line of driving five hours to Chicago to try out a Nokia E71 instead of waiting on the Bold. I love me some BlackBerry, but I am nervous about some issues.

Any help is appreciated. Anyone that thinks they can troubleshoot with me, I will be glad to respond to questions about my current settings.

Thanks!
Offline  
Old 09-02-2008, 11:27 PM   #2 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,715
Post Thanks: 6
Thanked 115 Times in 82 Posts
Default

I have heard there are issues with MIMO routers with the wifi on BB's.
Offline  
Old 09-07-2008, 04:42 PM   #3 (permalink)
Thumbs Must Hurt
 
John-Fox's Avatar
 
Join Date: Apr 2005
Location: Louisville, KY
Model: 9000
OS: 4.6.0.167
Carrier: AT&T Mobility
Posts: 80
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I sure hope this will be addressed in someway, someday by someone.
Offline  
Old 09-07-2008, 04:45 PM   #4 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,715
Post Thanks: 6
Thanked 115 Times in 82 Posts
Default

Many issues with wifi compatibility have been addressed with OS 4.5.
Offline  
Old 09-07-2008, 04:47 PM   #5 (permalink)
Thumbs Must Hurt
 
John-Fox's Avatar
 
Join Date: Apr 2005
Location: Louisville, KY
Model: 9000
OS: 4.6.0.167
Carrier: AT&T Mobility
Posts: 80
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by John Clark View Post
Many issues with wifi compatibility have been addressed with OS 4.5.
Eeek! And that is what I have on this 8820 right now.
Offline  
Old 09-07-2008, 07:11 PM   #6 (permalink)
Latino Hasta La Muerte
 
rambo47's Avatar
 
Join Date: Jan 2005
Location: Denville, NJ.
Model: 9370
Carrier: Verizon
Posts: 9,062
Post Thanks: 52
Thanked 311 Times in 296 Posts
Default

I have no problems with my 8820 and basic Verizon FiOS router. It's a piece of crap router but my 8820 holds the signal well. I've also used my 8820 with a LinkSys router and had no problems. Ditch the Belkin.
Offline  
Old 09-07-2008, 07:30 PM   #7 (permalink)
No longer Registered.
 
Join Date: Jan 2007
Model: 8900
OS: 4.6.1.199
Carrier: None
Posts: 2,622
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

do firewall on your router? i was having the same issue with signal dropping, but once i openned up the firewall on the router everything worked flawlessly
Offline  
Old 09-08-2008, 05:51 PM   #8 (permalink)
Thumbs Must Hurt
 
mb978n's Avatar
 
Join Date: Aug 2008
Location: jax
Model: 8820
PIN: 248e3c5
Carrier: At&t
Posts: 52
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have a similar issue to what you are having however my router password requires WAP2 and i do not have that listed on my connection wizard for my 8820 with 4.5. so i used PSK and it connects maybe for 15 mins.. dies... and comes back. Any thoughts?
Offline  
Old 09-09-2008, 05:43 AM   #9 (permalink)
Thumbs Must Hurt
 
Join Date: Dec 2006
Model: 8320
OS: Vista SP1
Carrier: T-mobile
Posts: 75
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I was using a Belkin with great success for the past 5 weeks...that is after I upgraded the firmware. Not sure if you're using UMA, but check this link.
__________________
MuzikFetish
Offline  
Old 09-09-2008, 11:16 AM   #10 (permalink)
Thumbs Must Hurt
 
John-Fox's Avatar
 
Join Date: Apr 2005
Location: Louisville, KY
Model: 9000
OS: 4.6.0.167
Carrier: AT&T Mobility
Posts: 80
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

No, I am not using UMA, and my Belkin's fireware has no updates available. I am looking around in the router for a firewall option now, reference Cory's post.
Offline  
Old 09-09-2008, 11:57 AM   #11 (permalink)
Thumbs Must Hurt
 
John-Fox's Avatar
 
Join Date: Apr 2005
Location: Louisville, KY
Model: 9000
OS: 4.6.0.167
Carrier: AT&T Mobility
Posts: 80
Post Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs down Blah!

I have tried everything. One of the two devices is junk!!
Offline  
Old 09-09-2008, 06:49 PM   #12 (permalink)
Thumbs Must Hurt
 
mb978n's Avatar
 
Join Date: Aug 2008
Location: jax
Model: 8820
PIN: 248e3c5
Carrier: At&t
Posts: 52
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

on our network we use a cisco AP and i connect to it with PSK since its WPA2 secured.. i also frequently drop my connection and it reaquires its self... really strange...
Offline  
Old 09-09-2008, 07:01 PM   #13 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,715
Post Thanks: 6
Thanked 115 Times in 82 Posts
Default

Quote:
Originally Posted by John-Fox View Post
I have tried everything. One of the two devices is junk!!
Let's see....Belkin or Blackberry? Not hard to figure out since my wifi/uma works great.
Offline  
Old 09-10-2008, 01:37 AM   #14 (permalink)
Thumbs Must Hurt
 
John-Fox's Avatar
 
Join Date: Apr 2005
Location: Louisville, KY
Model: 9000
OS: 4.6.0.167
Carrier: AT&T Mobility
Posts: 80
Post Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Finally!!

So I went out today and bought a Linksys WRT54G2 router. Works perfect with my 8820. Patched!!

The MIMO'ing Belkin goes back to Wal-Mart!
Offline  
Old 09-10-2008, 01:40 AM   #15 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,715
Post Thanks: 6
Thanked 115 Times in 82 Posts
Default

That's what I figured.
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.