BlackBerry Forums Support Community               

Closed Thread
LinkBack Thread Tools
Old 09-09-2008, 09:03 PM   #1 (permalink)
Knows Where the Search Button Is
Join Date: Jan 2006
Model: 9000
Carrier: AT&T
Posts: 21
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Unable to upgrade 8700c to 4.5

Please Login to Remove!

After repeated attempts using various official versions from A4.5.0.37 to the latest A4.5.0.55 from PCCW (I need Asian language support) I have not been able to upgrade to 4.5. The symptom is the same, it stuck at the step of re-connecting to the device just before restoring, with a black display with blinking red signal light. After the timeout period it displays some such thing as needing a password. I remember this was reported early by a few posters when 4.5 first came out. Blindly entering the password or pulling battery to reset doesn't help, it's as though the display wasn't turned on for some reason.

I tried many different things including device wipe using Jl_cmdr but with the same results. I am always able to recover by reloading 4.2.1 however.

Any ideas?

it's a good thing that 8700c is my secondary phone. My primary with BES is a 8820 and I am staying with 4.2.2 on it for now.

Old 10-05-2008, 11:20 PM   #2 (permalink)
Knows Where the Search Button Is
Join Date: Sep 2007
Model: 8320
Carrier: T-Mobile
Posts: 30
Post Thanks: 0
Thanked 0 Times in 0 Posts

I've had the same issue when trying to upgrade my 8700c to any of the versions of 4.5. It will actually go through the whole installation process, but it turns on, and it has the single red blinking light every 20 seconds or so. The phone will not turn on at all until I reinstall 4.2 OS. Anyone have any ideas?
Old 10-06-2008, 12:07 AM   #3 (permalink)
Crimson Tide Moderator
JSanders's Avatar
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,909
Post Thanks: 60
Thanked 244 Times in 182 Posts

I've upgraded two 8700s to OS 4.5 without a hitch.
Old 10-07-2008, 06:27 PM   #4 (permalink)
Thumbs Must Hurt
jimmyh's Avatar
Join Date: Nov 2006
Location: Vidalia, Louisiana
Model: 9810
Carrier: AT&T
Posts: 79
Post Thanks: 1
Thanked 3 Times in 3 Posts

I have upgraded my 8700c to and the only problem I have is I lost my BB browser. I'm on AT&T. Haven't had any problems yet.....
Old 10-08-2008, 11:04 AM   #5 (permalink)
Talking BlackBerry Encyclopedia
Join Date: Dec 2007
Model: 8830
Carrier: Sprint
Posts: 293
Post Thanks: 0
Thanked 0 Times in 0 Posts

Wipe your device first with JL_Cmder and then try the upgrade, of course you need to do a backup first to be on the safe side
Old 11-18-2008, 11:51 PM   #6 (permalink)
New Member
Join Date: Nov 2008
Model: 8700c
PIN: 247649A6
Carrier: ATT
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts

I am on ATT I tried endlessly to upgrade to 4.5 on my laptop with Vista, then I tried another lap top I have XP on and installed desktop v4.6 and then downloaded the v4.5 handheld software and it worked without a hitch.
Old 11-19-2008, 12:03 AM   #7 (permalink)
iPhone Mod!
zerog46's Avatar
Join Date: May 2007
Location: In a House
Model: 9650
Carrier: VZW Bold
Posts: 6,761
Post Thanks: 21
Thanked 7 Times in 7 Posts

Here is your Vista fix: Fix Discovered for OS Upgrade Gone Haywire! |
Life is not holding a good hand. Life is playing a poor hand well.
Closed Thread

« nsada | Att Os 4.5 »

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Copyright 2004-2014
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.