BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-11-2008, 10:40 PM   #1 (permalink)
New Member
 
Join Date: Sep 2008
Location: New Haven, CT
Model: 8800
OS: 4.5.0.187
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Setup 8700c on TMOB, no data plan

Please Login to Remove!

I just picked up an unlocked Cingular-branded 8700c that I'd like to use on T-Mobile. But I don't need push email or any other BB-specific features, I just wanted it for a decent screen and a QWERTY keyboard.

I had TMOB Web on my old Razr and it did everything I needed, but the lack of a QWERTY keyboard was really annoying.

I popped in my SIM and I can place/receive calls. But there seems to be a lot of setup to do, and I was hoping somebody might have done this before and have some tips.

For starters, the phone seems to think that it's in another area code. I have to dial the AC even for local calls. Also, I've done some searches and it looks like some folks have installed the TMOB 8700g software to get T-Mobile branding (except for the ROM-based Cingular splash screens) and access to T-Zones. But it seems like in some cases installing it could cause the BB to become locked to Cingular again.

I guess there's a lot of debate over whether not not T-Zones or T-Mobile Web (the $5.99 plan) can be used for WAP access, either with the built-in browser or with Opera Mini. If it can't, this puppy's going back, because that's why I bought it.

I'm having some trouble installing Desktop Manager too, I get a “Database server not found. Verify the provided information” error.

If anybody has actually set up their 8700c on TMOB without a data plan and can help me out with any of this, I sure would be grateful.

TIA, Arjay
Offline  
Old 09-11-2008, 11:03 PM   #2 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

The OS installed has nothing to do with what services are pushed to the device. That's the sim card's job.

Go to the Phone app. Then click the wheel and select Options and go to Smart Dialing. Enter your area code in there. You may still need to dial the area code, though.

You can use wap access but you need to go to Options >Advanced Options >TCP and enter TMo's apn there.

apn:wap.voicestream.com
username
password

username/password stay blank.
Offline  
Old 09-11-2008, 11:03 PM   #3 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

And there is no way to lock the device to a carrier again. Once it's unlocked it's unlocked for life.
Offline  
Old 09-12-2008, 12:17 AM   #4 (permalink)
New Member
 
Join Date: Sep 2008
Location: New Haven, CT
Model: 8800
OS: 4.5.0.187
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks, John. You resolved my area code problem just like that <snaps fingers>.

I put in the apn info, but I can't open my browser, or for that matter, any apps. The convenience key doesn't do anything, and if I go to "help" and try to open the BB help site, I get an error message telling my that I don't have any Browser Configuration Service Book Entries. I checked and there aren't any Service Book entries at all.

Any ideas?
Offline  
Old 09-12-2008, 12:19 AM   #5 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

You may need to use Opera Mini as I don't think any of the other browsers will work.
Offline  
Old 09-12-2008, 12:37 AM   #6 (permalink)
New Member
 
Join Date: Sep 2008
Location: New Haven, CT
Model: 8800
OS: 4.5.0.187
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Okay, that makes sense. As soon as I can get Desktop Manager working, I'll install Opera Mini.

Any idea why the "convenience key" doesn't work? Must be a setting I'm missing somewhere, no?
Offline  
Old 09-12-2008, 12:41 AM   #7 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

The convenience key only works for what you set it for in screen/keyboard. However, if you set it for browser and there is no browser service book then nothing can open.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.