BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-21-2008, 09:10 PM   #1 (permalink)
New Member
 
Join Date: Dec 2005
Model: 8800
Carrier: Rogers
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Angry 8800 Not Working

Please Login to Remove!

I have a rogers 8800. Upgraded to bold so had it in storage. Today I took it out, put a battery in and does not work. I get a battery symbol witha red line across it. What happened? The only thing i did is i put in the SIM in the wrong way (tried to anyway) then got it right.

Other than that nothing has been done since I stored it. Is the BB now FUBAR'd and an expensive paper weight?

Is there anything I cando? Any and all help is appreicated!

Regards,

G

Last edited by gokulesh : 12-21-2008 at 11:06 PM.
Offline  
Old 12-22-2008, 01:38 AM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Jan 2007
Location: Hanoi
Model: 8xGSM
PIN: FFFFFFFF
Carrier: VNM and Viettel, VN Mobifone
Posts: 28
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

don't scare, I think this's only a bad connection beetwen battery and your phone. Try to clean 4 points in its battery slot, or replace battery for many times. Hope you fix problem.
Offline  
Old 12-22-2008, 01:55 PM   #3 (permalink)
New Member
 
Join Date: Dec 2005
Model: 8800
Carrier: Rogers
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Angry 8800 Not working

Quote:
Originally Posted by Phuongcv View Post
don't scare, I think this's only a bad connection beetwen battery and your phone. Try to clean 4 points in its battery slot, or replace battery for many times. Hope you fix problem.

Thanks. I tried, that but it did not work. I have replaced with 3 different battries, and the same message. Note I checked the battries on the 8700 and they all work fine.

Hopefully other readers can provide some direction. With not many replies though I begining to wonder.

G.
Offline  
Old 12-22-2008, 04:01 PM   #4 (permalink)
BlackBerry Master
 
djm2's Avatar
 
Join Date: Jul 2007
Model: 9780
PIN: N/A
Carrier: T-Mobile
Posts: 4,652
Post Thanks: 34
Thanked 14 Times in 14 Posts
Default

Have you tried wiping the device and reloading the OS?
Offline  
Old 12-22-2008, 11:27 PM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Jan 2007
Location: Hanoi
Model: 8xGSM
PIN: FFFFFFFF
Carrier: VNM and Viettel, VN Mobifone
Posts: 28
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

If you try whit different batteries and the phone not work, I think it's a hardware failure. In my local servire, this error can be fix within 30 minutes. You should bring the phone to nearest service.
Offline  
Old 12-28-2008, 03:36 PM   #6 (permalink)
New Member
 
Join Date: Dec 2005
Model: 8800
Carrier: Rogers
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Smile 8800 Not Working - Fixed!

Thanks to all who replied.

Before I get to what fixed it - answer to one of the suggestion re: wiping the device - I never got to a point where it would allow me to do that.

Now for the feeling stupid / duh part: I have a 8700 as well and multiple battries. I tried the 8700 battries and since they fit perfectly I did not clue in to the fact that it was the wrong type. The 8700 battries are blue in colour and the 8800 are green!! How stupid can I get!

Anyway I was speaking with the nice folks from new horizon wireless to unlock my bold and he asked me to verify the colour and that I might be using the wrong battrey! Sure enough when I put the in the right battery (like duh!) it worked.

Once again folks thanks to all.

Regards,

G
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.