BlackBerry Forums Support Community               

Closed Thread
LinkBack Thread Tools
Old 05-21-2009, 11:56 PM   #1 (permalink)
New Member
Join Date: May 2009
Model: 7290
Carrier: Rogers
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 7290 Only Starts when plugged in

Please Login to Remove!

I have a Blackberry 7290, the handset itself is brand new but the battery that it came with looks used ( the unit was purchased on ebay ).

The problem I m having is that when the phone is on it works great...however if i pull the batteryand reinstall it the unit will not power back on until it is plugged in..even though the battery contains a charge.

Is this an issue anyone else has experienced? Is it hardware related?

I went ahead and ordered a new battery but i m hoping the handset itself isn't damaged.
Old 05-22-2009, 07:11 AM   #2 (permalink)
BBF Moderator
akosnitzky's Avatar
Join Date: Jul 2005
Location: Southern Florida
Model: 9650
Carrier: Verizon BIS
Posts: 14,484
Post Thanks: 6
Thanked 7 Times in 7 Posts

Wirelessly posted (Its All About the U!)

Hmmm. Seems like a hardware issue. Return it.
Follow @akosnitzky on Twitter

Old 05-22-2009, 07:45 AM   #3 (permalink)
BlackBerry God
aiharkness's Avatar
Join Date: Jul 2005
Location: Florida Panhandle
Model: BBPP
OS: 10.3.2
Carrier: T-Mobile USA
Posts: 13,871
Post Thanks: 18
Thanked 521 Times in 505 Posts

A new 7290?
- Ira
Old 05-23-2009, 04:53 PM   #4 (permalink)
BlackBerry Extraordinaire
david9962000's Avatar
Join Date: May 2007
Location: Los Angeles, CA
Model: 9360
Carrier: at&t
Posts: 1,377
Post Thanks: 0
Thanked 0 Times in 0 Posts

Bad battery?
BlackBerry user since the 7230.
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Copyright 2004-2014
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.