BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   General Legacy Device Discussion (http://www.blackberryforums.com/general-legacy-device-discussion/)
-   -   Known problem with contact sync on an 8700g (http://www.blackberryforums.com/general-legacy-device-discussion/33047-known-problem-contact-sync-8700g.html)

matty5490 04-24-2006 09:43 AM

Known problem with contact sync on an 8700g
 
Hey all, I'm newly registered and I just wanted to share what happened last week

I do freelance consulting for small businesses. Last week one of my clients got an 8700g from Tmobile to replace his 7230 (which was hurting from lots of heavy use). The user is somewhat of a power user where he has a very busy schedule, two assistants and travels everywhere. He also has over 7000 contacts (yes, seven thousand). Many of these contacts are badly entered with phone numbers in address fields and other strange things. But it hasnt been a problem really until the 8700 came along.
the client has MS Exchange server in house with the Enterprise server running 3.6. All users run Outlook 2003.

So every other time I have upgraded a blackberry, I basically unplug the old one, plug in the new one and sync it. The sync usually takes a long time, but thats about as complicated as it gets. Every once in a while I'll update the desktop sync software...

So I go to sync the device, and it gets through about 3000 contacts and it gives the error [cant read or write application data] (I'll post the exact KB article later, cant find the link right now)
So when faced with this, I upgrade the BB desktop to newest version on their site... Same error. :-o
OK, Then I uninstalled desktop and installed the BB Desktop version on the CD that came with it... same error
This is when I found the KB article stating that you cannot have any special characters in any name fields. So I quickly went through and looked for & $ * ? etc in the frequently used fields in the 7000 contacts. At that point I was like $#&%*# (cursing)
Of course I made a backup of the contacts folder before I did all the above.

So.... at this point I'm sure it must be the fact that I'm running BES 3.6 So I upgrade the server from 3.6 to 4.0 (No small task)... So that disrupts all the users, but I needed to do it anyway and its done, so that wasnt so bad. Anyway, SAME PROBLEM.

I finally called them and since we have Tsupport it was really easy to get someone on the phone. (I should have said I was having a problem with the BES instead of the desktop because then I wouldn't have been transferred to India.) The indian tech dude walked me through deleting the intellisync folder and creating a contact on the BB to see if it would sync. At this point the sync process was only getting to the 4th contact before it crapped out with the error.
So the Blackberry tech guy (who was not bad for an Indian dude) puts me on hold, and then he comes back and says I need to go through and remove all special characters from the 'name' and 'company name' fields in outlook. And that this is a known issue with the 8700g and he's sorry for the inconvenience blah blah.

At that point I was pissed because I had already been there for a long time and my client is like WTF is taking so long (I do hourly billing).... So the pressure is ON.

I sent someone out to go buy a 7290 while I stayed and worked on the 8700g. I exported all the contacts to an excel file and started doing a search and replace. There were tons of periods and dashes and slashes, so I was removing all of them, and its hard, and excel wants to remove ALL the periods from the whole contact database (including email address ARGH) So, about the time I get finished, the 7290 arrives, and I sync the whole thing with no problems.

SO, I just wanted to let you all know, sorry for the long winded post but I wanted to share what happened so you can avoid it. If you have thousands of contacts, I would stick with the 7290 until a patch comes out for the 8700g.

I think its F'd up that T-Mobile and RIM would release the device knowing about a problem like this. I have a friend who has it and she loves it, so its obviously not a major problem...

I'll track down the exact KB articles later.

matty5490 04-24-2006 05:23 PM

here's the article
 
well, I can't post a clickable URL unless I have posted 10 times...
so the article number is KB-00729
Support - Unable to write or update application data

CBR900RR 04-24-2006 05:41 PM

Here you go.

http://www.blackberry.com/knowledgec...25621&vernum=9


Support - Unable to write or update application data
Last Updated: 08 April 2005
Article Number: KB-00729


--------------------------------------------------------------------------------

Summary
This article applies to the following:

BlackBerry® Desktop Software versions 2.1 to 4.0
BlackBerry Wireless Handhelds™
Microsoft® Windows® 2000
Microsoft Outlook®
IBM® Lotus Notes®


--------------------------------------------------------------------------------

Problem
You receive the following message when synchronizing personal information management (PIM) data between your handheld and personal computer:

Unable to write or update application data.

Summary of Causes
This error message is caused by one of the following:

Not enough storage space on the handheld.
Invalid characters in name or address fields.
Handheld database is corrupted
Cause 1 - Not enough storage space on the handheld
The handheld does not have enough space to synchronize PIM data with the personal computer.

Resolution
Create more space on the handheld by reducing the range of days with Intellisync. If you require additional storage space, you can also remove applications from the handheld with Application Loader.

Note: Back up the data on your handheld with the Backup and Restore tool in Desktop Manager before proceeding.

Reduce the range of days using Intellisync:

Reducing the range of days restricts the number of appointments or events being transferred to the handheld. You can choose to transfer all items to your handheld, transfer only future items, or transfer items which fall between a range of days. Reducing the range of days will increase the amount of space on the handheld.

Connect your handheld to your personal computer. Double-click Intellisync.
Open Configure PIM and select Calendar.
In the Configure drop-down menu and select Advanced Settings.
In the Date Range tab, reduce the range of days.
Remove Applications from the handheld:

Connect your handheld to your personal computer. Double-click Application Loader. The Application Loader Wizard opens. Click Next.
Enter your password in the Password field. Click Next.
In the Handheld Application Selection area, uncheck the applications you want to remove from your handheld. Click Next.
Click Finish. This will remove the application(s) from your handheld.

--------------------------------------------------------------------------------

Cause 2 - Invalid characters in name or address fields
There are invalid characters such as +, $ or % in the name or address fields of address book entries. The handheld is only able to read text. Any symbols appearing in the name or address fields are considered invalid characters and will cause the error.

Resolution
Ensure that there are no invalid characters in the name or address fields of address book entries.

Open the Address Book on the handheld and select entries with invalid characters.
Remove any symbols or invalid characters in the name or address fields.

--------------------------------------------------------------------------------

Cause 3 - Handheld database is corrupted
The handheld database or information on the handheld is corrupted.

Resolution
Clear the corrupted handheld database:

Connect the handheld to your personal computer. Double click Backup and Restore > Advanced.
Select the database for the application where the error occurred and click Clear. For more information on how to determine the corrupt application, see Support Knowledge Base article KB-03069.


--------------------------------------------------------------------------------

Additional Information
If the above procedures do not resolve the issue, erase and reload handheld data and applications.

To erase handheld data and applications:

Back up your handheld using the Backup and Restore tool.
Erase all handheld data and applications. For more about this, see Support Knowledge Base article KB-02318.
To restore handheld applications and data:

Connect your handheld to your personal computer. Double-click Backup and Restore. The Backup and Restore window opens.
Click Restore. Select the backup file that you created before erasing your handheld data and applications.
Click Open. This will restore your handheld applications and data.


--------------------------------------------------------------------------------

Keywords
unable, write, application, desktop, manager, calendar

agentthor 04-24-2006 05:43 PM

I was right there with you over the weekend, Matty
 
Here was my solution:

The Tmobile rep walked me through how to do a log of my intellisync. i went into the log file and found the contact that intellisync was quitting on. They were surprised to find out that it wasn't a $ # or unusual character - there was nothing unusual about the contact at all. When I deleted it and retyped the same info into a new contact, it synced fine.

Good luck

stealthx32 04-25-2006 03:48 AM

(y) for T-Mo support.

matty5490 04-25-2006 11:30 AM

cool.
thanks for the info...

I have a feeling though that it will quit on many contacts. who knows how many have the mysterious problem out of the 7100 contacts. if it was 10, thats bearable, but what if there's a mysterious problem with 100 contacts...

I would have to retype them all? Yikes.

my client is happy with the 7290 so, I guess I'll wait until this one breaks.
If it was me, then I'd go through with it, of course, I only have 200 contacts....

glad to know someone else went through the same thing.

Radio Flyer 04-25-2006 11:39 AM

I haven't gotten my 8700g yet (later this week) but I had similar problems in the past with older BB units. Happened several times when migrating from one unit to the next in my past corporate lives...

SMR 04-25-2006 03:07 PM

I have approximately 1,400 contacts and had the same problem toward the end of my first synch. I only noticed recently that many of my Outlook contacts are not on my Blackberry (but were on my 7230). I guess I'll try TMobile support to see if they can walk me through the Intellisynch logs?

Paul King 04-26-2006 09:46 AM

Thanks to O2 synch with outlook 2003 and 8700g works
 
Having upgraded to my fourth BB I was surprised to find that 4.1 would not would pick up my outlook pab folder and clicking on the browse button would simply give an hour glass for 5 seconds and then fail.

Thanks to really nice helpful and professional young lady called Asma on the Data Support with O2 its now working.

Have a look here, because I could not post a URL please add the usuall blackberry.com/ then add /knowledgecenterpublic/livelink.exe/fetch/2000/8021/7919/8125/Support_-_MS_Outlook_is_missing,_invalid_or_points_to_a_fil e_of_zero_length.html?nodeid=154079&vernum=10

I think this will get around the link issue ;-0

Best wishes and thanks for this forum, it's a great facility.
Kind regards
Paul


All times are GMT -5. The time now is 07:16 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.