BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-08-2006, 08:57 AM   #1 (permalink)
New Member
 
Join Date: Sep 2005
Model: 7100r
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default My Number not displaying?

Please Login to Remove!

Not sure why the "My Number: Unknown" is displayed as unknown in the phone display section. It's a new blackberry and my other unit shows the number. The sim card is working as I can make calls and under Phone Options/General/Show "My Number" is ticked Yes. Anyone have any suggestions? I am on the Rogers Canada network. Thanks.
Offline  
Old 07-08-2006, 09:31 AM   #2 (permalink)
CrackBerry Addict
 
K-Mack's Avatar
 
Join Date: Apr 2006
Location: San Antonio
Model: 8700c
Carrier: Cingular
Posts: 592
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (8700c: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0) BlackBerry8700/4.1.0 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/102)

Possibly remove and re-install battery if you haven't tried yet.
__________________
8700c
Samsung Wep 200 Headset
Offline  
Old 07-08-2006, 09:38 AM   #3 (permalink)
New Member
 
Join Date: Sep 2005
Model: 7100r
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks. Tried that and no change. Very strange. It shows on all our other blackberries.
Offline  
Old 07-08-2006, 09:55 AM   #4 (permalink)
BlackBerry Extraordinaire
 
DallasFlier's Avatar
 
Join Date: Feb 2006
Location: Dallas, TX
Model: 9800
OS: 6.0.0.666
PIN: OT NOIR
Carrier: AT&T/Cingular/AT&T
Posts: 1,741
Post Thanks: 30
Thanked 20 Times in 15 Posts
Default

Mine was that way when I first got it. I think its just the rep who sold it to you who forgot one step of the setup. I was able to go to Options-->Advanced Options-->Sim Card and click on "Edit SIM Phone Number", type in your number, save, then reboot - it should be there then.
__________________
Top 50 Year Win%: Nebraska-.785 tOSU-.768 Penn St-.740
Oklahoma-.740 Texas-.733 Alabama-.729 Michigan-.724 USC-.723
Dominance! The HUSKER Tradition!
Offline  
Old 07-08-2006, 11:48 AM   #5 (permalink)
New Member
 
Join Date: Sep 2005
Model: 7100r
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks! Worked perfectly.
Offline  
Old 07-20-2006, 07:17 AM   #6 (permalink)
New Member
 
Join Date: Jul 2006
Location: NIGERIA
Model: 8320
Carrier: MTN
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

mine still shows unknown number despite following the above steps. It in fact, displays "error accessing sim". Pl help!
Offline  
Old 07-31-2006, 10:39 AM   #7 (permalink)
New Member
 
Join Date: May 2005
Model: 7290
Carrier: AT&T
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

kenuzoka - Try removing the sim card and putting it back in to remove the sim error. If that does not work you should have the card replaced as it may be bad.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.