BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-16-2006, 06:52 PM   #1 (permalink)
New Member
 
Join Date: Aug 2006
Model: 8800
Carrier: AT&T
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Blackberry 7290 Battery Issues

Please Login to Remove!

I've had a 7290 for approximately 14 months. The current unit that I own is actually only about two months old as my previous unit had a major software malfunction and Blackberry replaced the entire unit except for the battery.

Prior to getting the new handheld, I had absolutely no problems with battery life. Unfortunately, since receiving the new unit, i've had nothing but issues.

Upon receiving the new unit, I immediately started using the existing battery from the original unit that I purchased. The battery life was significantly shorter. I could go to bed at night with a charge of 100% on the unit, allow the Auto Off to power the unit down from 0200-0500, and wake up the next morning with about 20% of the power in the battery remaining.

I immediately thought that maybe something subtle had been done at the hardware level on the new unit. As a result, I purchased the extended life battery from a third-party reseller and starting using that battery. Once again, the extended life battery is generally down to about 15-20% charge when I go to bed in the evening. By no means am I huge Blackberry user.

I know cellphone usage decreases battery life very quickly, however, my wife and I currently have over 7,000 rollover minutes accumulated through Cingular. I'm primarily a calendar/task user. I do not have my Blackberry tied into my work email, so i'm only really using the messaging for SMS as well.

After reading through the forum and not really seeing any threads that jumped out at me as being similar to my situation, I decided that maybe I had bought a defective extended life battery. Since my best battery life was experienced with the regular battery, I decided to buy another of the regular batteries. I purchased the battery yesterday, allowed the buy to fully exhaust, and then charged the battery overnight.

Leaving work today at 1700, I had about 15% charge left on the battery. I did receive and make several phone calls today, however, I would say that I spent a total of about 30 minutes on the phone today.

Has anybody else experienced similar issues? If so, were you able to correct it without replacing the unit you owned? If not, does anybody have any suggestions?

Thanks in advance,

Jason
Offline  
Old 08-16-2006, 09:52 PM   #2 (permalink)
Thumbs Must Hurt
 
BB_0wned's Avatar
 
Join Date: Oct 2005
Model: 7290
Posts: 93
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I would suggest apploading the HH to ensure that there isnt any software on the HH that is draining it. Seems strange but worth a shot. Besides that you are most likely looking at a defective HH. The fact that you have replaced it with 2 different batteries and still having the same issue would point to defective hardware imo.
Offline  
Old 08-21-2006, 11:15 AM   #3 (permalink)
New Member
 
Join Date: Aug 2006
Model: 8800
Carrier: AT&T
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I received my replacement unit from Cingular on Friday. I immediately put the extended life battery in the unit and attached it to my pc at home to charge the battery to 100%. As of this afternoon, the battery is at 75%.

Unfortunately, it appears I have FOUR batteries now!!! The original, the extended life, the generic replacement, and a brand new one that was part of the replacement phone package Cingular sent me that all work!!!

Thanks,

Jason
Offline  
Old 09-16-2006, 06:18 PM   #4 (permalink)
New Member
 
Join Date: Sep 2006
Model: 7290
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default I have the same problem

Just to let you know I have the same problem/story.

My 1st 7290 gave fatal errors - Cingular sent me a new one - New phone works great but battery runs dead half way through the day.

The only difference that I notice is that when I talk on the phone sometimes I hear a lot of static/buzzing and when this happens the battery drains very quickly. However, if I go though a day with no static/buzzing the battery seems to appear back to normal. Also the more drained the battery gets the more static/buzzing I hear.

Bizzare huh? I'm going to try a new battery first, but the current battery I'm using is only 8 months old, so...

I'll keep my fingers crossed.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.