BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   General Legacy Device Discussion (http://www.blackberryforums.com/general-legacy-device-discussion/)
-   -   Freedom Universal Keyboard (Bluetooth) (http://www.blackberryforums.com/general-legacy-device-discussion/58926-freedom-universal-keyboard-bluetooth.html)

Parker Rose 12-22-2006 05:20 PM

Freedom Universal Keyboard (Bluetooth)
 
I was given this as a gift a few days ago. It could be a neat item, but I am having problems. So far, the tech support for this keyboard (freedominput.com) has bee non-existent, a terrible disappointment. I will be delighted to share a full review with everyone on this forum if I can finalize the operation. Here is the problem (and this is substantially as it was posted to the Freedom Keyboard Tech support site, but with no acknowledgment at all yet. ARGH!)

I have managed to install the keyboard driver for the Freedom Universal Keyboard. The device IS successfully paired with my Blackberry 8700c. The permissions have been edited to allow the keypboard and the settings to allow the device to be trusted. You would think that this would be enough, but some tekkie-type decided that it had to be more difficult.

I cannot get the keyboard to function. It is turned on (the on-off switch is in the upper right, not the lower left as the online documentation states) and it has HID and SPP positions (I have no idea what this means).

Anyway, I seem to be missing one thing here. There is reference to the keyboard icon appearing on the Blackberry main screen and then clicking on it and activating it. THERE IS NO KEYBOARD ICON THAT HAS APPEARED AND THEREFORE THIS IS NOT POSSIBLE.

This may be the problem. If anyone can help, please let me know. Thanks...

Parker R.

mark0341 12-22-2006 06:05 PM

Wirelessly posted (BLACKBERRY 8703e (ALLTEL): BlackBerry8703e/4.1.0 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/106)

I think HID stands for Human Input Device.

NADight 12-23-2006 11:06 AM

Need to install the driver onto your BB. The keyboard icon should then appear

lcater 12-23-2006 02:38 PM

Website says to use this link for OTA Freedom Input

Parker Rose 12-23-2006 08:43 PM

Yes, the driver was installed and when I look for it in the apps, I find it. But still no icon on the main screen. Although not a tekkie, I am guessing that if I can get the icon to appear on the screen, I can then "activate" it. But no icon and therefore no activation.

Parker

JeffGray 12-23-2006 09:00 PM

I too have the keyboard - with a Pearl 8100 - and am not clear on how to install the drivers. The package has a Mac Icon but the instructions indicate that one MUST have Windows and Blackberry 4.0 (Windows only software) to install the driver. It appears that the driver needs to be downloaded and then during the install an unlock code is provided (as best as I can understand their poor instructions).
How did you get the driver installed on a Mac and did you get it unlocked?
Maybe together we can work this through.
Jeff

Parker Rose 12-23-2006 09:54 PM

I don't have a Mac, but a PC, but I used the freekey direct download to the 8700c. Although the PDF manual that is available online speaks of codes to be entered, etc., none of that happened. I used the BB 8700c to download the driver directly. The "Freedom Universal Keyboard" driver was installed, but at no time before, during or after the installation process was there any prompt for a code of any kind.

This is the only bluetooth device that I have come across that has this ridiculous procedure. On all other devices I have used, you pair the device and that is that.

Freedom Keyboard has worthless tech suport as far as I can see. Absolute zip from them. We have written the vendor from whom this was purchased and told them the problem, but nothing yet (and there may not be anything until Tuesday the 26th).

I cannot express the contempt I have for companies that purport to be cutting edge high tech and then fail to follow up with what seems to be a routine question.

Anyway, sorry about the rant. If worse comes to worst, we can always challenge the credit charge on the card, but that hardly solves the actual problem.

PR

JeffGray 12-24-2006 09:25 AM

Exactly my experience with Freedom. Suspect my unit will be going back. Too bad as I like the idea.

That you did not need an unlock code is likely to be why your device is not working. They have worked hard to make sure you need one so as not to freely distribute their driver.

I agree, a terrible procedure.

Jeff

Parker Rose 12-24-2006 11:35 AM

I will let you know if there is anything further that develops. I am not optimistic, however.

Season's Greetings!

Parker

Parker Rose 12-25-2006 07:25 PM

Problem Solved!
 
OK, after another few hours of frustration, I finally got the keyboard and the 8700c to work with each other. Here is how it happened. Please note that I have no idea if this will work for other BBs. I have an 8700c. The documentation provided by the manufacturer is incompetently outdated. Anyway, this is how it worked out:

In our last episode, the driver had been installed and the Blackberry 8700c had recognized the device. However, I could not see the icon on the home page screen of the BB, meaning I could not activate and use the keyboard. It finally dawned on me to look in the Applications section, and... voila, there was the Keyboard icon.

Victory! Well, no. Not quite yet. I knew from the confusing PDF manual available online at the Freedom Keyboard site that there should be a code that needed to activated. I clicked on the Keyboard Icon and what appeared to be the registration code procedure appeared on the screen.

Both a "Device Code" and the "Unique" code assigned to the keyboard needed to be entered to complete registration and therefore the activation procedure. The Unique Code was printed on the back of the pamphlet that came with the keyboard. At least I thought it was.

The device code appeared on the screen automatically. This was good, as I had no idea what is was or where to find it. And it being almost a week since I had first contacted the Freedom Keyboard tech support - without any response whatsoever - I would not have known what to do had it not come up. I then filled in the Unique Keyboard Code - the one printed on the back of the pamphlet and... it still did not work!! An error message appeared on the screen that the code was invalid. WHAT?!?!?

This was really upsetting. What could have gone wrong? I used the freakin' code printed on the back page of the pamphlet! I went back to the online PDF manual and there was yet another, diferent procedure concerning these codes that was explained. It made no sense as presented in the PDF manual, but that was par for the course. Now it occurred to me that I possibly had all the pieces to the puzzle if I could just sort them out in the right order.

I entere my name and email address in the "code" menu that appeared, along with the device code that my BB had generated automatically and THEN the code on the back page of the pamphlet. When I submitted this info, the REAL device code was emailed to me. It looked nothing like the code on the back of the pamphlet.

I then went back to the keyboard icon on the Application page of the BB and started the registration/activation procedure that I had previously tried unsuccessfully. Only this time I used, for the device code, the code that had just been emailed me (instead of the code printed on the back page of the pamphlet included with the keyboard.)

BINGO! It took and was accepted, the keyboard was registered and it took only a few minutes to confirm that it had paired and was functioning with my BB.

Wow, what a hassle! I think this may be a very cool product. I also think that the Freedom Keyboard people should be ashamed for having put out the disgraceful "user's manual" that led to more confusion than anything else. Ya know, they are getting a hundred bucks for a device and they should get people through the installation process, not stay silent.

OK, let me work with the keyboard now for a week or so and I promise to get back with a review.

Parker

ico_chan 12-28-2006 06:38 PM

code failed
 
I try the code from freedominput like you Parker Rose but it doesn't works. I send a mail to Freedominput and I'm still waiting, can someone help me please!!!!

JeffGray 12-29-2006 12:33 AM

Excellent and thanks. Also got mine to work, similar set of frustrations and manual checking and similar no response from support.

Cannot find a layout diagram of what all the keys do. No schematic. Do you have one? For example, what is the letter B in the upper left corner? Several other questions could be answered with a simple layout diagram of all the keys and what they do.

Be nice to see how to program the function keys. I did my install via bluetooth (I have a Mac so cannot use the book method). Have a pearl 8100 and cannot, for example, get the menu to open from the home screen.

thanks
Jeff

martinc 01-08-2007 02:48 PM

unlock Code
 
I bought one from Nextel for $100. after a few attempts at setting it up I came to the unlock code screen on my 7520. I lost the cd cover with the code on it- whoops! Anyone want to share? Seems lame that you need a code as it will only work with thier hardware.

Parker Rose 01-11-2007 06:59 AM

I have been unexpectedly side-tracked by business, so I apologize for not responding to some inquiries. Regarding the custom programming of the Fn keys, go to Applications, Bluetooth Keyboard and when you click on that you should see a page with the version number, etc. If you scroll down, you will see the Fn keys listed. Click on that and you should be able to customize the keys.

Some of the keys on the keyboard do not function properly, but seem to be "trmped" by the regular BB functions. For example, without the keyboard connected, you would scroll down one screen at a time using the space bar. On the keyboard, you are supposed to be able to scroll down one screen at a time holding down the Fn key and then hitting the arrow-down key. But it doesn't work. That's the bad news. I discovered, however, that simply hitting the keyboard's spaceboard will do it, analogous to the BB itself.

I cannot get the keyboard to be automatically recognized by the BB when it is switched on. I must go to the Applications->Bluetooth Keyboard page (just like I described above) and the click the "activate" checkbox off and on. That does it.

The "Enter" key only functions under certain conditions. It seems to be pre-empted by the Fn+Arrow right combo. However, that combo works almost all the time.

Very quirky, but once you get the hang of it, worth it.

One additonal bizarre observation: I was out of the country for about a week, visiting a couple of islands in the Caribbean (yes, I dirty job, but someone had to do it). On two of them, the keyboard worked fine. On the last one, it connected, (the blue light came on, etc.) but it would not actually work. When I returned to the U.S., everything went back to "normal" and it could be used again. I think this may have had something to do with the Sim card needing to be rebooted, (taking it out and the put back in) but I am not sure.

That's it for now. Parker.


All times are GMT -5. The time now is 02:51 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.