BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-23-2007, 02:52 AM   #1 (permalink)
New Member
 
deadstk's Avatar
 
Join Date: Mar 2007
Model: 8300
Carrier: AT&T
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Smile How to get bbWeather to work on your 8800

Please Login to Remove!

After messing around for 45min and searching several post I finally was able to get bbWeather 0.74to work on my 8800. I thought I would save others the frustration and pull what I learned together in one post.

If you haven’t already you can download bbWeather here:
Over The Air Wireless Link: blackberrytools.sourceforge.net/OverTheAir/bbweather-0.74/BBWeather.jad
[TIP: email this link to your 8800 and select link in the email]

When you open bbWeather for the first time it most likely will give you an error that says: “Error. No Weather Profiles specified”. If you hit the menu button to enter your profiles it will crash and freeze your 8800.

Here’s what to do:
If you’re crashed (frozen) reboot your 8800 (hold the off button down for several seconds or remove and replace the battery).

Follow these instructions exactly:

1. Re-launce bbWeather when you see : “Error. No Weather Profiles specified” DO NOT hit the menu button.
2. Click on the trackball to select ok. DO NOT hit on the menu button.
3. Now click the trackball again… the menu you’re looking for will appear.
4. Select "Options" and add your weather information; Location ID: [your zip], description e.g., [your town, state], select “Disable MDS Proxy”, save.
5. Bada-Bing you should now have bbWeather up and running. Note: at this point you can now use the menu button whenever you want without fear of locking the program up.

-Good luck
Offline  
Old 03-23-2007, 06:25 AM   #2 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: iPh6
Carrier: AT&T
Posts: 27,822
Post Thanks: 33
Thanked 442 Times in 382 Posts
Default

In other words - the exact same way you get BBWeather to work on a Pearl!
Offline  
Old 03-23-2007, 08:33 AM   #3 (permalink)
New Member
 
Join Date: Mar 2007
Model: 8800
Carrier: O2
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Very useful - thanks.

Thanks for this. Very useful posting. I was having the same issues.

You can find weather location IDs here:

www dot aspnetresources dot com fwdslash tools fwdslash locid dot aspx
Offline  
Old 03-23-2007, 10:04 AM   #4 (permalink)
Knows Where the Search Button Is
 
jvalason's Avatar
 
Join Date: Mar 2007
Location: Albany, NY
Model: 9530
PIN: 3048C313
Carrier: Verizon
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I tried all of that..and I tried the zip and the code for where i live ans I still get error:malformed address. Returning Null. Any ideas?
Offline  
Old 03-23-2007, 10:12 AM   #5 (permalink)
Knows Where the Search Button Is
 
jvalason's Avatar
 
Join Date: Mar 2007
Location: Albany, NY
Model: 9530
PIN: 3048C313
Carrier: Verizon
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I figured it out...I put the address in the user name box not that top one.!!!!
Offline  
Old 03-23-2007, 10:37 AM   #6 (permalink)
Thumbs Must Hurt
 
H3LLFIRE's Avatar
 
Join Date: Jan 2006
Location: Boston, MA
Model: 8800
Carrier: Cingular
Posts: 100
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This has been covered in detail in previous posts.

If you're having trouble finding the weather location id, go to this link ---> National and Local Weather Forecast, Radar, Map and Report ---> and find your city from the search tool. If you do a search for Boston, for example, in the address bar you'll see a code that looks like: USMA0046

Use the code you get from your search as your location id. I've found that this works for cities (Boston, NYC, LA) but not so much for towns (suburbs). You may need to choose the city closest to you in order to get a proper code.

There are other ways to find the location id, but this works best for me.

Last edited by H3LLFIRE : 03-23-2007 at 07:03 PM.
Offline  
Old 03-23-2007, 02:10 PM   #7 (permalink)
New Member
 
Join Date: Mar 2007
Location: Maryland
Model: 8800
Carrier: Cingular
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BBWeather Error on Tunnel-Max

Need help with BBWeather, I have went through all the steps but getting an error message: Error: Open Tunnel - max timeout

Any help.
Offline  
Old 03-23-2007, 04:28 PM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Mar 2007
Model: 8800
Carrier: Cingular
Posts: 25
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

im getting an error,

"Error: open Tunnel - failure"

Last edited by Clandestine : 03-23-2007 at 04:30 PM.
Offline  
Old 03-23-2007, 05:15 PM   #9 (permalink)
Thumbs Must Hurt
 
H3LLFIRE's Avatar
 
Join Date: Jan 2006
Location: Boston, MA
Model: 8800
Carrier: Cingular
Posts: 100
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Make sure your TCP settings in the Advanced Options section are correct:

APN: wap.cingular
Username for APN: [email address]
Password for APN: CINGULAR1
Offline  
Old 03-23-2007, 05:02 PM   #10 (permalink)
Thumbs Must Hurt
 
MaxT32's Avatar
 
Join Date: Dec 2006
Location: USA
Model: 9000
OS: 5
Carrier: AT&T
Posts: 74
Post Thanks: 0
Thanked 0 Times in 0 Posts
Talking

Quote:
Originally Posted by H3LLFIRE
Make sure your TCP settings in the Advanced Options section are correct:

APN: wap.cingular
Username for APN: [email address]
Password for APN: CINGULAR1
Thank you that worked perfectly!
Offline  
Old 03-23-2007, 05:50 PM   #11 (permalink)
Thumbs Must Hurt
 
H3LLFIRE's Avatar
 
Join Date: Jan 2006
Location: Boston, MA
Model: 8800
Carrier: Cingular
Posts: 100
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Happy to help. Answers to most if not all of the questions asked in this thread can be found using the forum's Search feature. Don't be afraid to use it. Can save a lot of time and headache, trust me!
Offline  
Old 03-23-2007, 08:34 PM   #12 (permalink)
Knows Where the Search Button Is
 
Join Date: Mar 2007
Model: 8800
Carrier: Cingular
Posts: 25
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm still getting an error even if I do change the TCP
Offline  
Old 03-23-2007, 10:00 PM   #13 (permalink)
New Member
 
Join Date: Feb 2007
Model: 8800
Carrier: ATT
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Clandestine
I'm still getting an error even if I do change the TCP
me too, it a malformed address error. But I have double checked the TCP change and it is right???
Offline  
Old 03-23-2007, 10:28 PM   #14 (permalink)
Knows Where the Search Button Is
 
Join Date: Mar 2007
Model: 8800
Carrier: Cingular
Posts: 25
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm getting an error:null
Offline  
Old 03-24-2007, 12:37 PM   #15 (permalink)
Thumbs Must Hurt
 
H3LLFIRE's Avatar
 
Join Date: Jan 2006
Location: Boston, MA
Model: 8800
Carrier: Cingular
Posts: 100
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It's possible you need to contact Cingular to allow WAP data transfer. I got in touch with one of their data services guy and he was able to enable this on my account with no additional charges. I was having the same errors: Open tunnel, malformed address, error null, etc. before this. Honestly I'm not completely sure what he did but all my 3rd party apps work fine now and I haven't been charged additional by Cingular. Here's what my bill looks like now:

ExpandedIntlRoamgSvc $0.00
Upgrade $0.00
IMS APN Feature $0.00
Upgrade Processor $0.00
BM 1000 MSG $9.99
BBRYBISUNL $29.99
Offline  
Old 03-24-2007, 01:33 PM   #16 (permalink)
New Member
 
Join Date: Mar 2007
Model: 8800
Carrier: Cingular
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm getting the error of Bad DNS address. Any ideas?
Offline  
Old 03-24-2007, 01:38 PM   #17 (permalink)
Talking BlackBerry Encyclopedia
 
nimocone's Avatar
 
Join Date: Feb 2007
Location: Northern Va.
Model: 8800
Carrier: Cingular
Posts: 215
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does this weather program use up any extra battery power?
Offline  
Old 03-24-2007, 01:52 PM   #18 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

It polls for weather every hour or two, so yes it uses battery power. I've used it for a couple of years....it's not enough to notice.
Offline  
Old 03-25-2007, 05:57 PM   #19 (permalink)
New Member
 
Join Date: Mar 2007
Model: 8800
Carrier: O2
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by wbritt
I'm getting the error of Bad DNS address. Any ideas?
I got this message a few times too. Not sure why. I kept closing and reopening the app and it eventually worked after a few tries and now it's back to normal. Strange...
Offline  
Old 03-27-2007, 09:17 PM   #20 (permalink)
CrackBerry Addict
 
BBChristopher's Avatar
 
Join Date: Jul 2006
Location: Dutchess County, NY
Model: 9000
OS: 5.0
Carrier: AT&T
Posts: 646
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks, good info.....

__________________
24A3F370 (9000)
East Coast Shoutin!!!!!!
"Imagine the Possibilities", Run Silent..Run Swift
850, 950, 957, 7100, 7130, 8100, 8800, 8310, 9000
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.