BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-15-2007, 11:23 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: Fido
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Help with 8700C Please

Please Login to Remove!

Hi All,

I just purchased a BB 8700C (Cingular) off of eBay. The auction clearly stated that the unit was unlocked, very important for me as I wanted to use it on the Fido network. When I rcvd the unit I inserted my sim card, and it shows invalid sim on the screen with the SOS in red.

My initial thought was that the unit was locked, so I bought a unlock code, I was never able to get to the point of actually entering the unlock code.

Weird thing is that in the sim card menu the unit is supposed to show the network setting as "network active" but on mine it shows "network disabled" So I am thinking that it is unlocked but for some reason it does not like my sim, or I am missing a step/information to get it going.

I have also tried another sim thinking mine might be defect, I also tried a sim from Rogers and still nothing. I removed the IT Policies, and even upgraded the software to the new v4.2 .. still nothing.

Bottom line is the my sim only shows up in SOS mode, and it shows invalid sim on the screen.

Does anyone have any thoughts on this.

Thanks

Last edited by silvertint : 04-15-2007 at 11:24 AM.
Offline  
Old 04-15-2007, 11:30 AM   #2 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,770
Post Thanks: 32
Thanked 439 Times in 379 Posts
Default

When you go into Options/Advanced/SIM Card and type MEPD exactly what does it show?
Offline  
Old 04-15-2007, 11:32 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: Fido
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by NJBlackBerry View Post
When you go into Options/Advanced/SIM Card and type MEPD exactly what does it show?
It shows the following:

Sim .. Disabled
Network .. Disabled
Network Subset .. Disabled
Service provider .. Disabled
Corporate .. Disabled
Offline  
Old 04-15-2007, 11:35 AM   #4 (permalink)
CrackBerry Addict
 
nexteli836man's Avatar
 
Join Date: Jul 2005
Location: Michigan
Model: 9000
Carrier: AT&T
Posts: 639
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

its unlocked then
Offline  
Old 04-15-2007, 11:36 AM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: Fido
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by nexteli836man View Post
its unlocked then
That was my thought too, so why won't my sim work !!!
Offline  
Old 04-15-2007, 11:37 AM   #6 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,770
Post Thanks: 32
Thanked 439 Times in 379 Posts
Default

It's unlocked. If it doesn't accept a Rogers or Fido card then it is possibly/probably damaged..
Offline  
Old 04-15-2007, 11:45 AM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: Fido
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by NJBlackBerry View Post
It's unlocked. If it doesn't accept a Rogers or Fido card then it is possibly/probably damaged..
I forgot to mention that I even got my hands on a Cingular sim, and only then does the unit not display the SOS. I do not think it is damaged because of the cingular sim.
Offline  
Old 04-15-2007, 11:49 AM   #8 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,770
Post Thanks: 32
Thanked 439 Times in 379 Posts
Default

You did forget to mention this.
Guess it has another problem.
Like it apparently isn't unlocked properly.
Offline  
Old 04-15-2007, 11:57 AM   #9 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: Fido
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by NJBlackBerry View Post
You did forget to mention this.
Guess it has another problem.
Like it apparently isn't unlocked properly.
Do you have any suggestions on how to unlock it properly. Keep in mind that once I do the MEPD, the next step is the mep2 and I am supposed to enter the unlock code at that point. This is where I encounter a problem as I am not getting, "enter the unlock code"
Offline  
Old 04-15-2007, 12:02 PM   #10 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,770
Post Thanks: 32
Thanked 439 Times in 379 Posts
Default

Nope.. Sorry.
The perils of eBay electronics purchases..
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.