BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-25-2007, 12:52 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 7520
PIN: N/A
Carrier: Boost Mobile
Posts: 43
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 7520 problem adds "+" before dialed address book numbers

Please Login to Remove!

I have a BB 7520
OS 4.0
Boost Mobil SIM

The problem that I'm having with the BB is that when I choose to dial a number from my address book, it never dials correctly. It appears that the phone appends a "+" before any dialed numbers from the address book and therefore doesn't dial correctly. Another strange thing is that when I dial a number directly, I must dial the area code as well... even though it's a local call?

Any idea on why the phone appends a "+" before dialed numbers from the address book? OR why I must dial the area code as well?

Also, I tried the 7520 as a modem for a PC. I set everything up correctly but always get an error code 738 (when trying to register on the network). Is it not possible to use the 7520 as a modem? I read the entire thread regardin this but nobody EVER mentioned an error 738.

Any help at all would be appreciated!

blackberry-guy
Offline  
Old 06-25-2007, 01:11 AM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 7520
PIN: N/A
Carrier: Boost Mobile
Posts: 43
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by blackberry-guy View Post
I have a BB 7520
OS 4.0
Boost Mobil SIM

The problem that I'm having with the BB is that when I choose to dial a number from my address book, it never dials correctly. It appears that the phone appends a "+" before any dialed numbers from the address book and therefore doesn't dial correctly. Another strange thing is that when I dial a number directly, I must dial the area code as well... even though it's a local call?

Any idea on why the phone appends a "+" before dialed numbers from the address book? OR why I must dial the area code as well?

Also, I tried the 7520 as a modem for a PC. I set everything up correctly but always get an error code 738 (when trying to register on the network). Is it not possible to use the 7520 as a modem? I read the entire thread regardin this but nobody EVER mentioned an error 738.

Any help at all would be appreciated!

blackberry-guy
Well after doing some research in this forum, I discovered the "smart dialing" options menu under phone options. By setting the country code to "unknown" it solved the issue where the phone would ALWAYS place a "+" before numbers dialed from the phone book!

Now I wonder why I must always dial the area code even for local numbers?

I still need help with the 7520 as a modem and error 738 as well... please

I love this forum, but JEEEEEZ has it been really messed up over the past few days! Everytime I try to access it, there's a new problem.

blackberry-guy
Offline  
Old 06-25-2007, 10:13 AM   #3 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Many carriers, like Cingular, are now moving to require area codes to be dialed--always. You should place your correct country code in the Smart Dialing section or your caller ID on the calls coming to your BB may not work correctly.
Offline  
Old 06-27-2007, 01:28 AM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 7520
PIN: N/A
Carrier: Boost Mobile
Posts: 43
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by JSanders View Post
Many carriers, like Cingular, are now moving to require area codes to be dialed--always. You should place your correct country code in the Smart Dialing section or your caller ID on the calls coming to your BB may not work correctly.
thanks for the info! Jeeez, this blackberry is gonna kill me yet It would be nice if there was a big RED button on the front that said "WORK" and after pushing it, everything worked properly hehehe

blackberry-guy
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.