BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   General Legacy Device Discussion (http://www.blackberryforums.com/general-legacy-device-discussion/)
-   -   Escape key stopped working; any simple fix? (http://www.blackberryforums.com/general-legacy-device-discussion/86464-escape-key-stopped-working-any-simple-fix.html)

csyria 07-18-2007 01:53 AM

Escape key stopped working; any simple fix?
 
Hi everyone, new member here, longtime lurker. I did search for my issue with a couple of terms, but nothing came up. Sorry if I missed it while searching.

I have a 7290 that I really love, but over the past month or so, my escape key has slowly stopped working, going from not responding to a press once in a while to requiring 3 or 4 presses, to where it is now at responding a mere fraction of the time.

Has anyone seen this before? Is there any simple fix? I'd prefer not to buy a new Blackberry since my 7290 does everything I need, but the inconvenience of not having a working escape key is really starting to annoy me.

Thanks!

John Clark 07-18-2007 04:34 AM

It sounds like the button is just worn out. The button is soldered to the mainboard of the BB so there is not an easy fix if it needs to be replaced. It's possible that it's just dirty, however. You could disassemble the device and see if you could clean it. Beyond that it may be time for a new BB.


All times are GMT -5. The time now is 03:56 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.