BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-18-2007, 01:53 AM   #1 (permalink)
New Member
 
Join Date: Jul 2007
Model: 7290c
PIN: N/A
Carrier: AT&T
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Escape key stopped working; any simple fix?

Please Login to Remove!

Hi everyone, new member here, longtime lurker. I did search for my issue with a couple of terms, but nothing came up. Sorry if I missed it while searching.

I have a 7290 that I really love, but over the past month or so, my escape key has slowly stopped working, going from not responding to a press once in a while to requiring 3 or 4 presses, to where it is now at responding a mere fraction of the time.

Has anyone seen this before? Is there any simple fix? I'd prefer not to buy a new Blackberry since my 7290 does everything I need, but the inconvenience of not having a working escape key is really starting to annoy me.

Thanks!
Offline  
Old 07-18-2007, 04:34 AM   #2 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,679
Post Thanks: 4
Thanked 96 Times in 71 Posts
Default

It sounds like the button is just worn out. The button is soldered to the mainboard of the BB so there is not an easy fix if it needs to be replaced. It's possible that it's just dirty, however. You could disassemble the device and see if you could clean it. Beyond that it may be time for a new BB.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.