BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   General Legacy Device Discussion (http://www.blackberryforums.com/general-legacy-device-discussion/)
-   -   8830 DM connection problem. (http://www.blackberryforums.com/general-legacy-device-discussion/86941-8830-dm-connection-problem.html)

Howard2k 07-20-2007 04:16 PM

8830 DM connection problem.
 
My 8830 does a near instantaneous disconnect from my XP PC for some stupid reason.

I've tried the DM from the CD that came with the 8830, I've also tried the 4.2.2 SP2 version.


Stupidly, out of the box the software wouldn't even detect the 8830 at all. Now it will detect it but disconnects it again straight away.


I suspect it could be a problem with the USB driver, anyone got any ideas?

I thought the Treo 700wx was a bad product, so far this one is not off to a stellar start either.

jeremyckitching 07-20-2007 04:36 PM

You might need to delete the USB ports from the Windows Device Manager. I have had to do that. Now if you have a USB keyboard and mouse it will stop them from functioning until you reboot. After the reboot it may take about 5 minutes for the USB devices to be re-recognized.

JSanders 07-20-2007 05:15 PM

Howard, do you have the BB connected via USB directly to the PC, not through a USB hub? I would recommend connecting direct, if you are not. I had this problem at one time and connected direct, and all was daisies from thereon.

Likewise, reboot (pull the battery) of the 8830 before connecting again.

Good luck.

Howard2k 07-20-2007 06:12 PM

Quote:

Originally Posted by jeremyckitching (Post 607766)
You might need to delete the USB ports from the Windows Device Manager. I have had to do that. Now if you have a USB keyboard and mouse it will stop them from functioning until you reboot. After the reboot it may take about 5 minutes for the USB devices to be re-recognized.

Thanks - trying that now.

Howard2k 07-20-2007 06:12 PM

Quote:

Originally Posted by JSanders (Post 607809)
Howard, do you have the BB connected via USB directly to the PC, not through a USB hub? I would recommend connecting direct, if you are not. I had this problem at one time and connected direct, and all was daisies from thereon.

Likewise, reboot (pull the battery) of the 8830 before connecting again.

Good luck.

Direct through the PC. I'll take your advice and pull the battery before trying again.

Thanks

Howard2k 07-20-2007 06:21 PM

Nope, still not working.

If I go to Connection Settings, ensure that USB is set and choose Detect it won't find the device.

It actually DID connect for a brief second, but then disconnects straight away and won't stay connected.

*sigh*.

UPDATE: Not sure if it's related or not, but the installation window flashes up in the DM software. I can't see what it's actually doing because it flashes on and off so quick, but maybe it's related. I've removed and reinstalled a bunch of times and tried the version on the CD (4.2.2.12) and the 4.2.2.SP2 download.

Howard2k 07-20-2007 07:34 PM

Got it working.

I wish I could succinctly explain how, in the event that someone else has the problem. But it was ONE of these steps that did it, I just don't know which one.

I DID have previous version of the BB DM on here from a previous 7250. I also took the advice of jeremyckitching (above) and it didn't work.

However - in the end I:

1 - Removed the Blackberry software.

2 - I then rebooted.

3 - I then spent a good 30-40 minutes going through the registry looking for references to "RIM" and "Blackberry" and clearing out the relevant ones. I went and ensured that I physically deleted all the files from Program File that were related.

4 - Then I went and repeated the advice from jeremyckitching (again) through device manager.

5 - I then reinstalled the latest Blackberry software (4.2.2SP2).

6 - Rebooted.

7 - Reset the device again (removed the battery).

8 - Started the DM software and connected.

It's been an INCREDIBLY frustrating experience, countless removals and reinstallations and playing with different software versions. Hopefully this will save someone else some of that frustration and now I can put the bad memories of the 700wx and the initial 8830 issues behind me.


All times are GMT -5. The time now is 04:21 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.