BlackBerry Forums Support Community               

Closed Thread
LinkBack Thread Tools
Old 08-29-2007, 10:32 AM   #1 (permalink)
Thumbs Must Hurt
Join Date: Jan 2006
Location: Alabama
Model: 9550
Carrier: Verizon
Posts: 50
Post Thanks: 0
Thanked 0 Times in 0 Posts
Angry 7290 Reception Issue

Please Login to Remove!

My wife's T-mobile 7290 has started displaying "searching for network" or "no service" for most of the time...and she swears she did not drop it. The device will periodically connect to the network and retrieve messages, but then it loses service for several hours. The SIM card works fine in my 8700, so it does not appear to be a SIM or T-mobile problem. Battery pulls have not helped either. Any ideas for trouble-shooting or getting the device repaired? (Naturally, the local T-mobile dealer is of no help whatsoever.)
Old 08-29-2007, 11:19 AM   #2 (permalink)
BBF Moderator
John Clark's Avatar
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,697
Post Thanks: 4
Thanked 107 Times in 75 Posts

Unfortunatly, it's probably not worth getting the device repaired. Have you removed the battery to reboot the device? Might be time to look at a new device. There are some great deals on used ones out there right now or maybe look at a device upgrade.
Old 10-04-2007, 10:03 AM   #3 (permalink)
New Member
Join Date: Oct 2007
Model: 7290
Carrier: TIM
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts

Hello, I have a 7290 and I can't use it in Brazil!!!!
Any one has the solution?

Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Copyright 2004-2014
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.