BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-10-2007, 01:53 PM   #1 (permalink)
New Member
 
Join Date: Apr 2006
Model: 8830
Carrier: Sprint
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Sprint EVDO bad? Or is the 8830 not tweaked enough?

Please Login to Remove!

Just moved from Verizon BB 7130e (EVDO) to Sprint BB 8830 (EVDO). I'm having a horrible time getting a solid EVDO signal and keeping it for longer than a minute on the Sprint 8830 (this is location independent) . I'm no stranger to Blackberry. I actually support them in an enterprise environment. I have also had every model from the 957 to the current 8830. So I know what they normally need to work right. I have contacted 1st tier Sprint tech support but got a dunce. I'm wondering if there is something I'm missing or Sprints EVDO on the BB is buggy. My config is listed below.

Sprint Blackberry 8830
Device Software Version: 4.2.2.123 (Platform 3.0.0.64)
Desktop Software Version: 4.2.2.14
Signal: -87 dBm to -92dBm (average)

Issue: will not maintain a solid EVDO connection no matter where the device is used.
Offline  
Old 09-10-2007, 05:35 PM   #2 (permalink)
BlackBerry Master
 
djm2's Avatar
 
Join Date: Jul 2007
Model: 9780
PIN: N/A
Carrier: T-Mobile
Posts: 4,637
Post Thanks: 29
Thanked 12 Times in 12 Posts
Default

I'd guess it is the phone. I get a worse signal than you in my office (if I average -100 I'm lucky), and it stays locked on EVDO.
Offline  
Old 09-10-2007, 06:15 PM   #3 (permalink)
CrackBerry Addict
 
ladydi's Avatar
 
Join Date: Jun 2005
Location: Washington
Model: 8800
Carrier: T-mobile
Posts: 848
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

sounds like a broken antenae problem aka bad phone. Sprint will make you reload the radio software or perhaps the whole OS before they will declare it broke, so you may try doing this first before you call them back. Its easiest to jump through the hoops with them - I'm so glad I'm on t-mobile now (sorry, I couldn't help that last comment)
__________________
~Di~
Windows 2003
Exchange 2003
BES 4.1
Offline  
Old 09-10-2007, 07:54 PM   #4 (permalink)
Talking BlackBerry Encyclopedia
 
harryzuluberries's Avatar
 
Join Date: May 2005
Location: Surf 'n Sun dude.
Model: 9630
OS: 4.iforgot
PIN: DUPONT FIFTH AVENUE LARGE ORPHEO ROLLERBALL
Carrier: the Titanic
Posts: 372
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Had this same problem, took it to a pre-merger NRS which is now a Sprint store....they ordered me a new one, called me when it was in and swapped them. Definitely a radio issue as my new one stays connected to EVDO and the signal doesn't bounce all around the place like before.
__________________
TAIN
www.myspace.com/tshaka_zulu
Do, or do not. There is no try. -Yoda

7510>7520>7100i>8830>8330>9630
Offline  
Old 09-11-2007, 11:19 AM   #5 (permalink)
New Member
 
Join Date: Apr 2006
Model: 8830
Carrier: Sprint
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

What is an NRS? And why is it beneficial in this instance? I'm going to call Sprint blackberry support now. See below what I have done so far.

I loaded this... 8830EFS_PBr4.2.2_rel240_PL3.0.0.64_A4.2.2.123_Spri nt.exe
Got it from the Blackberry site. Does the sprint site have a newer version than that?
And I'm not sure if it was any different from the pre-loaded version. Either way, I re-provisioned, re-sent service books, and full power cycled for good measure. It did not help at all. Still mainly seeing 1X, 1x, 1xev, and rarely 1XEV. When I get 1XEV it is only for a minute or 2. I called sprint 1st level support to see if loaction wise i was ok. I am. and the signal is strong. My network settings are:

Mobile Network: Sprint PCS
Network Selection Mode: Automatic
Network Mode: 1XEV

What next???
Offline  
Old 09-11-2007, 12:53 PM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
harryzuluberries's Avatar
 
Join Date: May 2005
Location: Surf 'n Sun dude.
Model: 9630
OS: 4.iforgot
PIN: DUPONT FIFTH AVENUE LARGE ORPHEO ROLLERBALL
Carrier: the Titanic
Posts: 372
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, here's the fix.....

Take it to a Sprint/Nextel Corporate store (not an affiliate store) and tell them that you're blackberry has a radio problem. You thought it was software and that you would wait for a new update, but other people with the same device have told you that they don't have the same problem. Tell them that the radio is bad and you want to (under the provisions of the insurance...if you have it) swap your 8830 for another one. That SHOULD solve your problem unless you get another handset with a radio like the one you currently have. Hope that helps.

NRS=Nextel Retail Store by the way
__________________
TAIN
www.myspace.com/tshaka_zulu
Do, or do not. There is no try. -Yoda

7510>7520>7100i>8830>8330>9630
Offline  
Old 09-11-2007, 01:51 PM   #7 (permalink)
New Member
 
Join Date: Apr 2006
Model: 8830
Carrier: Sprint
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well its working albeit a tick slower than Verzions EVDO on a 7130e.

I called Sprint Blackberry support. They re-provisioned on their end, and then removed and re-added the BB data plan. after a hard power cyle of the 8830 and 10 minutes. I got a solid 1XEV signal. Tried Tethered and averaged 300kbps-down/100kbps-up. Is this good for Sprint?
Offline  
Old 09-11-2007, 08:03 PM   #8 (permalink)
Talking BlackBerry Encyclopedia
 
harryzuluberries's Avatar
 
Join Date: May 2005
Location: Surf 'n Sun dude.
Model: 9630
OS: 4.iforgot
PIN: DUPONT FIFTH AVENUE LARGE ORPHEO ROLLERBALL
Carrier: the Titanic
Posts: 372
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm getting about 600-800 and my buddy gets 1mbp bursts, tethered.
__________________
TAIN
www.myspace.com/tshaka_zulu
Do, or do not. There is no try. -Yoda

7510>7520>7100i>8830>8330>9630
Offline  
Old 09-12-2007, 11:42 AM   #9 (permalink)
New Member
 
Join Date: Apr 2006
Model: 8830
Carrier: Sprint
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm getting Av. 500/100 now. Same location as yesterday. Any tips to improve this?
Offline  
Old 09-14-2007, 02:35 AM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2007
Location: nyc
Model: 9630
PIN: N/A
Carrier: Sprint
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm able to achieve sustained download speeds of 750-800 kbps, with a reported signal strength of -80 dbm and a signal quality of 31 (AT+CSQ?).

Not sure why I was able to push 1.1-1.2 Mbps on my 8703e. I also wonder if the modem settings on the 8830 can be tweaked to approach the 8703e rates. There's quite a number of modem settings (AT&V) that can be played with.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.