BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   General PlayBook Discussion (http://www.blackberryforums.com/general-playbook-discussion/)
-   -   2.1.0.1088 WiFi Disconnects? (http://www.blackberryforums.com/general-playbook-discussion/262357-2-1-0-1088-wifi-disconnects.html)

jgb@etree 11-08-2012 09:37 AM

2.1.0.1088 WiFi Disconnects?
 
I had the same issue when I intially bought my Playbook (2.0 software) and after a month or so seemed to work itself out.

I've held off on upgrading to 1088 until yesterday, and after the upgrade (OTA & very smooth) it's doing the same thing & is very frustrating.

Has anyone found a solution to this problem?

Each time it disconnects, the WiFi log shows this message:

CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys

TIA

daphne 11-08-2012 07:46 PM

Re: 2.1.0.1088 WiFi Disconnects?
 
I've never had this problem. Did you try deleting the wifi profile and recreating it? Are you using an older router?

jgb@etree 11-09-2012 03:15 PM

Re: 2.1.0.1088 WiFi Disconnects?
 
Quote:

Originally Posted by daphne (Post 1791685)
I've never had this problem. Did you try deleting the wifi profile and recreating it? Are you using an older router?

Yeah, I've tried deleting and re-creating all of the profiles. It's happening on every network I connect to - hotspot from 9930, connectify from laptop, cisco aeronet's @ home and work & a linksys wrt that I use for 'testing'. None are N devices, and are are running the most current firmware. I'm also using AES instead of TKIP where possible. I'm starting to think it may getting confused when there are multiple saved networks available and is switching between them to a point where it gets so confused that I can't connect to anything unless I turn wifi off & back on. I'm going to try disabling/deleting all but one saved network and see if the situation improves.

Jase88 11-09-2012 09:34 PM

Re: 2.1.0.1088 WiFi Disconnects?
 
I've never had this issue myself....

jgb@etree 11-10-2012 06:39 AM

Re: 2.1.0.1088 WiFi Disconnects?
 
Looks like my suspicions may have been correct. I disabled all of the saved profiles except for my home network, and it's been stable since 6:00 last night.

Next test is to re-enable the saved profiles, but make sure I'm only within range of one network. From there, I'll start to bring it in the range of multiple saved networks and see what happens.

FWIW, BT connections (Bridge, BT Tether Bridge) are rock solid.

jgb@etree 11-12-2012 11:57 AM

Re: 2.1.0.1088 WiFi Disconnects?
 
Well, I can confirm that the issue is related to having saved profiles for multiple networks that are available at the same time. When I keep all off the WiFi profiles (except for the one I want to use) disabled, the WiFi is stable (tested on 6 different networks). As soon as a second (or more) saved profile is marked active, and the Playbook gets within range of 2+ saved networks, it starts switching between them every 30 seconds or so. After 4-5 minutes of this, I can't connect to any network until I disable wifi & re-enable it.

I can deal with the workaround of having to manually enable/disable wifi profiles as needed, but would prefer not to. If anyone finds a solution (or better workaround) I'd love to know.


All times are GMT -5. The time now is 06:11 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.