BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-12-2013, 05:35 AM   #1 (permalink)
Knows Where the Search Button Is
 
SGoodman's Avatar
 
Join Date: Nov 2012
Location: Canada
Model: 9670
PIN: N/A
Carrier: Telus Mobility
Posts: 38
Post Thanks: 2
Thanked 0 Times in 0 Posts
Question Android Apps Won't Run

Please Login to Remove!

Greetings,

The following apps show a blank black screen when started:

They were all installed from BlackBerry World, but I think they're Android Apps. Does anyone know what could cause all Android apps to simply show a blank screen?

Thanks,
Shane.
__________________
Z10 (version 10.2.1.3247)
LTE Playbook (version 2.1.0.1917)
Offline  
Old 12-12-2013, 09:14 PM   #2 (permalink)
Knows Where the Search Button Is
 
pkcable's Avatar
 
Join Date: Jan 2009
Model: Z10
OS: 10.2.1
PIN: N/A
Carrier: VZW & T-Mobile
Posts: 23
Post Thanks: 4
Thanked 1 Time in 1 Post
Default Re: Android Apps Won't Run

The CB forum is a native app! Unless you sideloaded the different. Android app that we have.

Well it appears I can not post the App World URL yet. ;). Anyways search CB 10 and you will find our app which I believe was written in cascades. In any event it is a native BFB app.
__________________
Rich C.

Blackberry history 7290>8700>(budget cuts took my BB)>9530 (bought myself)>9550,8703e(backup)>9650>9930>DevAlpha>9780 >Z10>Q10>Z10
Offline  
Old 12-13-2013, 03:51 AM   #3 (permalink)
Knows Where the Search Button Is
 
SGoodman's Avatar
 
Join Date: Nov 2012
Location: Canada
Model: 9670
PIN: N/A
Carrier: Telus Mobility
Posts: 38
Post Thanks: 2
Thanked 0 Times in 0 Posts
Question Re: Android Apps Won't Run

Sorry. CB Forums is showing a blank screen exactly like the other apps, so I thought it was an Android app. Also, it doesn't appear in Settings > Security > Application Permissions, just like the Android apps.

I don't know what 'sideloading' is, but I installed CB Forums from BlackBerry World.

Also, there's someone who thinks that it's actually malware.

Thanks,
Shane.
__________________
Z10 (version 10.2.1.3247)
LTE Playbook (version 2.1.0.1917)
Offline  
Old 12-13-2013, 05:13 AM   #4 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,807
Post Thanks: 33
Thanked 442 Times in 382 Posts
Default Re: Android Apps Won't Run

I think the owner of that forum is making a joke. CB forums may be many terrible things (including intolerant) but their app is not malware.
Offline  
Old 12-13-2013, 06:46 AM   #5 (permalink)
BlackBerry Extraordinaire
 
ZombieBerry's Avatar
 
Join Date: Sep 2010
Location: Toronto
Model: Z10
OS: 10.3.xxxx
PIN: 2AB9C463
Carrier: WIND
Posts: 2,338
Post Thanks: 30
Thanked 340 Times in 279 Posts
Default Re: Android Apps Won't Run

Yeah, I don't see Joe actually believing that the CB app is malware...lol
__________________
fere libenter homines id quod volunt credunt
Online  
Old 12-13-2013, 01:37 PM   #6 (permalink)
Knows Where the Search Button Is
 
pkcable's Avatar
 
Join Date: Jan 2009
Model: Z10
OS: 10.2.1
PIN: N/A
Carrier: VZW & T-Mobile
Posts: 23
Post Thanks: 4
Thanked 1 Time in 1 Post
Default Re: Android Apps Won't Run

OH the PlayBook app, I'm sorry I misread the thread! My apologies. I will take a look from my play book tonight and if their is an issue I will get it reported to our tech people. (I am one of the mods over there)
__________________
Rich C.

Blackberry history 7290>8700>(budget cuts took my BB)>9530 (bought myself)>9550,8703e(backup)>9650>9930>DevAlpha>9780 >Z10>Q10>Z10
Offline  
Old 12-13-2013, 03:47 PM   #7 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,807
Post Thanks: 33
Thanked 442 Times in 382 Posts
Default Re: Android Apps Won't Run

You Are?
Offline  
Old 12-13-2013, 09:01 PM   #8 (permalink)
Knows Where the Search Button Is
 
pkcable's Avatar
 
Join Date: Jan 2009
Model: Z10
OS: 10.2.1
PIN: N/A
Carrier: VZW & T-Mobile
Posts: 23
Post Thanks: 4
Thanked 1 Time in 1 Post
Default Re: Android Apps Won't Run

Quote:
Originally Posted by NJBlackBerry View Post
You Are?
Which will only ever be mentioned in the content where it can be helpful. ;).


Anyways I checked and the app itself works fine on my device. I agree it does appear to be an android port, as it uses back swipes. However I will ask around to make sure.

Have you thought about doing an OS reload?
__________________
Rich C.

Blackberry history 7290>8700>(budget cuts took my BB)>9530 (bought myself)>9550,8703e(backup)>9650>9930>DevAlpha>9780 >Z10>Q10>Z10
Offline  
Old 12-14-2013, 12:56 AM   #9 (permalink)
Knows Where the Search Button Is
 
SGoodman's Avatar
 
Join Date: Nov 2012
Location: Canada
Model: 9670
PIN: N/A
Carrier: Telus Mobility
Posts: 38
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: Android Apps Won't Run

Quote:
Originally Posted by pkcable View Post
Anyways I checked and the app itself works fine on my device. I agree it does appear to be an android port, as it uses back swipes. However I will ask around to make sure.

Have you thought about doing an OS reload?
What are "back swipes"?

I just did another restore from BlackBerry Desktop, but I still have the same problem. How to I do an OS reload?

Thanks,
Shane.
__________________
Z10 (version 10.2.1.3247)
LTE Playbook (version 2.1.0.1917)
Offline  
Old 12-14-2013, 07:34 AM   #10 (permalink)
Knows Where the Search Button Is
 
pkcable's Avatar
 
Join Date: Jan 2009
Model: Z10
OS: 10.2.1
PIN: N/A
Carrier: VZW & T-Mobile
Posts: 23
Post Thanks: 4
Thanked 1 Time in 1 Post
Default Re: Android Apps Won't Run

Yes the Crackberry PB app is an android port. Back swipes are where you swipe from right to left on the bottom bezel to emulate pressing the android back arrow.

You reload the OS through Desktop Manager, there is probably a there here that explains, let me see if I can did one up. If not can I post one from the BB site or CB, NJ? I guess the BB site should be fine.


Edit: http://supportforums.blackberry.com/...Y/td-p/1822649
__________________
Rich C.

Blackberry history 7290>8700>(budget cuts took my BB)>9530 (bought myself)>9550,8703e(backup)>9650>9930>DevAlpha>9780 >Z10>Q10>Z10

Last edited by pkcable : 12-14-2013 at 07:47 AM. Reason: Adding link from bb support forum
Offline  
The Following User Says Thank You to pkcable For This Useful Post:
SGoodman (12-14-2013)
Old 12-14-2013, 02:56 PM   #11 (permalink)
Latino Hasta La Muerte
 
Join Date: Jan 2005
Location: Denville, NJ.
Model: 7250
OS: 4.1
PIN: G!!!
Carrier: Verizon
Posts: 9,040
Post Thanks: 51
Thanked 305 Times in 293 Posts
Default Re: Android Apps Won't Run

I've had apps fail to show up in the Security settings after installation, but a restart sorted it out. Seems like the restart forced the completion of the install process.
Offline  
Old 12-14-2013, 09:34 PM   #12 (permalink)
Knows Where the Search Button Is
 
SGoodman's Avatar
 
Join Date: Nov 2012
Location: Canada
Model: 9670
PIN: N/A
Carrier: Telus Mobility
Posts: 38
Post Thanks: 2
Thanked 0 Times in 0 Posts
Thumbs up Re: Android Apps Won't Run

I reloaded the OS from BlackBerry Desktop, and it seems to be working now. This feature isn't documented in the BlackBerry Desktop User Guide, which is strange.

I'm glad that my PlayBook is working again, but I still don't know what caused the Andoid apps to stop working. I'm going to install each app individually, instead of doing another restore from BlackBerry Desktop, in case Desktop was the culprit.

There is a line that appears at the bottom of most Android apps which includes a back button (click thumbnail). I'm guessing this is what you meant by "back swipes"?

Thanks all,
Shane.
Attached Thumbnails
Android Apps Won't Run-lastpass.png  
__________________
Z10 (version 10.2.1.3247)
LTE Playbook (version 2.1.0.1917)
Offline  
Old 12-16-2013, 09:28 AM   #13 (permalink)
Knows Where the Search Button Is
 
pkcable's Avatar
 
Join Date: Jan 2009
Model: Z10
OS: 10.2.1
PIN: N/A
Carrier: VZW & T-Mobile
Posts: 23
Post Thanks: 4
Thanked 1 Time in 1 Post
Default Re: Android Apps Won't Run

Quote:
Originally Posted by SGoodman View Post
I reloaded the OS from BlackBerry Desktop, and it seems to be working now. This feature isn't documented in the BlackBerry Desktop User Guide, which is strange.

I'm glad that my PlayBook is working again, but I still don't know what caused the Andoid apps to stop working. I'm going to install each app individually, instead of doing another restore from BlackBerry Desktop, in case Desktop was the culprit.

There is a line that appears at the bottom of most Android apps which includes a back button (click thumbnail). I'm guessing this is what you meant by "back swipes"?

Thanks all,
Shane.

Yes some apps have that back arrow, but not all, also try swiping along the bottom bezel on your PB while in an Android app, from right to left, this will make your Android app go back 1 screen. This is called a back swipe.
__________________
Rich C.

Blackberry history 7290>8700>(budget cuts took my BB)>9530 (bought myself)>9550,8703e(backup)>9650>9930>DevAlpha>9780 >Z10>Q10>Z10
Offline  
Old 12-17-2013, 01:14 AM   #14 (permalink)
Knows Where the Search Button Is
 
SGoodman's Avatar
 
Join Date: Nov 2012
Location: Canada
Model: 9670
PIN: N/A
Carrier: Telus Mobility
Posts: 38
Post Thanks: 2
Thanked 0 Times in 0 Posts
Red face Re: Android Apps Won't Run

Some apps were missing from BlackBerry World, so I decided to do a Restore from BlackBerry Desktop. Afterwards, though, Android apps weren't working again. At least I know now what has been causing Android apps to stop working. I had to do a Repair from BlackBerry Desktop, and I'm back to reinstalling the apps individually.

Shane.
__________________
Z10 (version 10.2.1.3247)
LTE Playbook (version 2.1.0.1917)
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: Android Apps Won't Run
Thread Thread Starter Forum Replies Last Post
Will Blackberry Playbook Have Android Support? Jimcarry General BlackBerry Discussion 1 03-06-2011 10:51 PM
Android Apps Hacked ARCANGEL63 BlackBerry and Mobile Security 2 03-02-2011 05:22 PM
Eclipse can't run apps on simulator ahmdsd_ostora Developer Forum 3 02-01-2010 09:33 AM
Will Pearl apps run on 8800 or 8300? Arkay General Legacy Device Discussion 1 03-23-2007 05:42 AM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.