BlackBerry Forums Support Community
              

Closed Thread
 
LinkBack Thread Tools
Old 05-21-2016, 02:58 PM   #1 (permalink)
New Member
 
Join Date: Apr 2016
Model: Q10
PIN: N/A
Carrier: Rogers
Posts: 12
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default Q10 vibrate not working

Please Login to Remove!

I recently bought a used Q10 in very good condition. The only problem I can find is that vibrate doesn't work, no matter what the Notification settings. I ran the vibrate test in BBVE and it fails. So I assumed it was a hardware problem and took the phone to a service centre for repair. They kept it four days and finally called me. They said they replaced the vibrator but that did not fix the problem. They had no idea about the cause. Incidentally, they said there were no signs of water damage and this was very likely the first time the case was opened.

So now I'm out $60 and no closer to a solution. Is this possibly a software issue? Any help would be greatly appreciated.
Offline  
Old 05-22-2016, 08:28 PM   #2 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: Cheerios
PIN: No Pin just a Tack
Carrier: at&t
Posts: 9,522
Post Thanks: 80
Thanked 804 Times in 773 Posts
Default Re: Q10 vibrate not working

If your phone does not have a hardware issue I would suggest doing a reload to factory OS and Apps. It is possible the OS is corrupted or one of the apps is causing this.
You can do a backup for any data you may want to keep but try the reload and testing before you reload a backup. If it works then you can load the apps one at a time to see if one is causing this.

If all fails then it may just be hardware and it might be worth selecting a ring tone that wont cause you any problems if it goes off.
__________________
If someone helps, tell them by clicking the Thanks button


9810 on BES
Z10 on BIS
Offline  
Old 05-22-2016, 09:24 PM   #3 (permalink)
New Member
 
Join Date: Apr 2016
Model: Q10
PIN: N/A
Carrier: Rogers
Posts: 12
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: Q10 vibrate not working

I tried a backup and then reloading the device software via the preferences menu in BlackBerry Link. The vibrator still didn't work. The software release was 10.3.2.2474, just as it was on the phone before the backup. I would try reverting to an earlier version just as a check, but I don't know where to find earlier factory software versions.

Restoring from a backup is something of a pain, as it does not restore all settings, and it takes me about 20-30 minutes of tweaking to put Humpty Dumpty precisely back together again. I suppose I'm wishing for something like Windows Restore, but I guess that's a lot to expect of a mobile OS.

If it is a hardware issue, I don't see how the service techs couldn't have fixed it by replacing the vibrator board. Is there a true Jedi Master of BlackBerry hardware I need to consult? It seems like there are tens of thousands of people who are successful repairing mobile phones today.

I really need vibrate to work. There are times I need to leave the phone on but to silence the ringer. The workaround to select another very quiet ring tone and then readjust the volume both before and after is a time-consuming exercise in frustration. I'd go crazy after about the tenth time that happened in three weeks.

Surely there's a fix for this. All problems *do* have solutions, however much time, effort and money it takes. I have an excess of the first two, if not the third, and I'm not one to give up.
Offline  
Old 05-23-2016, 10:34 AM   #4 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: Cheerios
PIN: No Pin just a Tack
Carrier: at&t
Posts: 9,522
Post Thanks: 80
Thanked 804 Times in 773 Posts
Default Re: Q10 vibrate not working

I searched for the older software but found out Blackberry seems to have removed all the older versions and requires the use of LINK to do any updates from their site.
You might try the Crackberry site for a version higher than yours. 10.3.1.2576
Indications are the older versions did have various issues and yours may be one but it's worth a try.
Be sure to read the info on the site for details.

BlackBerry OS 10.3.1.2582 update files now available for download | CrackBerry.com
__________________
If someone helps, tell them by clicking the Thanks button


9810 on BES
Z10 on BIS
Offline  
The Following User Says Thank You to tsac For This Useful Post:
BillPierce (05-23-2016)
Old 05-23-2016, 11:05 AM   #5 (permalink)
New Member
 
Join Date: Apr 2016
Model: Q10
PIN: N/A
Carrier: Rogers
Posts: 12
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: Q10 vibrate not working

Thanks for the information. I'll try it when I get a couple of hours of free time.
Offline  
Old 05-23-2016, 05:29 PM   #6 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: Cheerios
PIN: No Pin just a Tack
Carrier: at&t
Posts: 9,522
Post Thanks: 80
Thanked 804 Times in 773 Posts
Default Re: Q10 vibrate not working

Just make sure you read all the posts for any details and follow the information. I have not used this for updates but seems like a lot of people have.
__________________
If someone helps, tell them by clicking the Thanks button


9810 on BES
Z10 on BIS
Offline  
The Following User Says Thank You to tsac For This Useful Post:
BillPierce (05-23-2016)
Old 06-02-2016, 09:53 AM   #7 (permalink)
New Member
 
Join Date: Apr 2016
Model: Q10
PIN: N/A
Carrier: Rogers
Posts: 12
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: Q10 vibrate not working

I finally got time to try downloading earlier software and wiping the phone. It's not possible to revert to versions before 10.3.2., so I tried both versions 10.3.2.2339 and 10.3.02.2876. Unfortunately vibration continues not to work with either of these and no additional software installed.

Despite my earlier experience, I really don't see how I have any choice but to conclude the problem is hardware-related. Yet, the service technician I originally took it to insisted that the vibrator is not the issue and he could find nothing wrong apart from the fact that it doesn't vibrate.

So what do I try next? I'm afraid that if I take it to someone else I will hear the same thing and I will be out another repair charge for what couldn't be repaired.

Is there a Jedi Master of BlackBerry repair?
Offline  
Old 06-02-2016, 08:33 PM   #8 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: Cheerios
PIN: No Pin just a Tack
Carrier: at&t
Posts: 9,522
Post Thanks: 80
Thanked 804 Times in 773 Posts
Default Re: Q10 vibrate not working

You might try a different repair shop in your area but let them know you tried before and what you were told.

But try this link on reverting before you do.

https://supportforums.blackberry.com...e/td-p/2477759
__________________
If someone helps, tell them by clicking the Thanks button


9810 on BES
Z10 on BIS
Offline  
Old 06-02-2016, 11:40 PM   #9 (permalink)
New Member
 
Join Date: Jun 2016
Model: Q5
PIN: N/A
Carrier: AT&T
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Q10 vibrate not working

If the tech was being honest in saying he replaced the vibrator, then it's more likely the mainboard and a single output transistor or voltage output signal (series of smaller transistors that send voltage to a specific device)

Something like this can go bad but the rest of the components still work, in which case you are either out of luck and would have to purchase a new one, or find a tech who has a solider reflow machine and/or the skills and time to fix it. The transistor or component would be super cheap, the problem is the labor.

90% of phones theoretically can be easily fixed if you have the knowhow, its the expensive equipment to do so, and the time/effort people want to put in.
Offline  
Old 06-03-2016, 10:21 AM   #10 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: Cheerios
PIN: No Pin just a Tack
Carrier: at&t
Posts: 9,522
Post Thanks: 80
Thanked 804 Times in 773 Posts
Default Re: Q10 vibrate not working

You would think the tech would check to see the voltage to the vibrator is on when it should be during a test. A Simple test that would show the issue is not the vibrator and is in the main board.
I'm going with either inexperience or work not really done.
__________________
If someone helps, tell them by clicking the Thanks button


9810 on BES
Z10 on BIS
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: Q10 vibrate not working
Thread Thread Starter Forum Replies Last Post
OS, Hardwar, or Carrier Problem? Ringer and Vibrate Stopped working. muppetjones General BlackBerry Discussion 1 05-17-2009 07:25 AM
vibrate profile doesnt vibrate.....???? curveme General BlackBerry Discussion 0 05-27-2008 01:33 PM
Developers: Add Custom Vibrate Notifications to your apps (even vibrate in morsecode) Mark Rejhon Aftermarket Software 5 02-08-2008 09:50 PM
New Pearl -- Vibrate Not working tblackt General 8100 Series Discussion - Pearl 1 01-08-2007 03:58 PM
Vibrate No Longer Working??? mdkrebs11 General 8100 Series Discussion - Pearl 8 01-01-2007 09:23 AM

Vintage MAC Tools Machine Steel Numbers Stamp Set FS-316 (3/16")
$25.0
Vintage MAC Tools Machine Steel Numbers Stamp Set FS-316 (3/16Vintage MAC PB19 USA Long Industrial SCREWDRIVER flat slotted Pry Bar
$30.0
Vintage MAC PB19 USA Long Industrial SCREWDRIVER flat slotted Pry Bar pictureVintage 1/2" Drive MAC VUI 166T 6 Point Impact Swivel Socket
$11.95
Vintage 1/27 Vtg Kodak Color Micro Diskettes 3 1/2" MF2-DD 2S2D 1988,1990 Mac Start-up Disk
$10.39
7 Vtg Kodak Color Micro Diskettes 3 1/2GW Instruments MacADIOS - Vintage Mac Lab Interface 411
$99.0
GW Instruments MacADIOS - Vintage Mac Lab Interface 411 picture






Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.