BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-24-2006, 03:51 PM   #1 (permalink)
New Member
 
Join Date: Oct 2006
Model: 8700c
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default GPS problem

Please Login to Remove!

I've written a background module program which gets the GPS location every five minutes and sends it to a server. It wortks great for a period of time.

Every so often (almost always when it is inside) it loses the GPS signal. When this happens, no http call is made to send the info to the server. That's fine - it's supposed to work that way. But when the phone is taken outside, it's variable whether the program starts sending the signals again. Sometimes it does. But often it does not. I can't figure out why it sometimes works again and sometimes not.

Powering the phone down completely and then up again fixes the issue. But I don't want people to have to do that.

Does anyone have any ideas?

Thanks!
Offline  
Old 10-24-2006, 07:10 PM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Jan 2005
Model: Many
Carrier: Sprint
Posts: 1,475
Post Thanks: 0
Thanked 6 Times in 5 Posts
Default

What model BB?
Offline  
Old 10-24-2006, 08:08 PM   #3 (permalink)
New Member
 
Join Date: Oct 2006
Model: 8700c
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

7100i
Offline  
Old 10-24-2006, 10:01 PM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Jan 2005
Model: Many
Carrier: Sprint
Posts: 1,475
Post Thanks: 0
Thanked 6 Times in 5 Posts
Default

Not a clue. All the GPS apps I sell on iDEN BB's work.
Offline  
Old 11-04-2006, 11:16 AM   #5 (permalink)
New Member
 
Join Date: Mar 2006
Model: 7520
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

Take a look at this article at Blackberry.com KB# DB-00462 (I can't post the link on this forum until I make at least 10 posts...)
Offline  
Old 11-22-2006, 09:54 PM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Model: 8700r
Carrier: Rogers
Posts: 22
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question Midlet code ?

Hi,

I am looking exactly for the same application.. Did you develop it using MIDPlet or RIMlet ?

Thank you,

Marat
Offline  
Old 12-10-2006, 04:28 PM   #7 (permalink)
New Member
 
Join Date: Dec 2006
Model: 7520
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default same problem

Same problem for me. I am trying to track it down.
If the application isn't a background app and it a midlet it seems to pick the signal back up whenever an update is made.
I don't know why. I am really struggling to find a solution as well.
Ron


Quote:
Originally Posted by aecarroll
I've written a background module program which gets the GPS location every five minutes and sends it to a server. It wortks great for a period of time.

Every so often (almost always when it is inside) it loses the GPS signal. When this happens, no http call is made to send the info to the server. That's fine - it's supposed to work that way. But when the phone is taken outside, it's variable whether the program starts sending the signals again. Sometimes it does. But often it does not. I can't figure out why it sometimes works again and sometimes not.

Powering the phone down completely and then up again fixes the issue. But I don't want people to have to do that.

Does anyone have any ideas?

Thanks!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.