BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-19-2007, 10:52 AM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: May 2005
Model: 8800
OS: hybrid
Carrier: Proximus, BE
Posts: 55
Post Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up amAze GPS - first findings

Please Login to Remove!

Hi,

I've installed amAze GPS (http://www.amazegps.com/) on my 8800. Here are my first findings:

Getting it to work
1. OTA download from their site didn't work out (error 500).
2. Downloaded the app to my pc and installed it without problems using the apploader.
3. When you first launch the app you need to login or create a new user (this is best done from the site, it's free)
4. Next you encounter a 8800 bug, it says to hit the P-key to start, but it's actually the O-key (they brought it over from the Pearl incorrectly, it's still beta for the 8800)

First test runs
- Maps load a bit slow on GPRS because they are very detailed. Seems to work just OK on EDGE though.
- You can choose between map view and arrow view. Arrow view loads quicker and consumes less of your dataplan
- GPS positioning is fast (faster than BB maps or Google maps)
- Routing works really well and accurate.
- Route recalculation is fast.
- Voice commands are very clear, even better when connected to a Bluetooth carkit (tested on the Parrot CK3100).

Conclusion
This is a great free GPS app with voice commands and recalculating capabilities.
There are a few extra utilities (weather forecast, yellow page search,...) which I haven't tried yet but seem handy while out in the wild.

Recommended!

Last edited by Phrozen Horse : 09-19-2007 at 10:54 AM.
Offline  
Old 09-19-2007, 11:00 AM   #2 (permalink)
Thumbs Must Hurt
 
Pentarus's Avatar
 
Join Date: Dec 2004
Location: Montreal
Model: 8330
Carrier: Bell Mobility
Posts: 135
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Phrozen Horse View Post

Getting it to work
1. OTA download from their site didn't work out (error 500).
Use WAP Browser and point to wap.AmazeGPS.com... I had the same issue using the internet browser. Also works very well on a 8830.
__________________
Pentarus
Offline  
Old 09-19-2007, 07:34 PM   #3 (permalink)
New Member
 
Join Date: Mar 2006
Location: Montreal, Canada
Model: 8310
Carrier: Rogers
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Will this work on an 8310?

I'm gonna try it anyway ;)

Found that there is a BETA version alos. Downloading it OTA right now.

Well I'm having all kinds of trouble with the WAP browser. Just got the 8310 today and will have to pay a visit to my tech guy tomorrow to see whats up (or *gasp* call ROGERS!).

I managed to copy the direct OTA .jad link to the WAP browser and initiate a download, but at about 30% it fails...

Last edited by Ohlias : 09-19-2007 at 08:59 PM. Reason: Update
Offline  
Old 09-20-2007, 02:42 AM   #4 (permalink)
Thumbs Must Hurt
 
Join Date: May 2005
Model: 8800
OS: hybrid
Carrier: Proximus, BE
Posts: 55
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Why don't you try downloading it to you pc and installing it using apploader?
Offline  
Old 09-20-2007, 06:10 PM   #5 (permalink)
New Member
 
Join Date: Mar 2006
Location: Montreal, Canada
Model: 8310
Carrier: Rogers
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I tried this and got a "no applications found error". Perhaps I'm doing something wrong. The situation is also complicated by the fact that I am on a BES server with work through Lotus Notes (Domino). I've got all the files on my desk top and point to them with the app loader but get errors.

Anyone else experience similar problems>

How is the amAze software for Canada?
Offline  
Old 09-20-2007, 06:54 PM   #6 (permalink)
Thumbs Must Hurt
 
DaddyFizzle's Avatar
 
Join Date: Apr 2006
Location: San Francisco
Model: 9900
Carrier: AT&T
Posts: 60
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Works perfectly!
Offline  
Old 09-21-2007, 01:58 AM   #7 (permalink)
Thumbs Must Hurt
 
Join Date: May 2005
Model: 8800
OS: hybrid
Carrier: Proximus, BE
Posts: 55
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm on BES/Domino and it works - don't think it's related
Offline  
Old 09-21-2007, 10:10 AM   #8 (permalink)
CrackBerry Addict
 
lraed74's Avatar
 
Join Date: Aug 2005
Location: Columbus, OH
Model: S2
OS: 5.0
Carrier: Verizon
Posts: 720
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Will this work on the 8703e?
Offline  
Old 09-21-2007, 10:19 AM   #9 (permalink)
CrackBerry Addict
 
Spamdumpster's Avatar
 
Join Date: Jun 2006
Location: Boston, Mass.
Model: 8820
Carrier: at&t
Posts: 598
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It keeps trying to download the sound files and tells me that the "sounds download failed". Any idea why? Everything else on the device works fine.
Offline  
Old 09-21-2007, 10:32 AM   #10 (permalink)
Thumbs Must Hurt
 
Join Date: Jul 2007
Location: Kent, UK
Model: Bold
PIN: N/A
Carrier: Orange
Posts: 83
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just installed this on my Nokia n73 so not an exact comparison. So far for a free bit of software it looks pretty good. The maps do seem to take awhile to download though.

The BlackBerry I have at the moment doesn't have a useable dataplan but once I get my main test BB back I will give the BB version a run to.

Going to use it this weekend as I have quite a lot of traveling to do.
Offline  
Old 09-21-2007, 10:45 AM   #11 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Jun 2005
Location: NJ
Model: 9700
OS: 5.0.0.405
Carrier: AT&T
Posts: 304
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Same here with the sound files failing to download. I created an account on the amazegps forum and patiently waiting for a response.

Others on the forum seems to have the same issue and amazegps sent them the files.
Offline  
Old 09-25-2007, 10:52 AM   #12 (permalink)
Knows Where the Search Button Is
 
FgCrump's Avatar
 
Join Date: Jan 2005
Location: North Carolina
Model: 8130
Carrier: alltel
Posts: 27
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This application does not work on all BBs listed on their web site. The admin says it requires a version of BB OS that includes JSR-82. The error is : Error starting amaze_4_000: Class 'javax.bluetooth.DiscoveryListener' not found.

Admin answer:Usually, this error means that the phone doesn't support JSR-82. This JSR is what enables bluetooth connection at the same time that a JAVA application is running. In BlackBerry's case - the support/not support specific JSR depends on the software version of the phone and not on its model.

I am running the latest version OS for my 7130e and the 7130e is listed as a supported device on Amaze"s site. There may be other phones with pre 4.2 os that even though listed on the amaze site are not supported.
Bummer!
Offline  
Old 09-25-2007, 11:03 AM   #13 (permalink)
Thumbs Must Hurt
 
matthiasj's Avatar
 
Join Date: Jul 2007
Location: KY
Model: 9700
OS: 5.0.0.566
PIN: 2164B714
Carrier: AT&T
Posts: 171
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

it works but i had to install it via desktop manager. i havent tried it because i have no puck.
Offline  
Old 09-28-2007, 03:17 PM   #14 (permalink)
Thumbs Must Hurt
 
thunder33cat's Avatar
 
Join Date: Aug 2005
Location: SE Pennsylvania
Model: 9800
Carrier: AT&T
Posts: 158
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ugh. Tried it vs. Telenav for a trip from DC to the Philly burbs...

Interface: The interface on the 8830 is a bit cludgy... Address entries and such are less intuitive and take longer.

Use: Went to enter my home address (established neighborhood and street) and it couldn't locate it, while it provided some rather nonsensical alternatives in Western PA. I tried various methods to get at a more refined search to no avail. Ended up choosing the nearest town center as destination. The display and audio are generally very good. I like the turn by turn display more than the map, for several reasons... (1) lag and map refresh - even with a solid EVDO signal, I was outdriving the map on a consistent basis, (2) the compass circle clutters the interface, (3) the color choices are pretty harsh in terms of contrast and clarity, and (4) the location arrow is huge. Additionally, the software gets confused at interstate interchanges with cloverleaves and under/overpasses, locking onto the wrong road, which leads to... a prolonged delay while re-routing.

So... why is it still on my Blackberry? I think it has a lot of promise. I like the map detail. I haven't had a chance to really check out the aerial and hybrid maps. The voice prompts are fairly good. I think it will be fine for some pedestrian and biking use for right now. I hope they keep working on refining this, because I'd like to have a choice and not be relegated to Telenav.

My $0.02.
Offline  
Old 10-08-2007, 02:06 PM   #15 (permalink)
New Member
 
Join Date: Oct 2007
Model: 8300
PIN: N/A
Carrier: VZW
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default amazeGPS on 8830 (Verizon)

Has anyone got amazeGPS running on Verizon 8830 World Edition? I was able
to install the app, but when I run it I get "Communication Problem"

Any help is appreciated.
Offline  
Old 10-09-2007, 08:46 AM   #16 (permalink)
Thumbs Must Hurt
 
thunder33cat's Avatar
 
Join Date: Aug 2005
Location: SE Pennsylvania
Model: 9800
Carrier: AT&T
Posts: 158
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mrandazzo View Post
Has anyone got amazeGPS running on Verizon 8830 World Edition? I was able
to install the app, but when I run it I get "Communication Problem"

Any help is appreciated.
I have had it working on my 8830 using an external bluetooth puck (iBlue 737). My comments on the experience are above.
Offline  
Old 10-09-2007, 10:30 AM   #17 (permalink)
New Member
 
Join Date: Oct 2007
Model: 8300
PIN: N/A
Carrier: VZW
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 8830 on Verizon

thunder,

I don't have a puck yet, I thought I would be able to at least run the s/w.....but when I run it I see the progress bar move a little and about 15 seconds later I get a communication problem. If you have bluetooth disabled, do you get an error?

Did you have to change any settings? (APN, etc). fwiw, I able to get web access using the BB Browser...
Offline  
Old 10-10-2007, 09:26 AM   #18 (permalink)
Thumbs Must Hurt
 
thunder33cat's Avatar
 
Join Date: Aug 2005
Location: SE Pennsylvania
Model: 9800
Carrier: AT&T
Posts: 158
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I don't recall changing settings, nor any errors with no puck available. I'll try and double check. I actually removed amaze during my last application purge.
Offline  
Old 10-17-2007, 03:32 PM   #19 (permalink)
New Member
 
Join Date: Jun 2007
Model: 8300
PIN: N/A
Carrier: AT&T
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

works great with my 8300 and the BT GPS unit that ATT is selling on their site.
Offline  
Old 10-17-2007, 03:36 PM   #20 (permalink)
Thumbs Must Hurt
 
Join Date: May 2005
Model: 8800
OS: hybrid
Carrier: Proximus, BE
Posts: 55
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Currently the people at Locationet are working on a new version for the 8800.
I'm betatesting this new version and it looks very promising.

Any suggestions for improvement you might have can be added on their forum.

Keep you posted.

Ph.H.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.