BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-11-2007, 12:56 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2006
Location: San Diego
Model: 9700
Carrier: AT&T
Posts: 34
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default invisiblSHIELD's screen cover

Please Login to Remove!

I had the invisiblSHIELD screen cover installed on my 8300 and it was perfect no issues what so ever. I recently bought the 8310 and installed another shield cover from invisibleSHIELD. The screen cover has had 1 week to set up, but it still has that initial distortion. Itxxx8217;s almost like there is moisture trapped under the shield. It gives the screen a slight blurry look. My 8300 shield had the same issue but went away a day later after the shield and sealant set in. Has anyone else had this issue?
Offline  
Old 11-24-2007, 01:14 PM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Location: Canada
Model: 8310
Carrier: Rogers
Posts: 45
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same issue. It might still go away, it's been 30 hours since I installed the protector.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.