BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-23-2008, 10:43 AM   #1 (permalink)
New Member
 
Join Date: Aug 2008
Model: 9530
PIN: N/A
Carrier: T-Mobile
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 8100 pearl screen

Please Login to Remove!

I have a blackberry pearl and there is a white haze from the sides of screen underneath the lens. the phone works and I can see the screen when it is lit but the quality is lowered because of the haze on the image. has anyone ever had this before? is there a way to get rid of it or clean it? or do i need to buy another phone or screen? thanks!
Offline  
Old 12-23-2008, 11:03 AM   #2 (permalink)
Stuck In The '70's Mod
 
ndub33's Avatar
 
Join Date: Feb 2006
Location: The 'burbs east of Seattle.
Model: 9810
Carrier: T-Mobile
Posts: 7,599
Post Thanks: 0
Thanked 4 Times in 4 Posts
Default

Welcome to the forums!

You can try a battery pull , but I suspect that you have pixels going out on your display, which would mean screen repalcement is probably your best bet for a fix.
__________________
1st Step in Troubleshooting: Do you have a BlackBerry Data Plan?
2nd Step in Troubleshooting: Pull the Battery.
Offline  
Old 12-23-2008, 11:24 AM   #3 (permalink)
New Member
 
Join Date: Aug 2008
Model: 9530
PIN: N/A
Carrier: T-Mobile
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks, is this a do-it-yourself project or do i need to hire an electrical engineer?
Offline  
Old 12-25-2008, 02:11 PM   #4 (permalink)
New Member
 
Join Date: Dec 2008
Model: 8100
PIN: N/A
Carrier: Rogers Wireless
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

you might want to bring it in and let someone else with expertise fix-it for ya.
Voids warranty if you dismantle it yourself
Offline  
Old 12-25-2008, 04:22 PM   #5 (permalink)
New Member
 
Join Date: Dec 2008
Model: 8110
PIN: N/A
Carrier: ATT
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question Error 507 BB Pearl 8110

Tried to upgrade the 4.0 and it went completely blank, then it came back on with a circle with a line across it with square circle triangle in it, please can some one help a granny fix it, or do I have to get another one? thanks Merry Christmas my carrier is ATT
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.