BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Hardware & Accessories (http://www.blackberryforums.com/hardware-accessories/)
-   -   My BB does not turn on. (http://www.blackberryforums.com/hardware-accessories/223812-my-bb-does-not-turn.html)

b&o 04-08-2010 03:58 AM

My BB does not turn on.
 
My BlackBerry Bold 9000 does not turn on when I install the battery. No LED, no display or any sign of life. All I have to do is remove the battery, plug in the wall charger, reinstall the battery when the red LED turns on and unplug the wall charger. From now on the phone turns on and operates normally. I can turn it off then on again but the problem reoccurs if I remove the battery.

What's the problem with my phone? Please help.

aiharkness 04-08-2010 06:42 AM

Wirelessly posted

Thinking key/button failure, but a question ... Do you really have to connect it to the charger to make it power on? When it won't turn on, if you simply remove the battery and replace after half a minute, won't it boot up?

EDIT: I looked at OP again and see, first sentence, it seems the answer is that simply inserting the battery does not work.

Some other thoughts: Is the battery tight in the compartment, and contacts are being pressed against each other? What do the contacts on both the battery and the blackberry look like? Are they clean and more or less shiny, or dark and dirty looking?

b&o 04-08-2010 09:42 PM

Thanks, Ira

Yes, inserting the battery does not work. The phone does not turn on. No LED. No any sign of life. Plugging in the wall charger (with the battery in the phone) does not help. All I have to do is unplug the charger, remove the battery, plug in the charger for the LED turns on then insert the battery back. Now unplug the charger and the phone boots up. From now on the phone functions normally. I can turn it off then on again, charge the battery with the wall charger... Everything works normally until for some reason the battery being removed and inserted back.

The battery is fully charged and I've tried with 2 other batteries. The batteries and the phone is quite new so I think there's no issue with the contacts. BTW, I found 2 things:

1. The phone clock stopped at the time the battery was removed.
2. If the battery is inserted immediately after being removed (within 1 or 2 secs) then the phone boots up normally.

Someone told me it's the CMOS battery that caused the issue. I don't know but is there a so-called cmos battery for a BlackBerry Bold? Can it be dead and how do I replace it?

Do you have any idea? Thank you very much.

John Clark 04-08-2010 11:48 PM

I would check with HorizonWirelessOnline.com - Horizon Wireless, The World’s Cellular Repair Center . If anyone can tell you, it's them. If it needs repair, they can do that too.

b&o 04-09-2010 05:02 AM

Quote:

Originally Posted by John Clark (Post 1591959)
I would check with HorizonWirelessOnline.com - Horizon Wireless, The World’s Cellular Repair Center . If anyone can tell you, it's them. If it needs repair, they can do that too.

I may consider taking the phone to a technician. Thanks.

aiharkness 04-09-2010 07:19 AM

Wirelessly posted

Ditto re talking to a repair tech. Post an update when you have the time.


All times are GMT -5. The time now is 07:36 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.