BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-21-2005, 01:30 PM   #1 (permalink)
New Member
 
Join Date: Mar 2005
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Angry Caller ID on 7250?!?!?@

Please Login to Remove!

Was using 6750 and loved the fact that when a call came in, it would display caller's name. Moved my address book over to the new 7250 and it only displays numeric caller IDs (the names are in the address book as before). If you have any ideas on how to get this device to display the names of incoming calls, please let me know!!!
Offline  
Old 03-21-2005, 04:36 PM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Mar 2005
Posts: 21
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I noticed this also, make sure your not putting a "1" in front of the numbers in your address book, that should resolved the issue.
Offline  
Old 03-21-2005, 10:32 PM   #3 (permalink)
CrackBerry Addict
 
dkmadrid's Avatar
 
Join Date: Feb 2005
Location: Pueblo, CO
Model: 9530
Carrier: Verizon
Posts: 712
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Never had that problem, my caller id works wonderfully. But like Not Techy said, I do not store my numbers in the address book with a "1" in front.
Offline  
Old 04-02-2005, 06:08 AM   #4 (permalink)
New Member
 
Join Date: Apr 2005
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Wink BlackBerry 7520 Caller ID Not Displaying Contact Names

I've had the same problem with my BlackBerry 7250 from Nextel. You should disable the content protection from your Security menu in Options. This should fix your problem. If it doesn't repost and I will think of another sollution. However, its been working fine so far for me.
Offline  
Old 04-08-2005, 09:01 PM   #5 (permalink)
New Member
 
Join Date: Apr 2005
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same problem with the 7520. I upgraded to 4.0 and when I did my caller ID has gone away. Every call is displayed as "unknown number". I sync with MS outlook and do not use a "1" in the address. Further, I have made sure the content protection is disabled. Anyone else have a fix for this problem? Thanks
Offline  
Old 04-21-2005, 10:59 AM   #6 (permalink)
New Member
 
Join Date: Apr 2005
Model: 7250
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've found that when I sorted the names in the address book by last name then caller ID stopped working, when I went back to sorting by first name caller ID started working again.
Offline  
Old 04-22-2005, 11:00 AM   #7 (permalink)
Knows Where the Search Button Is
 
lmd2's Avatar
 
Join Date: Apr 2005
Location: NY
Model: 7100t
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default similar issue

I have a BB 7100t (2 weeks now and I luv it) and am with TMobile.
content protection is disabled
incoming calls are listed as "Private Number" or "Unknown Number" - and I am not sure what the difference is.
Am going to try removing the "1" from the numbers in my address book (will the calls still go out OK?)
if that doesn't work I will see if it is possible to remove the parenthesis as well. (maybe it wasn't such a usefull thing syncing with my Mac address book after all??)
I'll check back here to see if anyone else comes up with a definitive solution.
Thanx for the suggestions thus far-
lmd2
Offline  
Old 04-22-2005, 02:42 PM   #8 (permalink)
BlackBerry Extraordinaire
 
stonent's Avatar
 
Join Date: Oct 2004
Location: Fort Worth, Texas
Model: 8220
PIN: FFFFFFFF
Carrier: T-Mobile
Posts: 1,734
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

"Unknown Number" with Nextel means the Caller ID is disabled completely. You have to call Nextel to get it turned back on on their end.
__________________
Stonent

Prior: BES: 7510, 7520, 7290, 7230, 7130, 8220 (No Data Plan), Droid Eris
Post your question on the forum, don't PM me.
Offline  
Old 05-05-2005, 12:38 PM   #9 (permalink)
Knows Where the Search Button Is
 
MI_BB_TECH's Avatar
 
Join Date: May 2005
Location: Michigan
Model: 8530
Carrier: Verizon
Posts: 27
Post Thanks: 0
Thanked 0 Times in 0 Posts
Talking Same problem with 7520

I am a new wireless support tech here at the State of Michigan and have a client with exactly the same problem. I just did an upgrade to her 7520 to 4.0 and now every call comes in as "unknown", even if their number is listed in her address book.

We use GroupWise and Notifylink here. In looking at her account, I noticed that she has several address books. I suspected that it had something to do with the address book that is specified not having the numbers she is expecting to see.

After reading your post, I think I have a dual problem. I'll call Nextel to check on the caller ID issue and folow up with her address book!

I'm new to the forum and it looks like its already been time well spent!

Thanks for the tips!
Offline  
Old 05-09-2005, 09:51 AM   #10 (permalink)
New Member
 
Join Date: May 2005
Model: 7250
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

You do not need to dial a 1 with any wireless carrier I have used. (Nextel, Cingular, Sprint, and now Verizon.) I did not use a 1 and my CID works fine. The only ones that do not display are hte ones that are blocked on the callers end or if is is private. All others work as designed.
Offline  
Old 05-09-2005, 03:47 PM   #11 (permalink)
BBF Veteran
 
coreyg510's Avatar
 
Join Date: Apr 2005
Location: Lost in Translation
Model: 8700c
Carrier: Cingular
Posts: 3,190
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by eriq35
You do not need to dial a 1 with any wireless carrier I have used. (Nextel, Cingular, Sprint, and now Verizon.) I did not use a 1 and my CID works fine. The only ones that do not display are hte ones that are blocked on the callers end or if is is private. All others work as designed.
Having a 1 or not should not make a difference.
__________________
He's Back....and better than ever!
Offline  
Old 05-24-2005, 09:27 PM   #12 (permalink)
New Member
 
Join Date: May 2005
Model: 7290
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default caller id not working

just bought a new 7290 t-mobile. love it but caller id doesn't work. i don't use a 1 in front of the numbers and have tried the other suggestions. any suggestions?
Offline  
Old 05-25-2005, 02:56 PM   #13 (permalink)
Thumbs Must Hurt
 
HeadOffice's Avatar
 
Join Date: May 2005
Location: New York City
Model: 8700
Carrier: T-Mobile
Posts: 58
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Same here with 7290 & TMO...

Yep - no number identification on any landline call to my 7290. Any TMO cell phone to my 7290 works but all landline originating calls appear as 'Unknown number'.

Speak to the TMO support desk and realize how little they know about phones/PDAs and caller ID.

Hopefully someone will offer a fix soon...
__________________
HeadOffice
Offline  
Old 10-02-2006, 12:00 PM   #14 (permalink)
New Member
 
Join Date: Oct 2006
Model: 7250
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Caller id number only

I have a 7250 on 4.0 (verizon), content protection is disabled, but the contact number only is displayed, not the contact name. Any further suggestions?

Please disregard. I changed the sort to Last Name, started working. Then put the sort back to First name, it's still working so far

Last edited by jeffgian : 10-02-2006 at 12:07 PM.
Offline  
Old 10-12-2006, 06:28 PM   #15 (permalink)
Knows Where the Search Button Is
 
howlingthunder's Avatar
 
Join Date: Jun 2006
Model: 9630
Carrier: Sprint
Posts: 35
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had a customer that had the same issue. Upgraded handheld OS on Sprint 7250 to latest version - no luck. Tried all in this thread - no luck. Called Sprint and verified that the Caller ID service is on. They recommended I wipe and reload the handheld. Did it - no luck. That's weak Dude.
Offline  
Old 10-23-2006, 09:53 PM   #16 (permalink)
New Member
 
Join Date: Apr 2006
Location: Chicago
Model: 7520
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default This may do the trick. It worked for me and my 7520

I had the same problem up until a few minutes ago.
I was working on another issue I was having with my 7520 and its inability to save external updates to my address book.
I was reading a thread about the latter issue about a fix that entailed backing up the address book on the phone and then reloading that address backup back on the phone.
I am now able to update the address book externally.
This has been bugging me for quite a while.
I was then searching this site for a soultion to the caller id not displaying names only numbers even for contacts stored on the phone.
To my surprise I beleive that the load of the most current backup of the address book also solved the caller id issue.
I tried the caller id out with both content protection enabled as well as disabled and both worked.
Maybe its a fluke but I am content nonetheless.
Offline  
Old 08-22-2007, 09:06 AM   #17 (permalink)
New Member
 
Join Date: Aug 2007
Model: 8800
PIN: N/A
Carrier: Swisscom
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is an issue only people with password protection have.

On my 8800 the following worked:

Settings/Security Options/General Settings

look for Content Protection (which is assumebly enabled)
set Include Address Book from Yes to No (requires password)
Save

So long
Offline  
Old 09-12-2007, 10:52 PM   #18 (permalink)
New Member
 
Join Date: Sep 2007
Model: 8700
PIN: N/A
Carrier: TMO
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Getting incoming call's name from address book works

Agree with BlackBeauty -- I tried pretty much everything else on my 8700. The problem was with password protection AND content protection enabled.

Regardless of content protection setting, if your is unlocked when it rings, you do get the name from the address book.

When the is locked, if content protection is enabled (i.e., address book is encrypted), there is really no way for to locate the name from the address book.

To disable content protection: Options | Security Settings | General Settings | Content Protection -> Disabled.

Your choice: your privacy or your convenience -- isn't it always this way??
Offline  
Old 11-28-2007, 12:45 PM   #19 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have an 8830 and had the same issue with the caller ID. It would only show the number and not the name. Content Protection is enabled. My sort order for my contacts is by First Name. I switched this to Last Name and then back to First Name and saved it. Now the Caller ID works.
Offline  
Old 06-15-2008, 11:32 PM   #20 (permalink)
New Member
 
Join Date: Jul 2007
Model: 8703e
PIN: N/A
Carrier: sprint
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

Quote:
Originally Posted by PeterNic View Post
Agree with BlackBeauty -- I tried pretty much everything else on my 8700. The problem was with password protection AND content protection enabled.

Regardless of content protection setting, if your is unlocked when it rings, you do get the name from the address book.

When the is locked, if content protection is enabled (i.e., address book is encrypted), there is really no way for to locate the name from the address book.

To disable content protection: Options | Security Settings | General Settings | Content Protection -> Disabled.

Your choice: your privacy or your convenience -- isn't it always this way??
You my friend should be hired to train the blackberry support people. Worked like a charm, makes sense what you stated. What seemed like intermittent caller id failure in my case was actually caller id working with my phone unlocked and not working when it was locked. I never realized that this was the case until I read your post, did some testing to recreate the caller id failure.

Obviously the fix worked! Kudos!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.