BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-28-2008, 12:00 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2008
Model: 8130
PIN: N/A
Carrier: Sprint
Posts: 25
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Trouble getting the sd card detected

Please Login to Remove!

Sometimes when I plugin my pearl 8130, it doesn't detect the microsd card in it. I have an 8GB card in it, this also happened when it had a 2GB one. I don't know what the cause of it is. Sometimes it works, sometimes it doesn't. This is what I get in dmesg:


Quote:
[38028.683778] usb 1-3.2: new full speed USB device using ehci_hcd and address 20
[38028.795223] usb 1-3.2: configuration #1 chosen from 1 choice
[38028.796592] scsi894 : SCSI emulation for USB Mass Storage devices
[38028.802307] usb-storage: device found at 20
[38028.802310] usb-storage: waiting for device to settle before scanning
[38028.798568] scsi895 : SCSI emulation for USB Mass Storage devices
[38028.804283] usb-storage: device found at 20
[38028.804285] usb-storage: waiting for device to settle before scanning
[38028.801456] scsi896 : SCSI emulation for USB Mass Storage devices
[38028.807246] usb-storage: device found at 20
[38028.807250] usb-storage: waiting for device to settle before scanning
[38028.806396] scsi897 : SCSI emulation for USB Mass Storage devices
[38028.812198] usb-storage: device found at 20
[38028.812202] usb-storage: waiting for device to settle before scanning
[38028.808335] scsi898 : SCSI emulation for USB Mass Storage devices
[38028.814153] usb-storage: device found at 20
[38028.814156] usb-storage: waiting for device to settle before scanning
[38028.809942] scsi899 : SCSI emulation for USB Mass Storage devices
[38028.815657] usb-storage: device found at 20
[38028.815659] usb-storage: waiting for device to settle before scanning
[38028.811586] scsi900 : SCSI emulation for USB Mass Storage devices
[38028.817352] usb-storage: device found at 20
[38028.817356] usb-storage: waiting for device to settle before scanning
[38028.813441] scsi901 : SCSI emulation for USB Mass Storage devices
[38028.819156] usb-storage: device found at 20
[38028.819158] usb-storage: waiting for device to settle before scanning
[38028.816070] scsi902 : SCSI emulation for USB Mass Storage devices
[38028.821865] usb-storage: device found at 20
[38028.821868] usb-storage: waiting for device to settle before scanning
[38028.817689] scsi903 : SCSI emulation for USB Mass Storage devices
[38028.823404] usb-storage: device found at 20
[38028.823406] usb-storage: waiting for device to settle before scanning
[38028.819195] scsi904 : SCSI emulation for USB Mass Storage devices
[38028.824941] usb-storage: device found at 20
[38028.824943] usb-storage: waiting for device to settle before scanning
[38028.820565] scsi905 : SCSI emulation for USB Mass Storage devices
[38028.826281] usb-storage: device found at 20
[38028.826283] usb-storage: waiting for device to settle before scanning
[38028.821939] scsi906 : SCSI emulation for USB Mass Storage devices
[38028.827650] usb-storage: device found at 20
[38028.827652] usb-storage: waiting for device to settle before scanning
[38028.823311] scsi907 : SCSI emulation for USB Mass Storage devices
[38028.829027] usb-storage: device found at 20
[38028.829029] usb-storage: waiting for device to settle before scanning
[38028.824685] scsi908 : SCSI emulation for USB Mass Storage devices
[38028.830412] usb-storage: device found at 20
[38028.830414] usb-storage: waiting for device to settle before scanning
[38028.826187] scsi909 : SCSI emulation for USB Mass Storage devices
[38028.831899] usb-storage: device found at 20
Keeps repeating this with scsi909 incrementing........

Quote:
[38029.362956] usb-storage: waiting for device to settle before scanning
[38029.419815] scsi1172 : SCSI emulation for USB Mass Storage devices
[38029.432898] usb-storage: device found at 20
[38029.432903] usb-storage: waiting for device to settle before scanning
[38029.711878] usb 1-3.2: USB disconnect, address 20
[38029.927752] usb 1-3.2: new full speed USB device using ehci_hcd and address 21
[38030.026552] usb 1-3.2: configuration #1 chosen from 1 choice
[38030.030975] scsi1173 : SCSI emulation for USB Mass Storage devices
[38030.031039] usb-storage: device found at 21
[38030.031041] usb-storage: waiting for device to settle before scanning
[38035.031323] usb-storage: device scan complete
[38035.137666] scsi 1173:0:0:0: Direct-Access RIM BlackBerry SD 0001 PQ: 0 ANSI: 4 CCS
[38035.146642] sd 1173:0:0:0: [sde] 15954944 512-byte hardware sectors (8169 MB)
[38035.150536] sd 1173:0:0:0: [sde] Write Protect is off
[38035.150542] sd 1173:0:0:0: [sde] Mode Sense: 43 00 00 53
[38035.150544] sd 1173:0:0:0: [sde] Assuming drive cache: write through
[38035.159642] sd 1173:0:0:0: [sde] 15954944 512-byte hardware sectors (8169 MB)
[38035.164280] sd 1173:0:0:0: [sde] Write Protect is off
[38035.164286] sd 1173:0:0:0: [sde] Mode Sense: 43 00 00 53
[38035.164288] sd 1173:0:0:0: [sde] Assuming drive cache: write through
[38035.164297] sde: sde1
[38035.172919] sd 1173:0:0:0: [sde] Attached SCSI removable disk
[38035.172956] sd 1173:0:0:0: Attached scsi generic sg5 type 0


I'm running Kubuntu Hardy Heron 8.04 64-bit (don't have berry installed since I can't get it to compile)

Last edited by Ashex : 07-28-2008 at 12:01 AM. Reason: added OS
Offline  
Old 07-28-2008, 12:12 PM   #2 (permalink)
mrn
New Member
 
Join Date: Nov 2007
Model: 8900
PIN: N/A
Carrier: Tmobile
Posts: 14
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

have you tried disabling and reenabling the microSD storage though the options on your BB thentry again.
Also have you tried with other OS?
check it out with "lsusb -i" and report the results.
__________________
Offline  
Old 07-30-2008, 08:05 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2008
Model: 8130
PIN: N/A
Carrier: Sprint
Posts: 25
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have it set to prompt me when I plugin the usb. It works fine in XP and Vista. I'm not sure what you're referring to with the -i option on lsusb, this is the output without flags:

Quote:
Bus 002 Device 006: ID 0ac8:305b Z-Star Microelectronics Corp. ZC0305 WebCam
Bus 002 Device 005: ID 0bda:8187 Realtek Semiconductor Corp.
Bus 002 Device 004: ID 0409:005a NEC Corp.
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 046d:c512 Logitech, Inc.
Bus 001 Device 002: ID 046d:c041 Logitech, Inc.
Bus 001 Device 001: ID 0000:0000
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.