BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Linux Users Corner (http://www.blackberryforums.com/linux-users-corner/)
-   -   Use your blackberry as modem with just Barry (http://www.blackberryforums.com/linux-users-corner/150505-use-your-blackberry-modem-just-barry.html)

Iare Tosevite 09-17-2008 12:59 AM

Use your blackberry as modem with just Barry
 
Generally, Net Direct :: Open Solutions is all you need to install and set up, but here is general guideline on what I did in order to make mine work (Sprint).

I used Ubuntu Hardy Heron with sprint blackberry.

Install those packages by shell command:
Quote:

sudo apt-get install pkg-config libusb-dev libssl-dev libboost-serialization-dev libtar-dev libgtkmm-2.4-dev libglibmm-2.4-dev libglademm-2.4-dev zlib1g-dev
If everything goes fine, go to SourceForge.net: Barry and download two packages, barry and libbarry.

Install libbarry first, then finally barry itself.

Plug in your blackberry, then use this shell command to check if it worked:
Quote:

btool -l
If it doesn't show your blackberry, try lsusb to see if there is any device names with RIM in it.. if not you will need to try unplug and plug again. If not you will need to research on why it didn't work.

If it does show device with your pin, it worked! Now on to configuring the script. I will assume sprint, but barry does come with few others service providers like rogers and verizon. If you have a different one, you will have to do some research. Anyway...

In my case, I had to edit the script. I wanted to keep the orginial one, so I did this...
Quote:

cd /etc/ppp/peers
sudo cp barry-sprint bb
Now it have a much shorter and easier to remember name. :) Now... I had to edit bb file that way...
Quote:

sudo nano bb
I looked for entries user and password. Default just doesn't work for sprint. You will have to use your sprint login and passwords here. (don't add < > to your user and password)
user <login>
password <youraccountpassword>

Since my device does have a password set on it, I had to edit other line...
change
Quote:

pty "/usr/sbin/pppob"
to
Quote:

pty "/usr/sbin/pppob -P <password>"
Change <password> to your device password.

*EDIT - sudo required, it makes pppd works perfectly each time.*

to start it, just type this command:
Quote:

sudo pppd call bb
to hang up...
When you are done, just press Ctrl-c to exit. Wait till it returns to prompt before closing, however, so it will hang up properly.

****Fixed - ignore this line. It usually works the first time. Oddly enough, it usually doesn't the second time. Just unplug and plug your bb again before dialing again.*****

Other odd problem happens if focus happens to be on your shell window when you plug in your bb, it will spam that box. Just click on desktop before you plug in your blackberry. :)

Hopefully it's a little bit helpful. :) I'm glad I didn't do the ugly method. :)

Iare Tosevite 09-18-2008 12:23 AM

Did this guide work for anyone?

Iare Tosevite 09-23-2008 03:26 AM

Edited to add new information after some research.

champagj 10-14-2008 09:03 PM

Rogers Blackberry Bold
 
I am using Acer Aspire One (Linux Linpus which is an offshoot of fedora 8) with Blackberry Bold on Rogers network.

I am new to Blackberry and Linux and I found getting Barry going kinda difficult. I read that Linpus is hard to make work sometimes but after some rpm hunting I got to the pppd call which returned :

Connect script failed
Waiting for 1 child processes...
script /usr/sbin/pppob, pid 28492
sending SIGTERM to process 28492

my BB is listed under lsusb and btool so I guess it's up to connect script work...

since the Bold uses 3G, I suspect I may encounter more hurdles. Any idea where to start?

Thanks,

JF

Iare Tosevite 10-15-2008 12:59 PM

Did you modify your call file for your blackberry? IE: I had to add username as password, as well as device password.

champagj 10-16-2008 01:07 AM

Iare,

I actually disabled the password on my BB and started to play with the script. I have it down to a point where the 'pppd call bb' returns IP, DNS etc. and no loggin errors.

Howevere, the new IP / gateway info is not "linking" to the connection manager to create a net connection.

I use Linpus which has limited functionnalities and the connect manager seems to support only Ethernet and Wifi profiles.

I believe I can update the connect manager but I'm on the road and I have no way to re-load if this thing goes south... so I'll have to wait for the weekend before using brute force.

As a side note the "mass storage" function is buggy. Not sure if Barry caused it but I can browse the BB via Thunar but it freezes when I try to access/move/copy any file..

JF

Iare Tosevite 10-16-2008 01:17 PM

Yeah? Do you have any other connection active at that time? That's only question I thought up...

Sorry I couldn't help ypu further than this. :(

I'm good linux user, but that means I'm no linux "guru".

Basically it works for me once I get dns and ip.

champagj 10-18-2008 02:39 PM

Iare,

You may have an idea... I finally get "login" into BB. I can see IP, DNS etc..

I can browse but only with pure ip addresses. If I type the IP address of Google it goes to google via BB.

I do see DNS info when I connect.. However there are no config / status via the network manager. Almost as if it "bypass" it. As far as the net gui is concerned there is no net connection...

any idea what to try?

Iare Tosevite 10-19-2008 02:13 AM

That made me wonder - is network manager ( I don't use it, I prefer WICD ) changing dns to an incorrect default value? I do recall something about default settings for locations such as home, college, work, etc.

champagj 10-24-2008 08:14 PM

Got it!
 
Finally got my Bold working with Aspire One over USB using barry.

Network manager does not work with pppob and pppd and basically DNS info is not updated. I found a thread on aspire one forum explaining how to add script files to update dns on pppd connect.

I am now curious to see if it does get 3G speed. (I only have edge coverage at home).

As a side note I tried to use the "pppob -P" command to add my device password without success. Looks like pppob only like digit password, no letters. and the bold doesnt like digit passwords... any suggestions?

Thanks!
(sent over usb-edge-blackberryBold with aspire one):bb:

Iare Tosevite 10-24-2008 11:18 PM

Hmm maybe that's Barry bug? my bb do have [a-z] only only password.

I do get EDGE speed when I use mine, I doesn't have G3 on mine. :) I wouldn't know if it would give you G3 speed.

Anyway I'm glad it works for you now. :)

I do highly recommand WICD - it makes network manager seem very clunky and unfinished. Maybe when you get home and has wired connection in case of problems. :)

NikolaM 11-13-2008 01:53 PM

I'm having problems with this..

I'm using Ubuntu Linux and Blackberry Bold
When i do "btool -l" i get the response that Blackberry device was found, PIN, .. etc
When i do "lsusb" i get the response that Blackberry is plugged in USB (Bus 001 Device 006: ID 0fca:8004 Research In Motion, Ltd.)



And when I use "sudo pppd call bb", on the device I see it started calling #700 (why this? shouldn't it be *99***!" like in Windows?) and I get this response:


Code:

Connect script failed
Waiting for 1 child processes...
  script /usr/sbin/pppob, pid 21631
sending SIGTERM to process 21631
Child process /usr/sbin/pppob (pid 21631) terminated with signal 15


I did edit username and password for ISP..

So.. where did i go wrong? What to do to make Blackberry act like modem to connect to the internet?

Regards,
Nikola

champagj 11-13-2008 04:46 PM

Nikola,

I had the same problem.

You need to change the bb.chat file.

Mine looks like this and it works with Bold on Rogers Wireless

ABORT ERROR
'' AT&F
OK ATZ
OK ATI
OK AT+CGDCONT=1, "IP","internet.com"
OK ATDT*99#
CONNECT


There is too many commands in the default file.

NikolaM 11-14-2008 05:16 AM

That's all u have in bb.chat file? Or just part of it?

If just part of it.. Can u copy/paste all? :smile:

Thanx!

Regards,
Nikola

champagj 11-16-2008 10:05 PM

bb.chat script
 
Yes,

That's pretty much it. Here is the whole file:


Code:

#
# Some of these options found documented at:
#   
#
# Others are based on the peer file in XmBlackBerry
#
# Please send all working peer files to, so we can
# build a library of peer files for different carriers.
#
ABORT ERROR
'' AT&F
OK ATZ
OK ATI
OK AT+CGDCONT=1,"IP","internet.com"
OK ATDT*99#
CONNECT[/size][/i]


NikolaM 11-17-2008 03:09 AM

I'm getting this error..

pppd: In file /etc/ppp/peers/bb: unrecognized option 'ABORT'

camp514 11-18-2008 01:19 AM

Has NE! gotten this to work with FREESPIRE LINUX?

Iare Tosevite 01-27-2009 01:51 AM

Was this guide useful for anyone so far?

radallen 01-28-2009 07:13 PM

how do I use my storm as a modem for my minilaptop

Iare Tosevite 01-29-2009 02:18 AM

Well it depends on Barry support, but if it does this guide should help a bit.


All times are GMT -5. The time now is 10:13 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.