BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Linux Users Corner (http://www.blackberryforums.com/linux-users-corner/)
-   -   Bold tethering issues... (http://www.blackberryforums.com/linux-users-corner/164951-bold-tethering-issues.html)

mariner 12-13-2008 01:24 AM

Bold tethering issues...
 
It looks like some of you are having success tethering your BB Bold with linux. I'm not having as much luck.

Here's what happens to me:

smcmackin@Mariner-T61:/etc/ppp$ sudo pppd call barry-att_cingular
Couldn't open pty slave /dev/pts/0: No such file or directory
Setting abort string
Initializing modem
Bad packet size. Packet: 26. DataSize(): 26. Required size: 44
00000000: 00 00 1a 00 09 ff 00 08 52 49 4d 5f 55 73 62 53 ........RIM_UsbS
00000010: 65 72 44 61 74 61 00 00 01 00 erData....

Packet:
00000000: 00 00 08 00 0c 06 00 09 ........

exception caught in main(): Bad packet size. Packet: 26. DataSize(): 26. Required size: 44
Connect script failed
Waiting for 1 child processes...
script /usr/sbin/pppob -P ******** -s, pid 24178
Script /usr/sbin/pppob -P ******** -s finished (pid 24178), status = 0x1

I'm running barry 0.15 from a PPA for Ubuntu 8.10.

Any help would be greatly appreciated...

mariner 12-22-2008 12:02 PM

For everyone's benefit, I worked with a barry developer over the past week and we have it working. Expect the patch to make it into the final release of barry-0.15.

Schwin97 01-08-2009 07:23 PM

Copy of source changes?
 
Anyway that you can share the source that was used to create pppob - all of it actually. I have downloaded CVS from sourceforge, but that doesn't seem to be the latest and greatest. I see some 0.15 packages created, but they seem to be before you worked with the barry developers. Any help would be apprciated since I just cancelled my sprint cell card with hopes of just using my bold.

Thanks!

mariner 01-08-2009 10:57 PM

We didn't do anything with pppob, only libbarry. It's not fully baked yet. What distro are you running? There's a PPA out there containing the SVN of 0.15 for Ubuntu 8.10. If you post your results in the barry mailing list they might work with you. If I was writing the code I'd share it freely, but I was only the hands and eyes for a developer that didn't have a Bold.

Schwin97 01-09-2009 09:16 AM

Bold tethering
 
I am on Fedora 10. I will look at sending a message into the mailing list and see if they can help me with it.

Thanks

mariner 01-11-2009 10:18 AM

Andy just posted the patch to the mailing list which should be incorporated into the daily builds shortly.

Schwin97 01-11-2009 01:55 PM

Great! Thanks for checking with him regarding the fix. I will continue to watch the mailing list to see when the cvs repository is updated, and see if it works for me...

Schwin97 01-19-2009 05:07 PM

I have been able to get much further with getting my Bold connected. I have downloaded the latest and greatest barry source from CVS today. When I built everything, easily done with the correct developer rpm's installed, I have been able to get connected. Unluckily, the connection doesn't take since I am unable to get an ip address. Looks like there are a bunch of us with the same issue on Fedora - hopefully, we can get a fix in place soon. If I hear of any fix - I will post again.


All times are GMT -5. The time now is 08:52 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.