BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-13-2008, 02:24 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Dec 2005
Location: Front Royal, VA
Model: 9000
OS: 4.6.0.210
Carrier: AT&T
Posts: 29
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Bold tethering issues...

Please Login to Remove!

It looks like some of you are having success tethering your BB Bold with linux. I'm not having as much luck.

Here's what happens to me:

smcmackin@Mariner-T61:/etc/ppp$ sudo pppd call barry-att_cingular
Couldn't open pty slave /dev/pts/0: No such file or directory
Setting abort string
Initializing modem
Bad packet size. Packet: 26. DataSize(): 26. Required size: 44
00000000: 00 00 1a 00 09 ff 00 08 52 49 4d 5f 55 73 62 53 ........RIM_UsbS
00000010: 65 72 44 61 74 61 00 00 01 00 erData....

Packet:
00000000: 00 00 08 00 0c 06 00 09 ........

exception caught in main(): Bad packet size. Packet: 26. DataSize(): 26. Required size: 44
Connect script failed
Waiting for 1 child processes...
script /usr/sbin/pppob -P ******** -s, pid 24178
Script /usr/sbin/pppob -P ******** -s finished (pid 24178), status = 0x1

I'm running barry 0.15 from a PPA for Ubuntu 8.10.

Any help would be greatly appreciated...
Offline  
Old 12-22-2008, 01:02 PM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Dec 2005
Location: Front Royal, VA
Model: 9000
OS: 4.6.0.210
Carrier: AT&T
Posts: 29
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

For everyone's benefit, I worked with a barry developer over the past week and we have it working. Expect the patch to make it into the final release of barry-0.15.
Offline  
Old 01-08-2009, 08:23 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2006
Location: Texas
Model: 8100
Carrier: Cingular
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Copy of source changes?

Anyway that you can share the source that was used to create pppob - all of it actually. I have downloaded CVS from sourceforge, but that doesn't seem to be the latest and greatest. I see some 0.15 packages created, but they seem to be before you worked with the barry developers. Any help would be apprciated since I just cancelled my sprint cell card with hopes of just using my bold.

Thanks!
Offline  
Old 01-08-2009, 11:57 PM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Dec 2005
Location: Front Royal, VA
Model: 9000
OS: 4.6.0.210
Carrier: AT&T
Posts: 29
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

We didn't do anything with pppob, only libbarry. It's not fully baked yet. What distro are you running? There's a PPA out there containing the SVN of 0.15 for Ubuntu 8.10. If you post your results in the barry mailing list they might work with you. If I was writing the code I'd share it freely, but I was only the hands and eyes for a developer that didn't have a Bold.
Offline  
Old 01-09-2009, 10:16 AM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2006
Location: Texas
Model: 8100
Carrier: Cingular
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Bold tethering

I am on Fedora 10. I will look at sending a message into the mailing list and see if they can help me with it.

Thanks
Offline  
Old 01-11-2009, 11:18 AM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Dec 2005
Location: Front Royal, VA
Model: 9000
OS: 4.6.0.210
Carrier: AT&T
Posts: 29
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Andy just posted the patch to the mailing list which should be incorporated into the daily builds shortly.
Offline  
Old 01-11-2009, 02:55 PM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2006
Location: Texas
Model: 8100
Carrier: Cingular
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Great! Thanks for checking with him regarding the fix. I will continue to watch the mailing list to see when the cvs repository is updated, and see if it works for me...
Offline  
Old 01-19-2009, 06:07 PM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2006
Location: Texas
Model: 8100
Carrier: Cingular
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have been able to get much further with getting my Bold connected. I have downloaded the latest and greatest barry source from CVS today. When I built everything, easily done with the correct developer rpm's installed, I have been able to get connected. Unluckily, the connection doesn't take since I am unable to get an ip address. Looks like there are a bunch of us with the same issue on Fedora - hopefully, we can get a fix in place soon. If I hear of any fix - I will post again.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.