BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Linux Users Corner (http://www.blackberryforums.com/linux-users-corner/)
-   -   BB Bluetooth tether failing (http://www.blackberryforums.com/linux-users-corner/168927-bb-bluetooth-tether-failing.html)

egggman 01-06-2009 11:41 AM

BB Bluetooth tether failing
 
Hi all,

Im new here and hoping I am not asking the same question as asked before. I have mucked with my Chatscript and Peer files 1000 different ways based on things found online. No matter what I do I get connected to a blackberry peer but hang at the '' ATZ or '' AT&F command. No response comes no matter what . I am not sure if my error stems from a Bluetooth error or a script error at this point. Let me know.

Jan 6 11:32:20 IS-LAP-4 hcid[16171]: Default passkey agent (:1.52, /org/bluez/applet) registered
Jan 6 11:32:50 IS-LAP-4 pppd[16298]: pppd 2.4.4 started by root, uid 0
Jan 6 11:32:59 IS-LAP-4 hcid[16171]: pin_code_request (sba=00:16:38:CA:1D:70, dba=00:1C:CC:E6:F4:1D)
Jan 6 11:32:59 IS-LAP-4 hcid[16171]: Calling PasskeyAgent.Request: name=:1.52, path=/org/bluez/applet
Jan 6 11:33:06 IS-LAP-4 hcid[16171]: link_key_notify (sba=00:16:38:CA:1D:70, dba=00:1C:CC:E6:F4:1D)
Jan 6 11:33:13 IS-LAP-4 chat[16299]: abort on (ERROR)
Jan 6 11:33:13 IS-LAP-4 chat[16299]: send (AT&F^M)
Jan 6 11:33:13 IS-LAP-4 chat[16299]: expect (OK)
Jan 6 11:33:58 IS-LAP-4 chat[16299]: alarm
Jan 6 11:33:58 IS-LAP-4 chat[16299]: Failed
Jan 6 11:33:58 IS-LAP-4 pppd[16298]: Connect script failed

Password disabled currently as that was my last thought. Thanks in advance for any help.

egggman 01-06-2009 11:45 AM

Changed security auto; to security user; Seems to have removed the pin portion but still no dice:


Jan 6 11:44:27 IS-LAP-4 pppd[16367]: pppd 2.4.4 started by root, uid 0
Jan 6 11:44:30 IS-LAP-4 hcid[16344]: link_key_request (sba=00:16:38:CA:1D:70, dba=00:1C:CC:E6:F4:1D)
Jan 6 11:44:32 IS-LAP-4 chat[16368]: abort on (ERROR)
Jan 6 11:44:32 IS-LAP-4 chat[16368]: send (AT&F^M)
Jan 6 11:44:32 IS-LAP-4 chat[16368]: expect (OK)
Jan 6 11:45:17 IS-LAP-4 chat[16368]: alarm
Jan 6 11:45:17 IS-LAP-4 chat[16368]: Failed
Jan 6 11:45:17 IS-LAP-4 pppd[16367]: Connect script failed
Jan 6 11:45:18 IS-LAP-4 pppd[16367]: Exit.

egggman 01-06-2009 12:21 PM

Tried wvdial with no additional luck. Devices seem to be pairing but I wonder if the error still lies there.

--> WvDial: Internet dialer version 1.56
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: AT&F
--> Sending: ATQ0
--> Re-Sending: AT&F
--> Modem not responding.

egggman 01-06-2009 12:45 PM

And to annoy everyone further. Changed to channel 1 and seem to get a whole lot further but still no dice:

Jan 6 12:42:07 IS-LAP-4 pppd[16811]: pppd 2.4.4 started by root, uid 0
Jan 6 12:42:11 IS-LAP-4 hcid[16793]: link_key_request (sba=00:16:38:CA:1D:70, dba=00:1C:CC:E6:F4:1D)
Jan 6 12:42:12 IS-LAP-4 chat[16812]: abort on (ERROR)
Jan 6 12:42:12 IS-LAP-4 chat[16812]: send (AT&F^M)
Jan 6 12:42:12 IS-LAP-4 chat[16812]: expect (OK)
Jan 6 12:42:12 IS-LAP-4 chat[16812]: AT&F^M
Jan 6 12:42:12 IS-LAP-4 chat[16812]: ^M
Jan 6 12:42:12 IS-LAP-4 chat[16812]: OK
Jan 6 12:42:12 IS-LAP-4 chat[16812]: -- got it
Jan 6 12:42:12 IS-LAP-4 chat[16812]: send (ATZ^M)
Jan 6 12:42:12 IS-LAP-4 chat[16812]: expect (OK)
Jan 6 12:42:12 IS-LAP-4 chat[16812]: ^M
Jan 6 12:42:12 IS-LAP-4 chat[16812]: ATZ^M
Jan 6 12:42:12 IS-LAP-4 chat[16812]: ^M
Jan 6 12:42:12 IS-LAP-4 chat[16812]: OK
Jan 6 12:42:12 IS-LAP-4 chat[16812]: -- got it
Jan 6 12:42:12 IS-LAP-4 chat[16812]: send (ATI^M)
Jan 6 12:42:12 IS-LAP-4 chat[16812]: expect (OK)
Jan 6 12:42:12 IS-LAP-4 chat[16812]: ^M
Jan 6 12:42:12 IS-LAP-4 chat[16812]: ATI^M
Jan 6 12:42:12 IS-LAP-4 chat[16812]: Research in Motion BlackBerry IP Modem^M
Jan 6 12:42:12 IS-LAP-4 chat[16812]: ^M
Jan 6 12:42:12 IS-LAP-4 chat[16812]: OK
Jan 6 12:42:12 IS-LAP-4 chat[16812]: -- got it
Jan 6 12:42:12 IS-LAP-4 chat[16812]: send (AT+CGDCONT=1,^M)
Jan 6 12:42:12 IS-LAP-4 chat[16812]: expect (IP)
Jan 6 12:42:12 IS-LAP-4 chat[16812]: ^M
Jan 6 12:42:12 IS-LAP-4 chat[16812]: AT+CGDCONT=1,^M
Jan 6 12:42:12 IS-LAP-4 chat[16812]: ^M
Jan 6 12:42:12 IS-LAP-4 chat[16812]: OK^M
Jan 6 12:42:57 IS-LAP-4 chat[16812]: alarm
Jan 6 12:42:57 IS-LAP-4 chat[16812]: Failed
Jan 6 12:42:57 IS-LAP-4 pppd[16811]: Connect script failed
Jan 6 12:42:58 IS-LAP-4 pppd[16811]: Exit.

egggman 01-06-2009 01:15 PM

Next:

Jan 6 13:15:28 IS-LAP-4 pppd[17196]: pppd 2.4.4 started by root, uid 0
Jan 6 13:15:31 IS-LAP-4 hcid[17085]: link_key_request (sba=00:16:38:CA:1D:70, dba=00:1C:CC:E6:F4:1D)
Jan 6 13:15:33 IS-LAP-4 chat[17197]: abort on (ERROR)
Jan 6 13:15:33 IS-LAP-4 chat[17197]: send (AT&F^M)
Jan 6 13:15:33 IS-LAP-4 chat[17197]: expect (OK)
Jan 6 13:15:33 IS-LAP-4 chat[17197]: AT&F^M
Jan 6 13:15:33 IS-LAP-4 chat[17197]: ^M
Jan 6 13:15:33 IS-LAP-4 chat[17197]: OK
Jan 6 13:15:33 IS-LAP-4 chat[17197]: -- got it
Jan 6 13:15:33 IS-LAP-4 chat[17197]: send (ATZ^M)
Jan 6 13:15:33 IS-LAP-4 chat[17197]: expect (OK)
Jan 6 13:15:33 IS-LAP-4 chat[17197]: ^M
Jan 6 13:15:33 IS-LAP-4 chat[17197]: ATZ^M
Jan 6 13:15:33 IS-LAP-4 chat[17197]: ^M
Jan 6 13:15:33 IS-LAP-4 chat[17197]: OK
Jan 6 13:15:33 IS-LAP-4 chat[17197]: -- got it
Jan 6 13:15:33 IS-LAP-4 chat[17197]: send (ATI^M)
Jan 6 13:15:33 IS-LAP-4 chat[17197]: expect (OK)
Jan 6 13:15:33 IS-LAP-4 chat[17197]: ^M
Jan 6 13:15:33 IS-LAP-4 chat[17197]: ATI^M
Jan 6 13:15:33 IS-LAP-4 chat[17197]: Research in Motion BlackBerry IP Modem^M
Jan 6 13:15:33 IS-LAP-4 chat[17197]: ^M
Jan 6 13:15:33 IS-LAP-4 chat[17197]: OK
Jan 6 13:15:33 IS-LAP-4 chat[17197]: -- got it
Jan 6 13:15:33 IS-LAP-4 chat[17197]: send (AT+CGDCONT=1,"IP","internet.com"^M)
Jan 6 13:15:34 IS-LAP-4 chat[17197]: expect (OK)
Jan 6 13:15:34 IS-LAP-4 chat[17197]: ^M
Jan 6 13:15:34 IS-LAP-4 chat[17197]: AT+CGDCONT=1,"IP","internet.com"^M
Jan 6 13:15:34 IS-LAP-4 chat[17197]: ^M
Jan 6 13:15:34 IS-LAP-4 chat[17197]: OK
Jan 6 13:15:34 IS-LAP-4 chat[17197]: -- got it
Jan 6 13:15:34 IS-LAP-4 chat[17197]: send (ATDT*99#^M)
Jan 6 13:15:34 IS-LAP-4 chat[17197]: expect (CONNECT)
Jan 6 13:15:34 IS-LAP-4 chat[17197]: ^M
Jan 6 13:15:34 IS-LAP-4 chat[17197]: ATDT*99#^M
Jan 6 13:15:34 IS-LAP-4 chat[17197]: ^M
Jan 6 13:15:34 IS-LAP-4 chat[17197]: CONNECT
Jan 6 13:15:34 IS-LAP-4 chat[17197]: -- got it
Jan 6 13:15:34 IS-LAP-4 pppd[17196]: Serial connection established.
Jan 6 13:15:34 IS-LAP-4 pppd[17196]: using channel 11
Jan 6 13:15:34 IS-LAP-4 pppd[17196]: Using interface ppp0
Jan 6 13:15:34 IS-LAP-4 pppd[17196]: Connect: ppp0 <--> /dev/rfcomm0
Jan 6 13:15:35 IS-LAP-4 pppd[17196]: sent [LCP ConfReq id=0x1 <asyncmap 0x0>]
Jan 6 13:15:38 IS-LAP-4 pppd[17196]: sent [LCP ConfReq id=0x1 <asyncmap 0x0>]

egggman 01-06-2009 01:27 PM

Well it turns out that it is working with an 8310 but hanging up with my 8320. Will do a firmware upgrade and see what that does for me. Sorry for all the posts :)

berry_blue 01-07-2009 06:37 AM

egggman,

Can you post a little more information about your setup?
i.e. Linux Distro and Version
Version of software and utilities involved.
maybe even a link to which tutorial you used to get as far as you've gotten.

then just a few generic questions.

1.) Are you sure the bluetooth connection is established?

2.) Have you verified that rfcomm.conf contains the BT address of the phone you are using?

3.) Have you adjusted the scripts you are using to reflect the user/pass info required by Rogers?

4.) The 8120 that you said works; is this a device that you have your hands on or is it being verified by another user?


I have a few more questions but knowing a bit more about your setup and method will help.

Thanks and good luck

arrnektornal 01-08-2009 12:08 PM

I am in a similar position to egggman. Here is my current steup:
-Thinkpad X200 with bluetooth and Ubuntu Intrepid
-Blackberry 8120 with T-Mobile

I have installed barry using Martin Owens' Ubuntu PPA repository. Using barry I am able to connect to the 8120 using USB: sudo pppd call barry-tmobileus However, I am only able to use the data connection for a short period of time. After this it no longer seems to work.

My goal is to tether over bluetooth and have a connection that works for longer than a few seconds.

If a set of steps are posted I can try with my setup and help debug. I have played with barry and hcitool. I'm just not sure where to proceed from here.

Any additional details, links, or suggestions would be appreciated.

berry_blue 01-08-2009 11:40 PM

arrnektornal,

Try this tutorial i wrote. its a bit rough around the edges but the information is there. Also i listed four other tutorials that I used together to get my setup to work.

http://www.blackberryforums.com/linu...rm-debian.html

Good Luck


All times are GMT -5. The time now is 01:09 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.