BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Linux Users Corner (http://www.blackberryforums.com/linux-users-corner/)
-   -   Blackberry as Modem on Ubuntu 9.04 (http://www.blackberryforums.com/linux-users-corner/203266-blackberry-modem-ubuntu-9-04-a.html)

kiarigato 09-04-2009 08:29 PM

Blackberry as Modem on Ubuntu 9.04
 
Hello all!

I need serious help, I recently installed Ubuntu 9.04 Netbook Remix so I'm a complete newbie working with Ubuntu. I need very simple step by step assistance installing an ap (Barry or other) that allows me to use my BlackBerry 8330 Curve as Modem. I don't really need to backup my info, but its a must to use it as a Modem.
Can anybody please help me here, I've tried just about everything!

Thanxs so much in advance
Blessings all
:smile:

NJBlackBerry 09-04-2009 08:31 PM

You may want to check out the Linux Users Corner where they may have information.

daphne 09-04-2009 08:31 PM

Moved to Linux Users Corner (as NJ was posting).

Iare Tosevite 09-05-2009 01:23 AM

http://www.blackberryforums.com/linu...ust-barry.html

That's how I made it work on my ubuntu.

kiarigato 09-06-2009 11:27 AM

Thank you so much, i followed the instructions and the computer did actually run some things, but it is not seeing the BlackBerry, it does see a RIM product but no pin is registered. What could i be doing wrong?

thank u again

Iare Tosevite 09-06-2009 09:46 PM

I'm not sure why that happened?

I'm not exactly an expert. :)

Did you successfully install libbarry and barry?

berry_blue 09-07-2009 02:25 AM

Quote:

Originally Posted by kiarigato (Post 1466306)
Thank you so much, i followed the instructions and the computer did actually run some things, but it is not seeing the BlackBerry, it does see a RIM product but no pin is registered. What could i be doing wrong?

thank u again

Hi,

you said your computer "did run some things". can you be a little more specific.

I mean are you saying that you got through all the packages in that first part of Lares post and got stopped at barry. Or did you not get that far. Or did you get it all installed and got tripped up at the script.

Just so I can get a better picture of where you need help.

thanks

Iare Tosevite 09-07-2009 01:43 PM

Whos Lare?

Also he uses different provider than Sprint which my guide is for. I don't know what provider needs in terms of login, etc.

berry_blue 09-08-2009 01:16 PM

kiarigato,

Can you post the output of the command line from the beginning. So i can tell where you're getting stopped.

if you've made it as far as getting barry installed and are trying to run the script here are the APN settings that have been reported to work;

APN: private.centennialwireless.com
username: privuser
password: priv

Also go to 'menu --> options --> advanced options --> TCP/IP
make sure that the "APN Settings Enabled" box is checked.
Also if the "APN Authentication Enabled" is checked that the credentials match the above.

Iare Tosevite 09-09-2009 01:05 AM

Yeah that was what I was thinking about. Different login requirements.

sent17inel 09-20-2009 10:30 PM

I gave it my best shot and even installed WICD.
 
I still cant get a connection to show up. here's my terminal output maybe you can see where im going wrong?

daniel@2ls49r:~$ sudo pppd call barry-sprint
Script /usr/sbin/chat -f /etc/chatscripts/barry-sprint.chat finished (pid 24666), status = 0x0
Serial connection established.
using channel 3
Using interface ppp0
Connect: ppp0 <--> /dev/pts/4
sent [LCP ConfReq id=0x1 <asyncmap 0x0>]
rcvd [LCP ConfReq id=0x6 <asyncmap 0x0> <magic 0x4bbfbd80> <pcomp> <accomp>]
sent [LCP ConfRej id=0x6 <magic 0x4bbfbd80> <pcomp> <accomp>]
rcvd [LCP ConfNak id=0x1 <magic 0x4bbfb158> <pcomp> <accomp>]
sent [LCP ConfReq id=0x2 <asyncmap 0x0>]
rcvd [LCP ConfReq id=0x7 <asyncmap 0x0>]
sent [LCP ConfAck id=0x7 <asyncmap 0x0>]
rcvd [LCP ConfNak id=0x2 <magic 0x4bbfb158> <pcomp> <accomp>]
sent [LCP ConfReq id=0x3 <asyncmap 0x0>]
rcvd [LCP ConfNak id=0x3 <magic 0x4bbfb158> <pcomp> <accomp>]
sent [LCP ConfReq id=0x4 <asyncmap 0x0>]
rcvd [LCP ConfAck id=0x4 <asyncmap 0x0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
rcvd [LCP DiscReq id=0x8 magic=0x4bbfbd80]
rcvd [IPCP ConfReq id=0x2 <addr 68.28.57.69>]
sent [IPCP ConfAck id=0x2 <addr 68.28.57.69>]
rcvd [IPCP ConfNak id=0x1 <addr 173.116.232.20> <ms-dns1 68.28.58.92> <ms-dns2 68.28.50.91>]
sent [IPCP ConfReq id=0x2 <addr 173.116.232.20> <ms-dns1 68.28.58.92> <ms-dns2 68.28.50.91>]
rcvd [IPCP ConfAck id=0x2 <addr 173.116.232.20> <ms-dns1 68.28.58.92> <ms-dns2 68.28.50.91>]
Cannot determine ethernet address for proxy ARP
local IP address 173.116.232.20
remote IP address 68.28.57.69
primary DNS address 68.28.58.92
secondary DNS address 68.28.50.91
Script /etc/ppp/ip-up started (pid 24709)
Script /etc/ppp/ip-up finished (pid 24709), status = 0x0
^Cselect(): Interrupted system call
Terminating on signal 2
Connect time 1.0 minutes.
Sent 0 bytes, received 0 bytes.
Script /etc/ppp/ip-down started (pid 25189)
sent [LCP TermReq id=0x5 "User request"]
Script /etc/ppp/ip-down finished (pid 25189), status = 0x0
sent [LCP TermReq id=0x6 "User request"]
Connection terminated.
Modem hangup
Waiting for 1 child processes...
script /usr/sbin/pppob, pid 24664
sending SIGTERM to process 24664
daniel@2ls49r:~$

Iare Tosevite 09-22-2009 01:49 AM

Do you have PAM on your account?

I'm not sure but Sprint might disallow blackberries without PAM to connect that way.

Looks like everything worked, just no data connection. You even got ip address and all.

Hmm did you test connection? The program will run forever till you press CTRL-c. Meanwhile the connection should work.

sent17inel 09-22-2009 09:06 AM

What is PAM? and yes i pressed control c and closed out the program properly.

Iare Tosevite 09-22-2009 11:29 PM

PAM is short for phone as modem. :)

It's supposed to stay running while you test internet access. Did you do so?

sent17inel 09-23-2009 01:31 AM

so your saying that thats a program on the blackberry itself? im not sure if it was running. how would i know?

Iare Tosevite 09-24-2009 01:58 AM

Oh PAM is a service offered by companies such as Sprint. Some companies require monthly payment before PAM will work. It's included in my plan so it works for me.

Just leave the command prompt alone after running command "sudo pppd call (whatever)" and browse internet if it works. It's supposed to stay running while you use internet access, then you press CTRL-c to close the internet access.

sent17inel 09-24-2009 05:00 PM

well i have the sprint everything plan so shouldnt that be included? do you think i have it? it seems like it should work but its not. i dont know what else to try. i felt like i followed the directions perfectly.

Iare Tosevite 09-24-2009 11:36 PM

I'm not sure why it doesn't work, since your output (assuming you tested the internet access before pressing CTRL-C) shows you connected just fine.

sent17inel 09-26-2009 03:15 PM

ok well thanks for taking a look at it. ill keep fiddling with it and see if i cant get it to work. if a come accross what im doing wrong ill go ahead and let you know what was wrong in case anyone else gets the same problem.

Iare Tosevite 09-27-2009 02:01 PM

Oh yeah other person had similiar issue, it was related to network manager force setting dns to wrong ip address.

I don't have that issue because I use Wicd.


All times are GMT -5. The time now is 11:04 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.