BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Linux Users Corner (http://www.blackberryforums.com/linux-users-corner/)
-   -   Connecting to Local Web Server failing (http://www.blackberryforums.com/linux-users-corner/204717-connecting-local-web-server-failing.html)

perlmonkey1977 09-19-2009 01:49 PM

Connecting to Local Web Server failing
 
I have a linux server running apache on my home network which I've setup with port forwarding on my linksys router (port 80) to accept requests externally. I have also setup an account with dyndns.org. When I connect to the dyndns page from an external computer everything works fine and my webpage comes up no prob. When I try to connect using my blackberry or even an iPhone it waits like 30 seconds, then gives me an 504 timeout error. I've checked the logs in my router, no denial logs. I've tailed the apache error_logs and nothing changes. I've turned off the firewall and tried it that way. I've tried connecting using the actual external ip address instead of using dyndns. Nothing seems to work.
It's like it's not even getting to the router. Does blackberry block certain sites or something? I think it must be my router configuration, but it just doesn't make sense that nothing shows up in the logs.
Any ideas anyone?

jhbowling 09-21-2009 05:00 AM

Same problem
 
For what it's worth, I'm having the exact same problem. Same setup as yours (dyndns, web server on internal network). The only thing that doesn't work is the Blackberry.

perlmonkey1977 09-23-2009 11:55 AM

Let me know if you find anything out. I've spent hours playing around with this today. Needless to say, about to pull out my hair.


All times are GMT -5. The time now is 06:49 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.