BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Linux Users Corner (http://www.blackberryforums.com/linux-users-corner/)
-   -   Any options for connecting a Linux laptop? (http://www.blackberryforums.com/linux-users-corner/87309-any-options-connecting-linux-laptop.html)

tmelcon 07-23-2007 07:31 PM

Any options for connecting a Linux laptop?
 
I have a 7290, and I'd love to be able to use it as a GPRS modem for my laptop. It works under Windows with the RIM software. However, my laptop doesn't run Windows, and reinstalling it now to dual boot would be mindbogglingly painful. Reports are that nobody has ever gotten the RIM software to work under Wine, either. So, I'd like to get it working under Linux.

Things I have tried which didn't work:
  • Pulse from brainmurmurs.com, with bluetooth connection: The Pulse application crashes upon connect with an error about being terminated due to message queue overflow. I asked brainmurmurs about this and have not gotten a reply. They do seem interested in trying to support Linux as a strategic goal, but they don't promise it works at the moment, and perhaps they're busy.
  • pppob from barry07, with USB connection: it exits immediately with "exception caught in main(): Wrong mode in RetryPassword". With no documentation on how to use it or what's supposed to happen, it seems unlikely I'll be able to debug this, and it's not even clear that it's supposed to work with my device at all.
Things I am considering:
  • Buying a different blackberry. If there is a model with a full QWERTY keyboard which is known to work with Linux, I will just buy that one. The 8100 is not an option because of the keyboard.
  • Buying a PCMCIA GPRS card and transferring the SIM when I need to use the laptop.
  • Buying another handset which DOES work for bluetooth or USB tether under Linux, and transferring the SIM when I need to use the laptop.
I'm wondering if anybody can vouch for any specific models of hardware for any of these three options, since I would hate to spend money on a new piece of equipment just to find that it doesn't work either.

tmelcon 07-24-2007 01:41 AM

Update : XmBlackBerry
 
I've tried one more approach and had more luck with it that I have with any of the others so far.

I got XmBlackBerry to compile, after sorting out some OpenMotif issues. It opens a port in /dev/pts which connects to the GPRS modem. I can actually talk to this modem, and the ATI command identifies it identically to what I see in Windows.

I then try to connect with the same commands as well:

AT+CGDCONT=1,"IP","wap.voicestream.com"
ATDT*99***1#

These work under Windows. Under Linux, they produce a "CONNECT" message, but then the actual PPP negotiation fails:

Connect: ppp0 <--> /dev/pts/6
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe0267202> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe0267202> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe0267202> <accomp>]
LCP: timeout sending Config-Requests

No LCP frames are ever received back.

Update: I compiled the latest XmBlackBerry from CVS, and it seems to include a workaround for this problem. I am now trying to figure out how to get pppd to send a BLANK username/password pair, which it doesn't seem to want to do - it interprets that to mean that it should refuse to negotiate for PAP. Sadly, the remote side insists on having PAP, and the correct username/password for my carrier is BLANK...

tmelcon 07-24-2007 09:42 PM

I've mostly gotten it working, although I'm having some intermittent disconnects. Still, I'm posting this message over it. I hope to write something up in more detail about it in a day or two, perhaps once I've gotten the bugs out. For now I'll just mention that the key to getting it working was the latest XmBlackBerry from CVS, more recent than the last released version.


All times are GMT -5. The time now is 08:27 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.