BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-08-2009, 06:22 AM   #21 (permalink)
Magic Bananas
 
ifonline's Avatar
 
Join Date: Jan 2006
Location: Braselton, Georgia
Model: iP4S
OS: 5.1
Carrier: Verizon
Posts: 2,350
Post Thanks: 1
Thanked 54 Times in 45 Posts
Default

Please Login to Remove!

Could it really be that easy? Need to test this when I get to work this morning.
__________________
Ian

Semper Fi 3/2/2
"Wow" is now overused. Therefore, I will use "Magic bananas" instead.
Offline  
Old 09-08-2009, 09:43 AM   #22 (permalink)
Magic Bananas
 
ifonline's Avatar
 
Join Date: Jan 2006
Location: Braselton, Georgia
Model: iP4S
OS: 5.1
Carrier: Verizon
Posts: 2,350
Post Thanks: 1
Thanked 54 Times in 45 Posts
Default

Quote:
Originally Posted by SkyMerc
If you want to keep the OEM icons for apps, games, setup and downloads DO NOT specify a default folder in Theme Builder. If you don't specify a default the OEM stays intact.
Okay, obviously I don't understand what you mean by "don't specify a default folder." What exactly do you mean?
__________________
Ian

Semper Fi 3/2/2
"Wow" is now overused. Therefore, I will use "Magic bananas" instead.
Offline  
Old 09-08-2009, 12:39 PM   #23 (permalink)
Knows Where the Search Button Is
 
SkyMerc's Avatar
 
Join Date: Feb 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

Quote:
Originally Posted by ifonline
Quote:
Originally Posted by SkyMerc
If you want to keep the OEM icons for apps, games, setup and downloads DO NOT specify a default folder in Theme Builder. If you don't specify a default the OEM stays intact.
Okay, obviously I don't understand what you mean by "don't specify a default folder." What exactly do you mean?
In theme builder don't insert a custom icon in the default folder spot. If you alraedy have, right click on it and select restore default. I took a screen shot, but don't have enough posts to put it here.

Last edited by SkyMerc : 09-08-2009 at 01:28 PM.
Offline  
Old 09-08-2009, 01:52 PM   #24 (permalink)
Magic Bananas
 
ifonline's Avatar
 
Join Date: Jan 2006
Location: Braselton, Georgia
Model: iP4S
OS: 5.1
Carrier: Verizon
Posts: 2,350
Post Thanks: 1
Thanked 54 Times in 45 Posts
Default

Doesn't work. I have never changed any of the icons, including the default folder icon. No matter what I do, I get blank folder icons when the theme is installed.

If I fire up Theme Builder and do absolutely nothing to the theme, build the theme, and install the theme, I still get the blank folder icons like this:

__________________
Ian

Semper Fi 3/2/2
"Wow" is now overused. Therefore, I will use "Magic bananas" instead.
Offline  
Old 09-08-2009, 02:11 PM   #25 (permalink)
Knows Where the Search Button Is
 
SkyMerc's Avatar
 
Join Date: Feb 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ifonline View Post
Doesn't work. I have never changed any of the icons, including the default folder icon. No matter what I do, I get blank folder icons when the theme is installed.

If I fire up Theme Builder and do absolutely nothing to the theme, build the theme, and install the theme, I still get the blank folder icons like this:
When you are on one of those folders, hit the menu key and then edit folder. See what other icons are available. My Bold displays the folders you want, so I'm curious why yours isn't doing it.
Offline  
Old 09-08-2009, 03:19 PM   #26 (permalink)
Magic Bananas
 
ifonline's Avatar
 
Join Date: Jan 2006
Location: Braselton, Georgia
Model: iP4S
OS: 5.1
Carrier: Verizon
Posts: 2,350
Post Thanks: 1
Thanked 54 Times in 45 Posts
Default

What version of the Theme Builder are you running? I get blank folders both on device and in the simulator for the Bold. The about screen on Theme Builder shows 4.1.0.19 for me.

As far as editing the folder on device, I don't get the icons I am looking for. I get folders with colored stars, folders with colored tabs, a folder with a heart, one with a smiley, and one with the BlackBerry logo. That's it.
__________________
Ian

Semper Fi 3/2/2
"Wow" is now overused. Therefore, I will use "Magic bananas" instead.
Offline  
Old 09-08-2009, 04:38 PM   #27 (permalink)
Knows Where the Search Button Is
 
SkyMerc's Avatar
 
Join Date: Feb 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ifonline View Post
What version of the Theme Builder are you running? I get blank folders both on device and in the simulator for the Bold. The about screen on Theme Builder shows 4.1.0.19 for me.

As far as editing the folder on device, I don't get the icons I am looking for. I get folders with colored stars, folders with colored tabs, a folder with a heart, one with a smiley, and one with the BlackBerry logo. That's it.
I'm running 4.7. Maybe that's the issue.
Offline  
Old 09-08-2009, 05:01 PM   #28 (permalink)
Magic Bananas
 
ifonline's Avatar
 
Join Date: Jan 2006
Location: Braselton, Georgia
Model: iP4S
OS: 5.1
Carrier: Verizon
Posts: 2,350
Post Thanks: 1
Thanked 54 Times in 45 Posts
Default

No... check your about box. I downloaded 4.7, but it comes up as 4.1 in the about box.
__________________
Ian

Semper Fi 3/2/2
"Wow" is now overused. Therefore, I will use "Magic bananas" instead.
Offline  
Old 09-08-2009, 05:03 PM   #29 (permalink)
Knows Where the Search Button Is
 
SkyMerc's Avatar
 
Join Date: Feb 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It's 4.1.0.18 - Feb 25 2009.
Offline  
Old 09-08-2009, 05:18 PM   #30 (permalink)
Knows Where the Search Button Is
 
SkyMerc's Avatar
 
Join Date: Feb 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here's a shot from the Michigan theme I was working on. I reset the default folder icon and voila.

Offline  
Old 09-08-2009, 06:32 PM   #31 (permalink)
Magic Bananas
 
ifonline's Avatar
 
Join Date: Jan 2006
Location: Braselton, Georgia
Model: iP4S
OS: 5.1
Carrier: Verizon
Posts: 2,350
Post Thanks: 1
Thanked 54 Times in 45 Posts
Default

Argh! I must be cursed or something. It just won't work on my end.
__________________
Ian

Semper Fi 3/2/2
"Wow" is now overused. Therefore, I will use "Magic bananas" instead.
Offline  
Old 09-08-2009, 07:21 PM   #32 (permalink)
New Member
 
weisguy's Avatar
 
Join Date: Jan 2008
Model: 9630
PIN: N/A
Carrier: Verizon
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

SkyMerc's advice above sent me down a path that actually led to success!

My setup:

Tour 9630 on Verizon
Theme Builder 4.1.0.19 w/Tour theme patch

1) On the "Theme the Application Icons" screen, I first tried resetting just the Default Folder to default by right-clicking. After a long reboot, nothing.

2) On the BlackBerry itself, I went to Options > Theme > [my theme]. Hit the BlackBerry menu key and reset the theme to default. Nothing.

3) Back in the theme: Right-click on the "Theme the Application Icons Screen" tab itself, directly under "Inspector" hit "Reset Section to Default." Reload to Blackberry: Success! I *did* lose all my work on just this tab, but it was better than starting from scratch.

Step #2 above might not be necessary - I do need also to rearrange my icons as I had organized them on the 'berry itself, and any other deviations from the theme.

Edit: Well shewt. After creating a Web Link on this screen and adding an icon to *that*, the folders went blank again. This screen is touchy but it definitely controls the folders, even if inadvertently so.

Last edited by weisguy : 09-08-2009 at 07:31 PM.
Offline  
Old 09-08-2009, 07:25 PM   #33 (permalink)
Magic Bananas
 
ifonline's Avatar
 
Join Date: Jan 2006
Location: Braselton, Georgia
Model: iP4S
OS: 5.1
Carrier: Verizon
Posts: 2,350
Post Thanks: 1
Thanked 54 Times in 45 Posts
Default

Hm... I'll give it a shot at work tomorrow. Fingers crossed.
__________________
Ian

Semper Fi 3/2/2
"Wow" is now overused. Therefore, I will use "Magic bananas" instead.
Offline  
Old 09-08-2009, 09:54 PM   #34 (permalink)
BlackBerry Extraordinaire
 
BCollins521's Avatar
 
Join Date: Sep 2006
Location: OH
Model: 9700
PIN: Ask...
Carrier: T-Mobile
Posts: 2,033
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

That's what I said all along was to change the icon yourself from the phone, whenever I load a theme of mine even changing the default folder in Theme Builder it would show the default folders with the icons and you would have to change the names for the default folders to work...

I have changed the default folder in every theme of mine but when loaded on my Storm and my Javelin (running either OS 4.6 or 5.0 on Javelin, 4.7 or hybrid on Storm) it shows the folders on initial load of the ones with the logos and then if I want to change it to the folder to match the theme then I have to rename the folder for it to show. But I can always go back and change the icon to the original ones


Screen shot from my Javelin:

__________________
-Brian

Get My Themes Here! | [email address] | Twitter

Last edited by BCollins521 : 09-08-2009 at 10:02 PM.
Offline  
Old 09-08-2009, 09:24 PM   #35 (permalink)
Knows Where the Search Button Is
 
SkyMerc's Avatar
 
Join Date: Feb 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here are a couple of shots from my device. These are the folder options when I specify a custom folder as the default. As you can see the normal system folders disappear.





The next shot is another theme with the OEM icons.



This behavior is the same for both the Bold 9000 and Curve 8900 themes I have created.

Last edited by SkyMerc : 09-08-2009 at 10:25 PM.
Offline  
Old 09-08-2009, 09:32 PM   #36 (permalink)
BlackBerry Extraordinaire
 
BCollins521's Avatar
 
Join Date: Sep 2006
Location: OH
Model: 9700
PIN: Ask...
Carrier: T-Mobile
Posts: 2,033
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

My screen shot was when I specified a custom folder in theme builder but when you load the theme on the phone the stock folder (one with the icons) are shown for the folders you have to physically change them when you want them to the icon to match the theme
__________________
-Brian

Get My Themes Here! | [email address] | Twitter
Offline  
Old 09-08-2009, 10:29 PM   #37 (permalink)
Knows Where the Search Button Is
 
SkyMerc's Avatar
 
Join Date: Feb 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by BCollins521 View Post
My screen shot was when I specified a custom folder in theme builder but when you load the theme on the phone the stock folder (one with the icons) are shown for the folders you have to physically change them when you want them to the icon to match the theme
The default folders for Applications, Setup, Games and Downloads are no longer available to me when I specify a custom folder in Theme Builder. I've tried renaming them, but it doesn't make a difference. Good thing I prefer my own folder icons.

Could it be that the some carriers lock those icons? I have a AT&T and a T-Mobile device, but I'm not sure how Verizon, Sprint and the others handle it.

ETA: Could it be the theme type? I always create custom, but I'll have check the icon behavior when I create a Zen theme.

Last edited by SkyMerc : 09-08-2009 at 10:31 PM.
Offline  
Old 09-09-2009, 05:26 AM   #38 (permalink)
Magic Bananas
 
ifonline's Avatar
 
Join Date: Jan 2006
Location: Braselton, Georgia
Model: iP4S
OS: 5.1
Carrier: Verizon
Posts: 2,350
Post Thanks: 1
Thanked 54 Times in 45 Posts
Default

Quote:
Originally Posted by BCollins521 View Post
That's what I said all along was to change the icon yourself from the phone...
No, this doesn't work for me. And it's pretty clear that it is possible to install a custom theme that has the built-in folder icons intact without the end user having to do anything.
__________________
Ian

Semper Fi 3/2/2
"Wow" is now overused. Therefore, I will use "Magic bananas" instead.
Offline  
Old 09-09-2009, 10:23 AM   #39 (permalink)
Magic Bananas
 
ifonline's Avatar
 
Join Date: Jan 2006
Location: Braselton, Georgia
Model: iP4S
OS: 5.1
Carrier: Verizon
Posts: 2,350
Post Thanks: 1
Thanked 54 Times in 45 Posts
Default

Quote:
Originally Posted by weisguy View Post
3) Back in the theme: Right-click on the "Theme the Application Icons Screen" tab itself, directly under "Inspector" hit "Reset Section to Default." Reload to Blackberry: Success! I *did* lose all my work on just this tab, but it was better than starting from scratch.
Ding ding ding! We may have a winner here! I created a blank theme, and the first thing I did was "Reset Section to Default" as described above. I loaded that into the simulator, and presto! The folders are correct.

So, now to see how far I can change things before it all breaks, but so far so good. Thanks!
__________________
Ian

Semper Fi 3/2/2
"Wow" is now overused. Therefore, I will use "Magic bananas" instead.
Offline  
Old 09-09-2009, 10:54 AM   #40 (permalink)
New Member
 
weisguy's Avatar
 
Join Date: Jan 2008
Model: 9630
PIN: N/A
Carrier: Verizon
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Couple bits of data to help you: I was able to change the background image and the font without blowing away the folders in question.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.