BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   OS 6 (http://www.blackberryforums.com/os-6/)
-   -   Attachments invisible in some HTML emails (http://www.blackberryforums.com/os-6/250755-attachments-invisible-some-html-emails.html)

pshute 06-29-2011 09:37 PM

Attachments invisible in some HTML emails
 
I've received an email with an attachment, and my 9780 running OS6.0.0.448 doesn't even recognise that the attachment is there.

I can see it if I choose the "Get Plain Text" option.

I can forward the email from my phone, and the recipient can see the attachment in Outlook.

If I forward it as is from Outlook, 9780 recipients still can't see it. Same thing if I delete the attachment and add another one of a different type.

If I forward it from Outlook after converting from HTML to plain text, 9780 recipients can see it.

It doesn't seem to be the type of attachment that's doing it, but the format of the original email. I've no idea what the sender used to create it, but I see this line in the headers:
Content-Type: application/ms-tnef; name="winmail.dat"

Has anyone seen this behaviour? Anything that can be done?

I posted this here because I'm assuming it's an OS6 problem. I have seen similar behaviour on a Bold 9000 with OS4.6, but only rarely. With these 9780s we've just rolled out (70 of them), I'm getting complaints every day.

nobody7290 07-02-2011 09:02 AM

Re: Attachments invisible in some HTML emails
 
do a search in google for "annoynance winmail.dat", then, you will know.

This ist most likely the result of a misconfigured Exchange config or a wrong address book entry in outlook of the sender.

Nothing special regarding the Blackberry.

pshute 07-03-2011 06:56 AM

Re: Attachments invisible in some HTML emails
 
Quote:

Originally Posted by nobody7290 (Post 1730684)
do a search in google for "annoynance winmail.dat", then, you will know.

This ist most likely the result of a misconfigured Exchange config or a wrong address book entry in outlook of the sender.

Nothing special regarding the Blackberry.

You're suggesting the sender is using Rich Text format? I did suspect it was to do with that, but it doesn't seem like the same problem.

There is no attachment called winmail.dat that I can see, and unlike those seeing a winmail.dat file, we can read the message on a Blackberry, and can see the attachments too if we change to text view. Outlook has no problem reading the emails or the attachments.

While it may be true that the problem is a funny format being used by the sender, I fee that the Blackberry ought to be able to handle it. If the email really is in a winmail.dat attachment, then perhaps the Blackberry is doing well to open it, but has stopped short of being able to show attachments hidden within the file.

nobody7290 07-03-2011 07:13 AM

Re: Attachments invisible in some HTML emails
 
What mime-type is the message and the attachment ? Can you post some of the source of the mail ?

I know that, when I create an email, starting with plain text on my mac, and then copy and paste something from a website into the mail, and then send that to myself (appple mail->exchange->BES->blackberry), that the Blackberry will only show the lines, I originally wrote, but not the part which I copied and pasted from the web-site content.
However, I never had problems with attachments.

I is not possible by chance, that the attachment is part of the html mail, like an inline picture inside a signature, which maybe is not displayed until you load the images ?

nobody7290 07-05-2011 04:41 AM

Re: Attachments invisible in some HTML emails
 
look,
i found this:
KB03820-A winmail.dat file is attached to a received email message instead of the original attachment

doesnt that match perfect to your description of the problem ?
Are you on a BES or on BIS ?

pshute 07-06-2011 08:57 AM

Re: Attachments invisible in some HTML emails
 
Quote:

Originally Posted by nobody7290 (Post 1731165)
look,
i found this:
KB03820-A winmail.dat file is attached to a received email message instead of the original attachment

doesnt that match perfect to your description of the problem ?
Are you on a BES or on BIS ?

No, it doesn't match the problem at all. At no stage do I actually see an attachment called winmail.dat, although the headers (obtained using Outlook) indicate there might be one.

The symptom on the Blackberry is that there appear to be no attachments at all, but if I use the "Get Plain Text" option, suddenly they're there. Thjey're pdf files, in this particular case, not winmail.dat.

The received email looks fine in Outlook.

pshute 07-06-2011 09:10 AM

Re: Attachments invisible in some HTML emails
 
Quote:

Originally Posted by nobody7290 (Post 1730808)
What mime-type is the message and the attachment ? Can you post some of the source of the mail ?

I know that, when I create an email, starting with plain text on my mac, and then copy and paste something from a website into the mail, and then send that to myself (appple mail->exchange->BES->blackberry), that the Blackberry will only show the lines, I originally wrote, but not the part which I copied and pasted from the web-site content.
However, I never had problems with attachments.

I is not possible by chance, that the attachment is part of the html mail, like an inline picture inside a signature, which maybe is not displayed until you load the images ?

I think the idea to forward an example is the best yet. How do I do that?

nobody7290 07-06-2011 09:13 AM

Quote:

Originally Posted by pshute (Post 1731365)
I think the idea to forward an example is the best yet. How do I do that?

You could clean the header from private information, and then, post it here.
Posted via BlackBerryForums.com Mobile


All times are GMT -5. The time now is 06:09 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.