BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/index.php)
-   GPS & Mapping (http://www.blackberryforums.com/forumdisplay.php?f=80)
-   -   Pearl GPS help (http://www.blackberryforums.com/showthread.php?t=157044)

j_p36 10-29-2008 02:09 PM

Pearl GPS help
 
Hi I'm new to the forums, but I have a problem that's been bothering me lately. When I got my pearl one of the first things I did was figure out the GPS. I used BB maps and got it to work. I also downloaded Google maps and got it to work. But for the past few months every time I try to use my GPS or if I tell a friend with a blackberry how to use their GPS the same thing happens. I use BB maps and click "Start GPS navigation", then I get a message saying "Unable to acquire GPS lock". After that, any more attempts to get BB maps to find a GPS signal results in me exiting the program after it has been sitting in my dash for 15 minutes saying "Searching for satellites".

-I do have the GPS turned on via OPTIONS>ADVANCED OPTIONS>GPS> GPS data source is set to Device GPS and GPS services are set to Location on. These are the only options.
-Every time I've told it to start GPS navigation I have been outside with a clear sky.
-Google maps just says waiting for GPS signal (and before I upgraded to the newer Google maps I could only get the GPS to work by making BB maps find the satellites then opening Google maps).
-I've spoken on the phone with and emailed my carrier (cellular south) and no one knows anything about them blocking the GPS. They just say that the pearl just has a weak transceiver and suggest I stand in a open area at least 10 minutes.
-I have tried various combinations of resetting the phone and turning on and off the GPS with no luck.
-The last time I tried it I: turned the GPS to location off; reset the phone via softreset; walked outside; turned the GPS to location on; opened BB maps; clicked start GPS navigation. Within 1 second it popped up and said "unable to acquire GPS lock.

Very sorry for the long post, I just wanted to make sure I explained the problem and how I've tried to fix it. Thanks in advance to all who offer advice.

Redflea 10-29-2008 04:01 PM

Someone else who's used the internal GPS on their Pearl will have to chime in on how weak or not it is.

However, If you haven't made any other significant changes (e.g., new OS) it sounds like you may have a HW issue...could be your GPS just isn't working. Have you discussed an exchange with Cellular South? You should be under warranty if you're less than a year w/your Pearl.

j_p36 10-29-2008 04:25 PM

Nope, haven't updated the OS or anything yet. And no, haven't really discussed the exchange. They have this return policy where you pay 15 dollars and get a new phone, but the phone is sent to RIM and if they don't find anything wrong with it then I pay full out of contract price for the phone I received to replace it. (i.e. way more money than I want to spend right now...)

It is possible that it is just my phone, but not a single one of my friends with blackberries (4 or 5) on this network have gotten their GPS to work. Granted though they have only tried once or twice. Is there any way I could test whether it was just my phone acting up or whether Cellular South changed something on there network preventing it from working?

On a side note is the 8130 Pearl A-GPS? or regular GPS? would that make a difference here?

Redflea 10-29-2008 08:30 PM

This sounds pretty nutty...if they sold you a phone w/a feature that is supposed to work, they should make it work, or give you a new phone.

I'd go into a Sprint store and tell them to show you how to make the GPS work. If they can't make it work either, you should get them to document that in your record and get a Pearl where the GPS does work.

j_p36 10-30-2008 10:58 AM

I guess that's the only thing left to try. I'll get to that whenever I get a little time off from work. Thanks for the replies.

Redflea 10-30-2008 11:48 AM

Good luck...

j_p36 10-31-2008 08:55 AM

hmmm. so i upgraded to 4.5.0.77 last night (from 4.3 something) and I tried the GPS on the way to work this morning and it worked... maybe its not just toying with me and will actually continue to work.

Redflea 10-31-2008 01:30 PM

4.5.0.89 is also available (in the sticky threads at the top of the 8130 forum) - there is the "if it ain't broke" rule, but if you have any issues w/.77, .89 is available as well.

.89's most significant contribution, for me, is adding support for media cards >8 GB - I have a 16 GB card on the way to me, and needed .89 to use that.

j_p36 10-31-2008 01:51 PM

thanks, I'll keep that in mind. do you know if it matters whether or not I leave the "location on" setting turned on all the time? should i turn it on only when needed?

Redflea 10-31-2008 05:36 PM

I leave it on all the time...not sure what you mean by whether it matters or not.

I think it would be a pain to have to keep turning it on and off....

j_p36 11-01-2008 01:27 AM

yeah I think I'll just leave it on for now

funkym 11-02-2008 08:45 PM

I am using my Pearl with a Holux GR.231 Bluetooth GPS dongle and the following software:

They all work fine with my Pearl :)


All times are GMT -5. The time now is 07:15 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.