BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/index.php)
-   General 9500 Series Discussion - Storm (http://www.blackberryforums.com/forumdisplay.php?f=122)
-   -   BB Storm2 Wifi issue (http://www.blackberryforums.com/showthread.php?t=235901)

Codizzle 09-13-2010 05:39 PM

BB Storm2 Wifi issue
 
Hello,

I recently got the BB Storm2. I have a wireless network in my home (Linksys wrt54gs running dd-wrt sp-2 for firmware). When I try to connect to my home network on my BB Storm2 it will connect but comes up with an error saying that it was unable to obtain an IP address even though when I look at my routers web interface I can see the BB Storm2 as a DHCP client with an IP address assigned (as seen in this screenshot outlined in red "Wouldn't let me post link"). Also, even when I manually assign all of the net info into the wifi profile in my BB Storm2 it says "connection terminated" when trying to connect instead of "Unable to obtain Ip address". I do not have another mobile device to test this with but I do have a laptop and a desktop that are both able to connect and obtain IP addresses/have internet access wirelessly. Also, it doesn't matter what IP address I manually assign it contained in my IP address block (192.168.1.5 - 192.168.1.55) It still does not work. Any help would be much appreciated. Thanks.

Codizzle 09-13-2010 05:39 PM

The screenshot "h-t-t-p://img10.imageshack.us/f/69369953.jpg". Of course remove the dashes between http.

Dubdub 09-13-2010 05:48 PM

Moved to the 9500 section

Codizzle 09-14-2010 04:52 PM

Updated on this issue. I tried connecting to the wifi network at my girlfriends which uses a completely different set up than my own (Netgear with default firmware) and I got the same error: "Failed to obtain an IP address". So apparently I am unable to use any wifi networks on my storm2. I find it hard to believe that no one else is having this problem. My storm is using the v5.0.0.713 (Bundle 1206, Platform 4.2.0.323) OS. Any help will be appreciated. Thanks.

Codizzle 09-16-2010 05:05 PM

Well thank all if you for the overwhelming help I received. I have however fixed this issue on my own. I reverted my blackberries OS from "5.0.0.713, Software Platform: 4.2.0.323" to "5.0.0.1020, Software Platform: 4.2.0.275" and I am now able to connect to any wifi network. If you are unable to connect to any wifi network with your storm2 that is running the 5.0.0.713 OS you should try downgrading to 5.0.0.1020. I am glad that I am able to contribute to the community. Thanks.

utgolf 09-17-2010 09:34 AM

I had the same issue and had to change the OS too, sorry I didn't see this post sooner.


All times are GMT -5. The time now is 03:30 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.