BlackBerry Forums Support Community

BlackBerry Forums Support Community (
-   Aftermarket Software (
-   -   Pocket Day Stocks Not Working (

Bridgeman 11-09-2005 02:56 PM

Pocket Day Stocks Not Working
Hey everyone, I've ready high and low trying to find the answer to my problem, but could not find it and have tried just about anything. I'm hoping Mark can help me with pocketday.... I currently have the TMobile 7100T and installed the newest version of pocketday professional today. I have BB 4.0.02 software installed on my BB. The weather is working fine, but for some reason, I can't get the stocks to show up at all. All it's doing is saying no data: What am I doing wrong? I have my APN set as

Inside communication: i have my internet connection as direct and everything else left blank.... Someone help me.....


Bridgeman 11-09-2005 03:08 PM

I just checked as well, and it doesn't look like my weather is allowing me to switch between locations either. So, that's my problem in a nutshell...

Dusty Saddle 11-09-2005 04:03 PM


Originally Posted by Bridgeman
I just checked as well, and it doesn't look like my weather is allowing me to switch between locations either. So, that's my problem in a nutshell...

Go to Options, Firewall and Reset Settings. Then take out and replace the battery. This has worked when I have had this problem on my 7250.

Bridgeman 11-09-2005 04:05 PM

Ok, I noticed that I couldn't switch between my two locations for weather, so I changed my settings to the following Default>Wap selected>>correct port and IP address...... that allows me to change my weather, but the stock still shows up as *empty* If I change my settings any other way, I can't change the location of my weather?????

Bridgeman 11-09-2005 05:30 PM


I've tried that several times and it still doesn't work....... Any other suggestions? I've tried it 3 time consecutively, and nothing.....

crs 11-09-2005 06:51 PM

Now that you switched to WAP, reset your firewall.

CyberJack 11-10-2005 12:44 PM

Do you have any other suggestions. I have been using this since March and no issues and now my Stocks will not refresh either and all I see is **Empty**. I have reset the firewall settings as you suggested and that has not corrected anything. I have NO issues with the Weather however it just updated fine. My stocks refresh does show the time it updates but no content. Any help greatly appreciated... (Registered Version)

crs 11-10-2005 02:57 PM

CyberJack...who is your cell carrier and are you a corporate BB user? What PocketDay communications settings do you have?

CyberJack 11-10-2005 09:26 PM

My carrier is T Mobile, I have BES throught a hosted service, I have my APN, Port 9201 and this is the way I have been setup without anychanges. Thanks

WNO 11-10-2005 09:36 PM

For what it's worth, my stocks are also showing up as *Empty* since upgrading to 2.71. I haven't done a thorough troubleshooting yet, but have shut down and restarted PD, and have rebooted the BB a couple of times as well. Have also tried different stocks, and different numbers of stocks per line. I was thinking about uninstalling/reinstalling PD, but currently don't have access to the archived e-mail that contains my registration key.

My communication settings appear to be fine -- RSS and weather updates are working well, and the stock section shows the time of the last update. TMO; no BES; default internet connection; WAP connection.

Wasn't going to write in until I had tried the reinstall, since I've been experiencing at least one other bit of unexpected quirkiness, but I figured I'd might as well hitch my wagon to CyberJack and his apparently identical problem.

CyberJack 11-10-2005 09:52 PM

With earning announcements, and some interest in some particular activity today it was a bigger deal than normal. Now that I am home I have checked some settings further. My browser goes directly to without a hitch so no issues with host resolution. I clearly see the arrows going in both directions when I request a refresh and the time, as I said earlier, of the refresh looks fine and updates correctly. No error messages at all. After doing the reset of the firewall and reloading the first time, I initially see No Data before it refreshes and then just says **EMPTY**. I have also removed and reentered the ticker symbols, tried different ticket symbols all to no avail. I too am using 2.71 but have had no issue until this morning. I know when I went to bed here on the Left Coast everything was normal.


crs 11-11-2005 08:44 AM

All very strange...I have a TMO device right in front of me running the stock 2.71 version.

WNO...can you try this: Go to Home / Options / TCP. Put in the APN field and save this. Then in the PocketDay communications settings set the Connection to Direct and disable WAP.

CyberJack 11-11-2005 10:57 AM

Not trying to be impatient, not ungrateful, but since I am running the WAP version and can not switch to direct, any ideas on what I might try to do?? I just have no idea what changed, as this had been running fine since I had upgraded and then just stopped working and I made no changes....

crs 11-11-2005 11:11 AM

I seem to be hacing the same issue...T-Mobile may have changed something over the last few days. I'm still testing this...

Can you check if you have a service book IPPP for BIS entry?

CyberJack 11-11-2005 11:28 AM

I have IPPP for BIBS [IPPP], Desktop IPP, EMail Setup [IPPP] but do do not see one labeled specifically BIS. Thanks

Bridgeman 11-11-2005 11:33 AM

hey guys... My phones still doing the same things. It'e weird. Mark have you heard anything regarding if TMobile has done something different? I've tried reseting my firewall, then doing a hard shut down. I've tried changing the phone to direct and nothing at all works.

Bridgeman 11-11-2005 11:34 AM

I don't use the BB enterprise server, I just use the normal webclient or push service... Whatever it's called when you handl everything from Tmobiles website.

crs 11-11-2005 01:29 PM

I have contiinued to test this and have found that the WAP gateway from t-mobile is working properly and I am running 2.71 as well. Can everyone check to make sure that t-mobile hasn't pushed a new WAP gateway to their device.

Here are the instructions to get the apn, gateway and port from your device
settings. After getting these, you go to PocketDay Settings/Communications,
set the internet connection to Default, Enable WAP and set the apn, gateway
and port. Leave the username and password blank.

1.. From your BlackBerry's home screen, select the Options application.
2.. Highlight the entry for Service Book and open it by clicking the
3.. If there is an entry labeled "WAP Transport", highlight the entry,
click the trackwheel, and select View. If there is no "WAP Transport" entry,
you will need to contact your mobile operator to obtain your WAP settings.
4.. Click the trackwheel and select Show HRT.
5.. Click the trackwheel and select View.
6.. If your device uses GPRS, there should be a line beginning with
"APN:". The remaining text on that line is your GPRS APN that you will need
to enter in PocketDay.
7.. Obtain your WAP gateway IP address and port from the "IP/Ports:"
entry. The WAP gateway IP address is composed of everything before the first
colon (":"). The WAP gateway port is the number following the first colon.
For example, if the "IP/Ports:" entry is "", then
your WAP gateway IP address is, and your WAP gateway port is

CyberJack 11-11-2005 04:11 PM

I am confused. Why would the weather work fine if there was a problem with my WAP settings and not the stocks? (I dread calling T-Mobile because they are never very helpful and it will turn into a 2 hour call.) But I will try and call T-Mobile shortly.

I do not have a WAP Transport Service Book.

CyberJack 11-11-2005 04:44 PM

OK... I have called T-Mobile and had to scream and holler for them to give me WAP Gateway Port but the information coincides with what I have in PD currently. GPRS APN: and WAP Gateway Port 9201. The also said I could try 8080, which I did and nothing changed. Of course in PD I am not seeing a place to enter the GPRS APN. Thanks for the help.

All times are GMT -5. The time now is 06:32 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.