BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   RIM Software (http://www.blackberryforums.com/rim-software/)
-   -   How to enable HTML email on your BlackBerry (http://www.blackberryforums.com/rim-software/137798-how-enable-html-email-your-blackberry.html)

JSanders 07-01-2008 12:53 AM

How to enable HTML email on your BlackBerry
 
If you are looking to get HTML email on your Blackberry, here are the requirements and process.



A) Your BB device must have Operating System version 4.5 loaded to your device. OS 4.5 is not officially released for ALL BB models yet. Those officially released are listed in our specific model sections here on these Forums in the Sticky Notes at the top of each model section. BlackBerry Device Specific - BlackBerryForums.com : Your Number One BlackBerry Community Check your current OS version on your BlackBerry at Options > About. Look at the third line down, starting with "v.4..."

If you don't find OS 4.5 for your model listed, please don't ask for outside links to not-yet-released OS versions. The latest OS versions are always listed on this forum.

Upgrade instructions for any model are simple:
  1. Download the new OS you want and install it to the PC
  2. Delete the vendor.xml file located in c:\program files\common files\research in motion\apploader
  3. Plug in BB and open Desktop Manager
  4. Select Application Loader
  5. You will be prompted to upgrade
B) Enable BIS 2.5 - From your BlackBerry, or PC, go to your carrier BIS site and resend your Service Books.
  1. Log into your providers BIS site from your handheld (see your personal email setup icon) or from your PC.
  2. Click the link to resend the service books.
You should receive a new Registration message to your device if the Service Books were sent successfully.

C. Configure your email now for HTML.
  1. On your BlackBerry, to go the Messages folder.
  2. Click the Menu key (left of trackball)
  3. Click Options
  4. Click Email Settings
  5. *Enable HTML Email = YES.
  6. *Download Images Automatically = Yes


*If you don't see these options, it is likely that your service books have not been updated. You may need to do a "hard reset" on your BlackBerry by removing the battery from the device with it powered ON, hold a few seconds, and replace the battery to reboot.

D. Receive an email on your device, and enjoy HTML.
  1. After opening your email, tap the Menu key and select "Get Images".
  2. Click YES to the warning message that "internet images can expose your address"...
  3. You will need to click "Get Images" on each email on which you wish to view images.
*Emails received before your upgrade will not be viewable in HTML, only those received after.

NOTE: Some users have reported the HTML images would not appear until they had their TCP/APN settings enabled. On your BlackBerry, look at Options > Advanced > TCP. If the settings are blank, follow the instructions in this link to set yours and save the settings. You may need to remove the battery on your BB and reboot after entering the APN, etc., in order for it work.



**Further Note: If you have performed all of the above instructions, and still don't see HTML email options on your mail,
OR, your HTML email has worked, and stopped working, try this:
1. Remove your email account from the BIS. Where can I log into my BIS account? - BlackBerryFAQ
2. Delete your Service Books on the BB. (Options > Advanced > Service Books) Delete those pertaining to your email containing the @ symbol and your email address.
3. Remove battery and reboot the BB.
4. Confirm the Service Books are not on the BB.
5. Reset the account on your BIS.
6. Resend the Service Books from your BIS.
7. You should get a Registration message from AT&T, on your BB. If not soon, pull the battery and reboot the BB again.
8. Turn on your HTML email again from you Message options.

rboy 07-01-2008 01:09 AM

is there a way to get the images to show without clicking on get images? kind of like bbsmart does.

John Clark 07-01-2008 01:13 AM

No, images must be allowed on a per email basis.

maish 07-01-2008 06:35 AM

regarding checking which BIS my carrier is running -

under options > about

I see ( Platform 2.7.0.55)does that relate to BIS 2.5 ( or in this case 2.7) ?

Ophidian 07-01-2008 07:16 AM

I'm still having trouble getting the pictures to show up.

I am able to receive html text, but when I click on Get Images>Download Images Can Expose Your Internet Address>Yes. I see the blue arrows in the top right corner indicate that I am sending/receiving info, but the pics never show up.

I am running 4.5.0.42 with an 8300 on T-Mob

penguin3107 07-01-2008 07:17 AM

Quote:

Originally Posted by maish (Post 995413)
regarding checking which BIS my carrier is running -

under options > about

I see ( Platform 2.7.0.55)does that relate to BIS 2.5 ( or in this case 2.7) ?

You can't see what version of BIS your carrier is running.

What you're looking at is the version of software on your device.

tdawg00 07-01-2008 07:22 AM

Quote:

Originally Posted by Ophidian (Post 995446)
I'm still having trouble getting the pictures to show up.

I am able to receive html text, but when I click on Get Images>Download Images Can Expose Your Internet Address>Yes. I see the blue arrows in the top right corner indicate that I am sending/receiving info, but the pics never show up.

I am running 4.5.0.42 with an 8300 on T-Mob

enter wap.voicestream.com under option>advance options< tcp. Where it says APN thats where you need to put that address

Ophidian 07-01-2008 07:25 AM

Quote:

Originally Posted by tdawg00 (Post 995456)
enter wap.voicestream.com under option>advance options< tcp. Where it says APN thats where you need to put that address

Been there done that...

All other data functions work properly. I just can't get the pics. Since the arrows are flashing, I'm assuming that the pics are going somewhere(?)

Thanks for the suggestion though

mettleh3d 07-01-2008 12:48 PM

Quote:

Originally Posted by John Clark (Post 995261)
No, images must be allowed on a per email basis.

Why is that? I hope there's a future update that allows for automatic downloading - even if this is a security feature, it should be on the users end to decide whether or not to utilize it.

hdawg 07-01-2008 12:54 PM

Quote:

Originally Posted by mettleh3d (Post 995956)
Why is that? I hope there's a future update that allows for automatic downloading - even if this is a security feature, it should be on the users end to decide whether or not to utilize it.

Just how RIM decided to do it for now.

I couldn't agree with you more and have submitted a request to have that feature / function in a future version. (y)

MisterEd 07-01-2008 05:23 PM

I don't have the menu option for HTML on my 4.5 8310 Curve. But I did update my service books earlier today and I'm getting HTML messages with no problems. Even animated gifs are working. The weird things with the animated gifs is that they "animate" for about 10 seconds then stop. They don't seem to repeat themselves.

MisterEd 07-01-2008 05:30 PM

Weird. Not on my 4.5 BB 8310. All my images are there without any prompting. I just tested JPEGS, GIFS, BMP's .... all there without being prompted.

Quote:

Originally Posted by John Clark (Post 995261)
No, images must be allowed on a per email basis.


MisterEd 07-01-2008 05:41 PM

OK, to take this one step further I just resent service books AGAIN. Now I DO have the HTML option (even though it worked before without the HTML option in the menu).

I still am ABLE to get images without "allowing them" on a per message basis. They are downloaded with the email.

kirbo20 07-01-2008 09:15 PM

HTML email is no longer working for me. I have the option there but its not coming in anymore as HTML. I have resent service books I have also tried deleting and re-adding the email account but it wont work anymore. SAD :cry: Any suggestions?

Edit: working now dont know why.

WillJitsu 07-01-2008 11:37 PM

Does anyone know if Sprint's BIS was updated to 2.5?

John Clark 07-01-2008 11:38 PM

Yes.

kjdoug 07-02-2008 08:24 AM

darn
 
i did all that and still don't get the images...i get a picture of a minature blackberry without the pics..

JSanders 07-02-2008 08:27 AM

What OS does your handheld have loaded to it? Options > About?

If you get a picture of a BlackBerry... you're getting at least one image.

kjdoug 07-02-2008 08:29 AM

Os
 
It's 4.5.0.42...but it's not really a picture of a blackberry...it's like on windows and there is a little x in the corner and you have to choose show pics...

JSanders 07-02-2008 08:44 AM

Do you have the options as stated in C) and D) above in the instructions?


All times are GMT -5. The time now is 08:14 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.