BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-12-2008, 03:14 AM   #1 (permalink)
New Member
 
Join Date: Dec 2008
Model: 9000
PIN: N/A
Carrier: Maxis
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Redirector Headaches

Please Login to Remove!

All,

I am at the end of my tether with this redirector. Does it actually work? Let me explain my environment first. I am using Outlook 2007 configured for exchange 2003 using mapi on an XP sp3 envirnoment. I work remote from my office and connect via a nokia Secure connector VPN client.

My first attempt at using this resulted in the pending to device queue just getting higher and higher. I never receive a message. I then found that although I am connected to the internet, because all my internet traffic is being passed accross the VPN, I am being restricted by IT policy and probably not allowed to make outbound connection on port 3101. To fix this I added some static routes to route redirector traffic direct to the internet to my pc for the two subnets that blackberry appear to use that is (206.51.26.0/204.187.87.0) this is based on the mx records for etp.us.blackberry.net.

Since doing this, some messages manage to get through but most don't. The queue just keeps on growing.

I have monitored the redirector activity using tcpview and i never see it try to connect to anything other than my exchange server which it can. I never see it try to redirect messages out to the internet. Is my under standing of how this process works wrong and my routes are doing nothing?

Can anyone explain exactly what the redirector does?

Regards
Offline  
Old 12-12-2008, 09:35 PM   #2 (permalink)
New Member
 
Join Date: Dec 2008
Model: pearl
PIN: N/A
Carrier: verizon
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am having a very similar problem and I am posting again hoping someone will help. My "pending to device" number grows and grows. About 10 messages come through and then they stop. If I purge the pending it will start to send them again, but only until the pending to device number gets to around ten again. It's making me crazy. Redirector worked for months and month. I've tried everything, I re-installed and upgraded the software AGAIN today. Same thing.
Offline  
Old 12-16-2008, 11:29 AM   #3 (permalink)
New Member
 
Join Date: Dec 2008
Model: 9000
PIN: N/A
Carrier: Maxis
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi all,

I managed to solve my issue and as it turns out has nothing to do with conectivity. I was hunting and hunting for information on how the redirector works and could not find anything conclusive, only that i needed to be able to establish a connection on port 3101. Please correct me if I'm wrong but i have found this to be not true. In fact the connector needs no more connectivity to your exchange server than your outlook client. It doesn't try to establish a connection to the outside world from what i can see. It simply works by encrypting messages and then sending them to blackberry to be passed to you. Your device then sends a response back to blackberry which intern send you an encrypted email. The redirector picks up the response and thats it. maybe I was confusing the requirments with BES but anyhow maybe someone can benefit from this brief explanation.

By the way my problem went away after i marked about 400 unread messages in my in box to read!

Cheers
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.