BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-19-2009, 08:24 AM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2006
Model: 9700
Carrier: T-Mobile
Posts: 50
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default update BB8900 software from .231 to .315

Please Login to Remove!

I have been using BB's for many years and have updated the handheld software many times. I've been trying to update my wifes BB 8900 from .231 to .315 or .348 and the DM on 2 different systems will not work. Both DM show the different versions available and they will come up with the notification that an update needs to be done. But, as soon as I select to update, DM checks the phone and decides that no update is required. I've wiped the phone did a manual uninstall of DM and reinstall, just can't seem to figure out what I'm doing wrong or missing. Any ideas?
Offline  
Old 12-19-2009, 11:59 AM   #2 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: BBPP
OS: 10.3.0
Carrier: T-Mobile USA
Posts: 13,766
Post Thanks: 16
Thanked 504 Times in 490 Posts
Default

Sounds like you are installing the OS version provided by your carrier, using the DM auto-update feature, correct?

What happens if you download and install the device software from the carrier and then try DM, or just use loader.exe instead?

That won't answer DM problem, of course, but it may get you where you want to be.
__________________
- Ira
Offline  
Old 12-19-2009, 12:02 PM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2006
Model: 9700
Carrier: T-Mobile
Posts: 50
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by aiharkness View Post
Sounds like you are installing the OS version provided by your carrier, using the DM auto-update feature, correct?

What happens if you download and install the device software from the carrier and then try DM, or just use loader.exe instead?

That won't answer DM problem, of course, but it may get you where you want to be.
i actually downloaded the .315 version, installed it on my PC, deleted the vendor.xml file and then opened the DM to do the update. Should I just go out to the directory and launch "loader.exe'? The .231 version on the phone was recieved by TMO - I just want to update this phone to .315 because I know the battery time is better based on experience previously with a different 8900.
Offline  
Old 12-19-2009, 12:42 PM   #4 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: BBPP
OS: 10.3.0
Carrier: T-Mobile USA
Posts: 13,766
Post Thanks: 16
Thanked 504 Times in 490 Posts
Default

Wirelessly posted (8820)

There is a stickied post (by John Clark) about what to do when the OS won't update even after you delete vendor.xml. If you have the newer DM and autoupdate enabled, it creates another vendor.xml. Find his post and see if that's what has happened to you.
__________________
- Ira
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.