BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-02-2005, 03:40 PM   #1 (permalink)
Talking BlackBerry Encyclopedia
 
jeremy's Avatar
 
Join Date: Sep 2004
Location: US
Model: 8900
Carrier: AT&T
Posts: 276
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Pictures app broken on 7100g

Please Login to Remove!

I have a 7100g with a broken pictures app. When you go into pictures, it shows the names, dates and sizes of all the pictures, but the preview just shows a red "x" like you see in IE when a picture cannot be loaded.

If I try to open a picture, i get this messages: "Cannot open DRM content." Great. :( So I cannot set the home screen image.

Any ideas? Is this DRM as in digital rights management?
Offline  
Old 03-02-2005, 04:08 PM   #2 (permalink)
Retired BBF Moderator
 
Mark Rejhon's Avatar
 
Join Date: Aug 2004
Location: Ottawa, Ontario, Canada
Model: Bold
Carrier: Rogers
Posts: 4,870
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

I think so. This might occur if you load pictures from a another carrier's BlackBerryOS -- causing a carrier conflict for DRM.

However, if you didn't do anything, this could be a bug. Are you able to download and save new photos from the web browser and email attachments?
__________________
Thanks,
Mark Rejhon
Author of XMPP extension XEP-0301:
www.xmpp.org/extensions/xep-0301.html - specification
www.realjabber.org - open source
Offline  
Old 03-02-2005, 04:41 PM   #3 (permalink)
Talking BlackBerry Encyclopedia
 
jeremy's Avatar
 
Join Date: Sep 2004
Location: US
Model: 8900
Carrier: AT&T
Posts: 276
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here is what I did: I was moving to a new 7100g. Same carrier, same model, same branding. I backed up the first one, wiped it, moved the SIM to the new one and restored the data.

One thing worth noting is that when I cradled the new one, it wanted to update two modules (i forget the names but I think they were certificate related) even though the application and modules versions matched the first device. Also, desktop manager wanted to remove a module called net_rim_er_disable (If I recall correctly). I let it do what it wanted.

I was able to save an image from the web. I can both display it in the pictures app and set it as home screen successfully. The original pics still don't show. If I have to, I will just wipe it but I'm trying to avoid doing that so I don't have to backup since that may restore whatever the problem is.

Quote:
Originally Posted by Mark Rejhon
I think so. This might occur if you load pictures from a another carrier's BlackBerryOS -- causing a carrier conflict for DRM.

However, if you didn't do anything, this could be a bug. Are you able to download and save new photos from the web browser and email attachments?
Offline  
Old 03-14-2005, 02:21 PM   #4 (permalink)
New Member
 
Join Date: Mar 2005
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have this same problem with a 7290 - did a backup from one 7290, restored to a different 7290, updated PIN etc. But all original picture files are broken. Anyone have any ideas? Also on the new device, the Tmobile specific T-Zones and email setup icons are missing.
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.