BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   RIM Software (http://www.blackberryforums.com/rim-software/)
-   -   Error 523 & Java Loader (http://www.blackberryforums.com/rim-software/76461-error-523-java-loader.html)

Adam9999 05-14-2007 05:35 AM

Error 523 & Java Loader
 
Having spent the weekend researching the reasons for my Pearl's crash I have come to the conclusion that Error 523 is generated when a Java module crashes and remains active instead of terminating. In my case it was Mobipocket Reader that was the guilty party though it seems that other apps are capable of producing the same problem.

First the good news - YOU MAY NOT HAVE TO RE-INSTALL THE OS.

Now the bad news, you need to use the command prompt and a piece of software called JavaLoader. First download jl_cmdr (posted below). Un-zip it and open the folder. Identify the file JavaLoader and copy it to the directory that comes up when you type 'command' into the 'run' utility available via the Start menu.

In the Dos-Prompt window (black screen that appeared when you typed 'command') type the following exactly as it appears below:

JavaLoader -USB DIR > DIR.TXT

Follow the screen prompts re passwords etc and, when finished, you will have a text file in the same directory as the JavaLoader app that lists all the modules on your BB.

Look through the list and the dates will identify the most likely culprit (probably the last module that was installed). Next type the following in the Dos-Prompt window:

JavaLoader -USB ERASE -F NAME-OF-MODULE-TO-BE-ERASED

If you are as fortuate as me then your little pal will spring back into life and you can reload the offending app.

Many thanks to all the other members of the forum whose posts got me working again - I hope that the summary above will provide a one-stop-shop for other suffers.

viktorv 06-18-2007 06:15 AM

MMS causing Error 523
 
I have been going through the same pain with my Pearl with every now and then getting an Error 523 "reset" .. Having pulled down the logs from the device, I can see that it appears an MMS was causing this. Reading some threads on forums etc, it appears that some cross carrier MMS's have been know to cause some problems, as such... Once connected, I ran;

C:\Program Files\JL_Cmder>javaloader -u -w erase -f net_rim_bb_mms

The device rebooted itself and is all good again, now I *could* install it again, but seeing as this particular module has done this to me a lot of times now. I will wait till there is new software and try again I expect....

Hope this helps someone as well...

Rojiwadiya dinesh 06-25-2007 01:59 AM

Hi,
Iam using 7100v series handheld,iam gettimg the blankscreen,
I tried the following
C:\Program Files\JL_Cmder>JavaLoader -USB ERASE -F 7100
but it gives error :sad:
Connecting to device...Error: unable to open port

Iam not able to wipe my device,can anybody help me wipe my device

viktorv 07-02-2007 12:57 AM

re:wipe
 
try taking the battery out of the BB device and connect it up to your computer with you USB cable. Then you can go via the BB Desktop Manager and reinstall your device.

Here is a good guide..

RIM Blackberry Forums - Pinstack.com

jhoetzl 07-02-2007 10:42 AM

Helpful hint on this one, as I seem to be getting these more often than I would like.
If the problem is caused by something connectivity related (I get to the security screen and then it pops the app errror 523) add these steps...
  • Remove battery - leave cover off for now
  • Remove the SIM
  • Boot up
  • Disable the "radio"
  • Remove battery
  • Re-insert SIM
  • Replace battery
  • Boot up
  • Put battery cover back on
  • Wait until everything looks finished
  • Enable Radio

Works like a charm for me...

scaevola 07-04-2007 11:32 AM

I seem to get the java error 532 when I leave jivetalk on over night and the machine (set to turn off at 11pm and on at 6am). And when I check it in the morning it has that error displayed and asks me to reset the device. So I'm guessing it's jivetalk, anyone else experienced this? I'm willing to put up with it as I love <3 jive talk, im+ is so slow to boot and consumes my battery like no tomorrow!..

Taxee 12-26-2007 04:29 PM

Quote:

Originally Posted by viktorv (Post 572163)
I have been going through the same pain with my Pearl with every now and then getting an Error 523 "reset" .. Having pulled down the logs from the device, I can see that it appears an MMS was causing this. Reading some threads on forums etc, it appears that some cross carrier MMS's have been know to cause some problems, as such... Once connected, I ran;

C:\Program Files\JL_Cmder>javaloader -u -w erase -f net_rim_bb_mms

The device rebooted itself and is all good again, now I *could* install it again, but seeing as this particular module has done this to me a lot of times now. I will wait till there is new software and try again I expect....

Hope this helps someone as well...

Thank you very much for your help! :smile:

This is the exact issue that I had today with my 8310.

I am actually quite surprised that RIM has done nothing to fix what appears to be a very serious error.

Anyways, I deleted the MMS module and my Curve restarted with no problems (after having repeated app error 523 messages since Christmas eve).

John Clark 12-26-2007 06:15 PM

Glad it worked for you....Welcome to the forums!

Charles Waters 03-15-2008 01:02 AM

Quote:

Originally Posted by viktorv (Post 572163)
I have been going through the same pain with my Pearl with every now and then getting an Error 523 "reset" .. Having pulled down the logs from the device, I can see that it appears an MMS was causing this. Reading some threads on forums etc, it appears that some cross carrier MMS's have been know to cause some problems, as such... Once connected, I ran;

C:\Program Files\JL_Cmder>javaloader -u -w erase -f net_rim_bb_mms

The device rebooted itself and is all good again, now I *could* install it again, but seeing as this particular module has done this to me a lot of times now. I will wait till there is new software and try again I expect....

Hope this helps someone as well...

Worked like a charm for me!! I was sending MMS pix to a buddy on Verizon Wireless earlier, and about 2 hours later, I got the App Error 523. Did what you said, and works perfect!

alwaysbelieve1 03-29-2008 02:51 PM

Whenever I type in the command prompt: "JavaLoader -USB DIR > DIR.TXT" it comes back to tell me: 'Javaloader' is not recognized as an internal or external command, operable program or batch file

I have it in the same directory as when I type in "command". That is: C:\Users\Bob

I put the JL_Cmder program in that directory and then installed it. I put the shortcut in there too, but no matter what I do nothing happens except it tells me what I stated above.

What else do I need to do? I'm running Windows Vista Home Edition.

Thanks

alwaysbelieve1 03-29-2008 03:38 PM

nevermind... I was not using Javaloader, but instead JL_Cmdr. Anyway it still comes back with the "error to open port" problem.

I don't want to lose my PIM data. All I want to do one more time is sync cause I have a lot of info unsynced yet. Is there anyway to do that at all?
I have tried with and without battery as well as SIM. Nothing connects.

alwaysbelieve1 03-29-2008 04:10 PM

Ok thank the Lord I was able to run DM 4.3's Apploader and took off all 3rd party apps and it came back up. :)

bbusch 04-24-2008 08:28 PM

Thank You!!!
 
While at work today, my personal 8100 Pearl decided to take [another] crap on me.
I was incredibly upset b/c I hadn't backed up my data in over a month!
Once I got home, I decided to hit up the wonder WWW to search for a solution - other than "reloading the OS".
THANK YOU SO MUCH!!
I was able to delete the "net_rim_bb_mms" module and BOOM!
It booted right back up with no problem!!!!
Woot!!
It's all backed up now, but I honestly think I'm going to look into switch over to AT&T and buy the Tilt.

Take care.

Brandon

Dusan Vip 05-03-2008 09:02 PM

Thanks! Helped a lot. Same thing, thr module-mms, crushed. Fixed now.

essyan 05-27-2008 01:36 AM

hi. i cant find where "net_rim_bb_mms" is located. i realized after sending MMS i got an app error 523. help

essyan 05-27-2008 01:50 AM

help. cant figure out app error 523 n my desktop manager does not recognize my device
 
need help. i just bought 8320 this week. after reading some of the post i remembered i sent MMS then aftr few hours i got the error. i tried the application loader, tried looking for the javaloader but i cant find it. plus my desktop manager does not recognize my device when i plug it.

thanks in advance i know anyone of u can help

mkanik 06-10-2008 03:16 AM

i was getting the Error 523 whenever i receive a MMS. Connected my BB to USB cable during the bootup process typed JavaLoader -USB DIR > DIR.TXT as adviced by Adam9999 and got the installed modules list.. then used

JavaLoader -USB ERASE -F net_rim_plazmic_mediaengine_smil_mms
JavaLoader -USB ERASE -F net_rim_bb_mms

and i am able to use my BB again. Thanks Adam9999

jasontan 06-10-2008 09:49 AM

Error 523 caused by 8300 receiving MMS, JL_Cmder successful!!!
 
I received Error 523 when I forwarded a MMS from my other phone to my Blackberry 8300. JL_Cmder and instructions posted by Adam9999 worked successfully on first try!!!

The moment I deleted "net_rim_bb_mms" the device restarted and booted as normal, and best of all, I had all my data intact!!! YAY!!

Thank you everyone on this community and for JL_cmder!!!

biguns 06-18-2008 10:49 AM

Quote:

Originally Posted by jhoetzl (Post 586400)
Helpful hint on this one, as I seem to be getting these more often than I would like.
If the problem is caused by something connectivity related (I get to the security screen and then it pops the app errror 523) add these steps...
  • Remove battery - leave cover off for now
  • Remove the SIM
  • Boot up
  • Disable the "radio"
  • Remove battery
  • Re-insert SIM
  • Replace battery
  • Boot up
  • Put battery cover back on
  • Wait until everything looks finished
  • Enable Radio

Works like a charm for me...

thanks JHoetzl. this appears to work great. I would try this before the Javaloader. This has happened a few times after installing new apps from the DM. It appears to only happen when I leave the phone connected when it reboots.

orlandojostos 06-20-2008 03:38 PM

Thanks!!
 
Quote:

Originally Posted by Adam9999 (Post 535893)
Having spent the weekend researching the reasons for my Pearl's crash I have come to the conclusion that Error 523 is generated when a Java module crashes and remains active instead of terminating. In my case it was Mobipocket Reader that was the guilty party though it seems that other apps are capable of producing the same problem.

First the good news - YOU MAY NOT HAVE TO RE-INSTALL THE OS.

Now the bad news, you need to use the command prompt and a piece of software called JavaLoader. First download jl_cmdr (posted below). Un-zip it and open the folder. Identify the file JavaLoader and copy it to the directory that comes up when you type 'command' into the 'run' utility available via the Start menu.

In the Dos-Prompt window (black screen that appeared when you typed 'command') type the following exactly as it appears below:

JavaLoader -USB DIR > DIR.TXT

Follow the screen prompts re passwords etc and, when finished, you will have a text file in the same directory as the JavaLoader app that lists all the modules on your BB.

Look through the list and the dates will identify the most likely culprit (probably the last module that was installed). Next type the following in the Dos-Prompt window:

JavaLoader -USB ERASE -F NAME-OF-MODULE-TO-BE-ERASED

If you are as fortuate as me then your little pal will spring back into life and you can reload the offending app.

Many thanks to all the other members of the forum whose posts got me working again - I hope that the summary above will provide a one-stop-shop for other suffers.


It worked perfectly for me!! Thanks once again!!


All times are GMT -5. The time now is 01:18 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.