BlackBerry Forums Support Community
              

Closed Thread
 
Thread Tools
Old 09-11-2009, 01:02 PM   #1
9duc
Thumbs Must Hurt
 
Join Date: Jun 2006
Location: NoVA
Model: 9630
Carrier: Sprint
Posts: 117
Default Question regarding scrolling dock- Plazmic 4.7 bug?

Please Login to Remove!

Hi all, I've been working on a "scrolling dock" theme, and seem to have it working smoothly... I have 12 icons scrolling across the bottom (zen style). Below is a pic of what I have so far:



I am trying to specify in Plazmic that the icons are user definable or customizable, but no matter what I can't seem to get it to export properly. No icons show (only "placeholders") on the home screen.

On the other hand, if I specify the icon order (not user customizable) it works perfectly fine.

Is there something I am missing, or is this another Plazmic bug?

If it makes any difference, I also have the theme set to show a Today preview if the calendar, messages, or SMS/MMS icons are highlighted.

Using Plazmic 4.7, initially for the Tour.

If I can figure this out, I'll be posting the theme (free) along with my others... TIA for any input!

Last edited by 9duc; 09-11-2009 at 01:14 PM..
Offline  
Old 09-11-2009, 04:28 PM   #2
BCollins521
BlackBerry Extraordinaire
 
BCollins521's Avatar
 
Join Date: Sep 2006
Location: OH
Model: 9700
PIN: Ask...
Carrier: T-Mobile
Posts: 2,033
Default

Look in your svg code for "slot" in the coding...that's what shows the applications
__________________
-Brian

Get My Themes Here! | [email address] | Twitter
Offline  
Old 09-12-2009, 03:07 PM   #3
9duc
Thumbs Must Hurt
 
Join Date: Jun 2006
Location: NoVA
Model: 9630
Carrier: Sprint
Posts: 117
Default

Wirelessly posted (9630)

Bcollins, thanks for the reply!!

I searched the svg code for "slot" and it doesn't turn anything up... I'll comb through it manually and see what I can find.

I did most of the svg work in Composer, and only added the code for the scrolling function, so I'm still a bit new to writing the code. Hopefully I can figure it out

Thanks again!
Offline  
Old 09-12-2009, 04:41 PM   #4
BCollins521
BlackBerry Extraordinaire
 
BCollins521's Avatar
 
Join Date: Sep 2006
Location: OH
Model: 9700
PIN: Ask...
Carrier: T-Mobile
Posts: 2,033
Default

To have the icon chose the application order you have to make sure you select the icon in composer and then select the theme button, and then under inspector choose the circle of "Use Device Application Order" and it will use the slot locations for the icons to show
__________________
-Brian

Get My Themes Here! | [email address] | Twitter
Offline  
Old 09-12-2009, 07:56 PM   #5
kurichan
CrackBerry Addict
 
kurichan's Avatar
 
Join Date: Dec 2005
Location: San Diego
Model: 9630
OS: 5.0.0.591
Carrier: Verizon BIS / BES
Posts: 696
Default

Device Application Order has a nasty bug for 4.7 in my experience. I gave up.
__________________
9630 #4 < 9630 #3 < 9630 #2 < 9630 < 9530 (returned) < 8703 < 7250
Offline  
Old 09-14-2009, 02:02 PM   #6
9duc
Thumbs Must Hurt
 
Join Date: Jun 2006
Location: NoVA
Model: 9630
Carrier: Sprint
Posts: 117
Default

Quote:
Originally Posted by BCollins521 View Post
To have the icon chose the application order you have to make sure you select the icon in composer and then select the theme button, and then under inspector choose the circle of "Use Device Application Order" and it will use the slot locations for the icons to show
Thanks again! I've been doing exactly what you specified above... but tried it again thinking I might not have done something correctly.

Still have issues- after I export, either the icon shows but the 'icon underlay' and 'icon glow' don't appear, or no icon shows at all.

Still banging away at it...
Offline  
Old 09-17-2009, 12:55 AM   #7
BCollins521
BlackBerry Extraordinaire
 
BCollins521's Avatar
 
Join Date: Sep 2006
Location: OH
Model: 9700
PIN: Ask...
Carrier: T-Mobile
Posts: 2,033
Default

There is a limit to which the icon itself can handle so if your adding more to the focus/normal images that might be your problem
__________________
-Brian

Get My Themes Here! | [email address] | Twitter
Offline  
Old 10-20-2009, 01:50 PM   #8
9duc
Thumbs Must Hurt
 
Join Date: Jun 2006
Location: NoVA
Model: 9630
Carrier: Sprint
Posts: 117
Default

Thanks for everyone's suggestions... I have everything figured out.

It might just be me, but Composer is waaaay buggy. I basically just had to set up a basic svg, and did most everything else manually in the code.

Anyway, I set up a scrolling dock (12 icons) that can also be hidden. I put in a couple other small additions; it was a challenge for me (no formal html training) to get the animations just right, but it works great.

Anyway, thanks again to all for the help, I'll probably post the theme up for everyone in a bit.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Software guide book manual Amiga Programmer C Language A2000 A500 computer disk
$115.0
Software guide book manual Amiga Programmer C Language A2000 A500 computer disk pictureRADSTONE VME BOARD PME 68-33 MOTOROLA 6800 33Mhz AMIGA PPC SCSI 16MB
$185.0
RADSTONE VME BOARD PME 68-33 MOTOROLA 6800 33Mhz AMIGA PPC SCSI 16MB pictureRADSTONE VME BOARD PME 68-31 MOTOROLA 6800 33Mhz AMIGA PPC Module card SCSI
$185.0
RADSTONE VME BOARD PME 68-31 MOTOROLA 6800 33Mhz AMIGA PPC Module card SCSI pictureRADSTONE VME BOARD PME 68-31 MOTOROLA 6800 33Mhz AMIGA PPC Module card
$185.0
RADSTONE VME BOARD PME 68-31 MOTOROLA 6800 33Mhz AMIGA PPC  Module  card pictureLOT(4)RADSTONE VME BOARD PME 68-33 MOTOROLA 6800 33Mhz AMIGA PPC SCSI 16MB
$675.0
LOT(4)RADSTONE VME BOARD PME 68-33 MOTOROLA 6800 33Mhz AMIGA PPC SCSI 16MB picture






Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.